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1. Introduction and Installation

This manual discusses the operations of the Ametek Fault Recorder suite 
of programs. This is comprised of:

• Display Station 32 and Display Station Analysis 32, which are 
packaged together. Display Station (DS) configures operations and 
Display Station Analysis filters and manipulates results for 
graphical display and analysis.

• An Expert System program for classifying fault data and working 
in concert with several dependant sub-components to filter, 
monitor results and manipulate those results for analysis, 
including:
• Voltage Dips Analysis 32 to analyze the voltage fluctuations 

from recorders.
• Distance to Fault, which uses an impedance model algorithm 

for fault analysis.
• Breaker Performance Monitor (BPM), which records the oper-

ations of switchgear to monitor which breakers are due for 
servicing due to accumulative contact wear.
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Introduction

DS32
Display Station 32 (DS32) provides communication, configuration and 
file handling functions. Although DS32 is designed to work with a range 
of AMETEK products, not all functions are available on all instruments 
and this is indicated where necessary in the text. For this reason some of 
the displays may not look exactly like those shown in this manual. 
References to the TR100 also include the DL8000 and references to the 
TR2000 also include the MFR. The TR100+ is an enhanced version of the 
TR100.

DS32 supports Pseudo Machines (PM). These are recorders of up to 160 
channels that are made up from standard systems. DS32 makes the 
individual recorders look like a single large machine. 

DS32 supports:

• Multiple modems and dial up networking. This means that 
auto-poll and auto-call are quicker since many recorders can be 
contacted at once.

• Windows services to add new modems and dial up networking 
capability. Details for configuring these options are given in 
Appendix B ”3Com 56k LAN Modem Configuration: Manual and 
Autopolling” and Appendix C ”DS32 3Com/Remote TR 3Com 
LAN Modem Connection Configuration (Autocall)”. These 
processes improve the response of the system

DS32 Analysis
DSA32 displays analog and digital signals from AMETEK recorders for 
analysis. DSA supports:

• Transient, disturbance and logger records from the TR100, 
DL8000, TR100+, TR2000 and PQR series.

• Records stored in the IEEE COMTRADE format.
• Import of records from the Rochester TR1600 series of recorders 

using the translator program TRTrans.

Analog and digital signals appear together with their channel names and 
instantaneous values, if required. The digital channels are interleaved 
between the analogs and appear as a thin green line for the normal state 
and a thick red line for the alarm state. This is similar to the printed 
record format from a TR100 or TR2000.
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When DSA32 is started the channels from the record are split into graphs 
with up to eight channels each. If there is a frequency channel it has a 
graph of its own. The graph that appears is the last in the list of graphs. 
This is channels 24 - 32 for a 32 channel transient record and the 
frequency channel for a logger record. Each channel is automatically 
scaled to fill the space available and channels in the same phase group 
initially have the same scale factor.

Figure 1.1  DSA Main Window

DSA has the following features:

• Zoom and panning features and the gain of each channel are 
individually adjustable.

• Two separately adjustable cursors to measure normal and 
differential amplitude and time values.

• Several graphs can be created with different channels of interest 
in each. These graphs are displayed individually, cascaded or 
tiled in the same way as other Windows™ based applications.

• Graphs can be printed using a wide range of printers and plotters. 
An extra line of text is added to these graphs that includes the 
location and name of the originating recorder and the time and 
date of the record. This is to identify the source of the printed 
output.

• The record header information, analog and digital profiles, is 
viewable directly from within DSA32.
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• Extra channels are created by combining existing channels using 
simple arithmetic (+,-,* or /) or computing functions like RMS, 
sequence components, power and impedance. These new 
channels are treated in the same way as the original channels. 
These functions are available for both transient and disturbance 
records.

• Disturbance records contain the RMS and phasor information for 
each channel at up to 2 samples per cycle for triggered records 
and up to one sample per two cycles from a TR2000 disturbance 
logger record. The RMS data appear in graphical form and the 
phasor values are used to compute the derived components.

• Logger records have up to 34 channels of the maximum, average 
and minimum true RMS input values for each logging interval. 
There is also a record of the max, min and average frequency on 
the channel that is specified for frequency triggering. Records 
from a TR2000 recorder have two frequency channels. Separate 
logs of imbalance (or NPS), flicker, and power can also be 
displayed in DSA32. For harmonic logs a separate application is 
used.
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Display Station Main Window
The Display Station main window (Figure 1.2) lists all of the data records 
on the system using a series of four tabs to separate the records by type. 
You can select a record for viewing and analysis in Display Station 
Analysis. A right-click menu offers access to various main menu or 
individual window-based function.

Figure 1.2  Display Station Main Window

The Display Station main window:

• Filters records - Records filtering is available by location, 
classification (fault type), recorder and date (applicable to 
individual or all records). Filter settings and sort settings apply 
only to the present program session. Column widths are stored 
permanently. See ”Main Menu Bar” on page 2-6.

• Status bar - Displays the status of communications with recorders. 
As DS32 can support multiple modems, there can be several 
connections at once. See ”Comms Manager” on page 2-23.
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Record Types 
Available

Display Station and Display Station Analysis works with the following 
records and recorders:

Transient Records Double-click on a record and the record window 
appears with the header information for the record 
and allowing for a comment to be stored with the 
record. This window also contains the following 
information:

• Recorder Identification- the name and location 
of the recorder where the record originated.

• Trigger Information - describes the trigger type 
that caused record generation with the 
originating analog or digital channel name. 
Also shows the time that the trigger was 
detected to the nearest millisecond. For the 
TR2000, this time is shown to the nearest 
microsecond. The date includes the day 
number in brackets. The type of time the 
recorder is locked in appears:
• GPS locked - GPS time
• Serial locked - Serial time code, which 

includes IRIG-B
• Internal clock 

• Record Length - shows the entire duration of 
the record in cycles.

• Comment - Display a message you can store 
appended to the record. This is also included 
with a printed version of the record. The 
comment is normally used to identify the cause 
of the fault record. See ”Paste comment” 
on page 2-29.

• Analyze fault data - Opens the waveforms and 
analyzes the record further using Display 
Station Analysis (DSA). See Chapter 3 ”Display 
Station Analysis 32 Menus and Operations”.

• Analogs - Opens the pre and post fault RMS 
levels for each input channel in the record. The 
maximum and minimum values also appear. 
The measurement points are the two cycles 
either side of the trigger point and either side of 
the safety point
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• Digitals - Displays the record’s digital 
transitions the nearest millisecond. The fault 
duration also appears - the time between the 
trigger and safety points.

• Expert Info - Opens the Expert System 
classification of the record. This is only 
available if the record has been analyzed. See 
Appendix A ”Expert System”.

• Expert System - Starts the Expert system 
application. If the substation model has been 
created, this classifies the record and makes 
specific measurements. It is also used to view 
RMS profiles of individual channels or phase 
groups.

Logger Records Double-click on a record and the record window 
appears with the header information. This window 
also contains the following information:

• Recorder Identification- the name and location 
of the recorder where the record originated.

• Record Information - start and end time to the 
nearest interval. The interval being the sample 
interval at which the logger data was 
recovered.

• Duration - the difference in the start and end 
times of the record.

• Comment - Display a message you can store 
appended to the record. This is also included 
with a printed version of the record. The 
comment is normally used to identify the cause 
of the fault record. See ”Paste comment” 
on page 2-29.

• Analyze - Opens the waveforms and analyzes 
the record further using Display Station 
Analysis (DSA). See Chapter 3 ”Display Station 
Analysis 32 Menus and Operations”.

• Transient Events - Available for logger records 
containing high speed transient events.
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Disturbance Records (TR2000, TR100+ & PQR)

Double-click on a record and the record window 
appears with the header information. This window 
also contains the following information:

• Recorder Identification- the name and location 
of the recorder where the record originated.

• Trigger Information - describes the trigger type 
that caused record generation with the 
originating analog or digital channel name. 
Also shows the time that the trigger was 
detected to the nearest millisecond. For the 
TR2000, this time is shown to the nearest 
microsecond. The date includes the day 
number in brackets. The type of time the 
recorder is locked in appears:
• GPS locked - GPS time
• Serial locked - Serial time code, which 

includes IRIG-B.
• Analyze - Opens the waveforms and analyzes 

the record further using Display Station 
Analysis (DSA). See Chapter 3 ”Display Station 
Analysis 32 Menus and Operations”.

• Analogs - Opens the pre and post fault RMS 
levels for each input channel in the record. The 
maximum and minimum values also appear. 
The measurement points are the two cycles 
either side of the trigger point and either side of 
the safety point

• Digitals - Displays the record’s digital 
transitions the nearest millisecond. This is only 
valid for the TR2000 and TR100+. The fault 
duration also appears - the time between the 
trigger and safety points.

• Expert Info - Opens the Expert System 
classification of the record. This is only 
available if the record has been analyzed. See 
Appendix A ”Expert System”.
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• Expert System - Starts the Expert system 
application. If the substation model has been 
created, this classifies the record and makes 
specific measurements. It is also used to view 
RMS profiles of individual channels or phase 
groups.

Digital Input transitions (TR2000 & TR100+)

This window shows the digital transitions that 
occurred during a disturbance record. This 
window also contains the following information:

• Filter Selection - select a channel to filter on. 
This is filtered by time range.

• Event List - lists the digital events, the type of 
transition: Normal or Alarm and the initial state 
of each input. The time shown is the same as 
the trigger time.

Harmonic Record Double-click on a record and the record window 
appears with the header information. This window 
also contains the following information:

• Recorder Identification- the name and location 
of the recorder where the record originated.

• Record Information - start and end time to the 
nearest interval. The interval being the sample 
interval at which the logger data was 
recovered.

• Duration - the difference in the start and end 
times of the record.

• Analyze - Opens the waveforms and analyzes 
the record further using Display Station 
Analysis (DSA). See Chapter 3 ”Display Station 
Analysis 32 Menus and Operations”.

• Comment - Display a message you can store 
appended to the record. This is also included 
with a printed version of the record. The 
comment is normally used to identify the cause 
of the fault record. See ”Paste comment” 
on page 2-29.
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Installation
To install DS32 and DSA from the CD:

1. Insert the CD and the installation commences and the splash screen 
appears (Figure 1.3).

Figure 1.3  Splash Screen

2. Click Next and the license agreement appears (Figure 1.4).

Figure 1.4  End User License Agreement
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3. Read the agreement and click Yes and the User Registration 
Information window appears (Figure 1.5).

Figure 1.5  User Registration Information

4. Enter Name and Company and click Next and the Setup Type 
window appears (Figure 1.6).

Figure 1.6  Setup Type

5. Click:

• Typical to install all purchased products.
• Custom to select from purchased products.
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6. Click Next and the Choose Destination Location window appears 
(Figure 1.7).

Figure 1.7  Choose Destination Location

The default location for the application is C:\Program files\DS32 but 
if DS32 has been previously installed the location of this version is 
used as the default.

7. Click Next and a window to select where database files are stored 
appears (Figure 1.8).
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Figure 1.8  Data File Location Selection

The default location of the data files is C:\Documents and 
Settings\All Users\Application Data\LER\DS32. If required the data 
files can be located on a network drive and shared between multiple 
versions on DS32. The data files and other parameters are held in a 
database. In some instances the structure of this database is altered 
when the software version is updated. 

8. Click Next and the program begins installation.

A dialog appears asking whether to back up files before install and 
noting the space required. This is recommended.

9. Click Yes and then OK.
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A window appears for you to import data from the 16-bit version of 
DS (Figure 1.9).

Figure 1.9  Display Station 16-Bit Data Import

10. Click the desired file types and click Next and a Setup Complete 
window appears.

11. Click a radio button to restart the PC now or later to finish the install 
and click Finish.
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2. Display Station 32 Software

This chapter explains the Display Station 32 windows, tabs and dialogs 
and their functionalities. This is accompanied with more detailed 
descriptions of window/tab/dialog purpose, specific field and button 
descriptions, and procedures for use, as necessary.

This chapter consists of the following sections:

• ”DS32 Window General Operations”, a discussion of the main 
window’s functions and capabilities.

• ”Main Menu Bar” on page 2-6, a discussion of the items accessed 
from the toolbar. General discussions and specific procedures 
appear.

DS32 Window General Operations

This section consists of the following sections:

• ”DS32 Tabs/Access a Record/Record Dialogs” on page 2-2
• ”Right-Click Menu” on page 2-4
• ”Main Toolbar” on page 2-5
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DS32 Tabs/Access a Record/Record Dialogs
There are four tabs used for DS32 operations:

• Transient (Figure 2.1)
• Logger
• Disturbance
• Harmonic

Figure 2.1  Transient Tab

Transient Tab Fields and Buttons

The fields and buttons on the main window tabs perform filtering 
operations.

Location Lists the locations available.

Classification Lists:

• Transient tab - fault types available
• Disturbance tab - distinguishes between 

Classified and Unclassified

Recorder Lists the recorders available for a particular 
location.

Set Date See page 2-10.
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Record Dialog Fields and Buttons

The fields on Record dialogs are display only, except for the Comment 
field.

Comment Enter a comment to append to the record and click 
OK to save.

The buttons on each Record dialog access some of the DSA32and Expert 
System tasks associated with each record type.

Analyze fault data Opens the DSA32 Main Window (Chapter 3 
”Display Station Analysis 32 Menus and 
Operations”). Transient and Disturbance Record 
dialogs only.

Analogues Opens the ”Analogue Profile” on page 3-41. 
Transient and Disturbance Record dialogs only.

Digitals Opens the ”Digital Profile” on page 3-42. Transient 
and Disturbance Record dialogs only.

Expert Info Opens the Transient and Disturbance Record 
dialogs only.

Expert System Opens the Expert System Main Window (Appendix 
A ”Expert System”). Transient and Disturbance 
Record dialogs only.

Analyze Opens the Harmonics Display. Logger and 
Harmonic Record dialogs only.

Transient Events Active if a PQR logger record contains high speed 
1 MHz transient events.

Transient Tab
Operations

To perform filtering operations:

• Click a check box and select an item from the drop down. The 
Locations appearing in the list are actively filtered to reflect your 
choices.
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Figure 2.2 shows the Transient Record dialog as an example.

Figure 2.2  Transient Record

To access a record:

1. Double-click on a record.

The appropriate Record dialog appears (Figure 2.2).

2. Click the button associated with the desired task.

Right-Click Menu
Figure 2.3 shows the DS32 main window tab right-click menu. Except for 
Analyze cameo data these items are the same as on the bottom or Record 
dialogs (”DS32 Tabs/Access a Record/Record Dialogs” on page 2-2).

Figure 2.3  Right-Click Menu
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Main Toolbar
The main toolbar accesses the following functions listed in Table 2.1.

Table 2.1  DS32 Main Toolbar Icons

Icon Function

Recorder Network - Connect (”Connect” 
on page 2-52)

Recorder Network Disconnect (”Disconnect” 
on page 2-54)

Recorder Network - Edit (”Recorder Network” 
on page 2-32)

Recorder Configuration (”Recorder Network” 
on page 2-32)

View New Communications Log Entries 
(”Communications Log” on page 2-160)

Refresh File List (”Refresh File List” on page 2-6)

About DS32
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Main Menu Bar

The Display Station main menu bar consists of:

• ”System Menu”
• ”Edit Menu” on page 2-29
• ”Recorder Menu” on page 2-51
• ”View Menu” on page 2-160
• ”Database Menu” on page 2-161
• Help

System Menu
Menu functionalities include: system directory maintenance, 
communications set up and auto-polling and to implement system 
security. Menus items include:

• ”Refresh File List” on page 2-6
• ”Directory Maintenance” on page 2-7
• ”Auto-poll & Incoming calls” on page 2-14
• ”Auto-poll now” on page 2-17
• ”Auto-poll disturbance logger now….” on page 2-18
• ”Security” on page 2-19
• ”Comms Manager” on page 2-23
• ”Data Directory” on page 2-25
• ”Options” on page 2-26

Refresh File List
The DS32 database stores the header information for each record in the 
Display Station 32 data directory. The actual record data are stored in the 
data directory as files. Each record in the database stores the name of its 
data file. This function checks all records to ensure their names 
correspond with the appropriate database records.

CAUTION Always use Directory maintenance to copy records to and from the data 
directory to avoid corrupting databases.

Refresh File List
Operations

To refresh the file list:

• Select System > Refresh File List or click .
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Directory Maintenance
The Directory Maintenance window (Figure 2.4) is used to:

• Back up the records in Display Station
• Import previously archived records. 
• Analyze previously archived records in DSA32 without importing 

them into DS32.

The Directory Maintenance - Main Directory window lists all the records 
currently available in the system, delineating them using the same four 
tab labels as the Main Directory window. The same filtering used on the 
Record dialogs (”DS32 Tabs/Access a Record/Record Dialogs” 
on page 2-2) appears here.

Figure 2.4 through Figure 2.7 show these windows.

Figure 2.4  Directory Maintenance Window - Transient Tab

Number of displayed records
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Figure 2.5  Directory Maintenance Window - Logger Tab

Figure 2.6  Directory Maintenance Window - Disturbance Tab
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Figure 2.7  Directory Maintenance Window - Harmonic Tab

Fields and Buttons

The fields and buttons on this window tabs perform filtering and 
archiving operations.

Location Lists the locations available.

Classification Lists:

• Transient tab - fault types available
• Disturbance tab - distinguishes between 

Classified and Unclassified

Recorder Lists the recorders available for a particular 
location.

Set Date Sets the filtering selections for the records that 
appear.

Copy records to Archive

Copies records to the archive directory and ensures 
that duplicate records do not appear in the archive 
directory. The copied records are not deleted from 
the directory; use Delete to do this.

Delete Deletes selected records.

Select All Selects all the displayed records.
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Copy Copies the selected record entries to the clipboard. 
From there they can be pasted into a text document 
(like Word) or spreadsheet (like Excel).

View Archive Opens the archive shown in the Archive Directory 
box. From the Directory Maintenance - Archive 
Directory window, select records from the archive 
and copy them back to the main directory.

Copy records to Main directory

Copies records to the main directory and ensures 
that no duplicate records appear in the main 
directory. The copied records are not deleted from 
the directory; use Delete to do this.

Analyze Opens DS32 Analysis to view archived records 
without importing them to the main directory (See 
Chapter 3 ”Display Station Analysis 32 Menus and 
Operations”).

Directory 
Maintenance 
Filtering Operations

To perform general filtering operations:

• Click a check box and select an item from the 
drop down. The Locations appearing in the list 
are actively filtered to reflect you choices.

To perform date filtering operations:

1. Click Set Date and the Data Filter Selection dialog appears 
(Figure 2.8).

Figure 2.8  Data Filter Selection
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2. Click either radio button:

• Select a number of days - Select the number of days back from the 
present.

• Select specific dates - Select the From and To dates from the 
calendars.

3. Click the Apply Filter to All Lists check box, if required. This applies 
the filter to all lists, not just the displayed tab.

4. Click OK.

Directory 
Maintenance 
Archiving 
Operations

To copy records to an archive:

1. Select an Archive Directory from the drop down or click Browse and 
navigate to an archive.

2. Select a record(s).

3. Click Copy records to Archive.

A dialog appears.

4. Click Yes.

To delete a record:

1. Select a record(s).

2. Click Delete.

A dialog appears.

3. Click Yes.

A dialog appears.

4. Click OK.
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To view archived records:

1. Click View Archive and the Directory Maintenance Window - 
Archive Directory appears (Figure 2.9).

Figure 2.9  Directory Maintenance Window - Archive Directory Tab

2. Select a record(s).

3. Click Analyze...

The Display Station Analysis main window appears.

For older records:

The Display Analysis - Classify Phase Groups dialog appears 
(Figure 2.10).

Figure 2.10  Classify Phase Groups I
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a. Click the appropriate button:
• Classify this record
• Classify this machine
• Use defaults

The Display Station Analysis Classify - Phase Group dialog 
appears (Figure 2.11) for the first two bullets.

Figure 2.11  Classify Phase Groups II

b. Select a Channels and a Classification for a Phase group and 
click OK.

This repeats until all Phase groups are configured. The Display 
Station Analysis appears ready for use.

The Harmonics Display or DSA appears.

To copy records to the main directory:

1. Select a record(s).

2. Click Copy records to Main dir.

A dialog appears.

3. Click Yes.

A dialog appears.

4. Click OK.
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Auto-poll & Incoming calls
Use this window (Figure 2.12) to automatically contact any or all of the 
recorders in the network at a particular time on a selected day of the 
week. Any new profiles or complete data records are then automatically 
transferred to Display Station.

Figure 2.12  Auto-poll & Incoming calls

Buttons and Fields

Auto-poll Enable this and auto-poll downloads Transient, 
Disturbance and Harmonic records according to 
the criteria specified on the window.

Auto-poll date/time Sets the day and time. Normally the best times to 
do auto-polling are late at night or early in the 
morning, as the cost of the calls are reduced and 
data transfers do not interfere with normal daytime 
telephone traffic or corporate LAN traffic.

If auto-poll is required more often, set it to start at 
the time set by the Time selection every day and 
repeat every 2, 4, 6 or 12 hours from the top of the 
list.
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Automatic record downloading (Auto-poll & incoming)

Transient download/Disturbance download

Select a check box to activate the record types to 
download during an auto-poll connection. 
Activates the associated profile radio buttons for 
use.

Profile radio buttons Indicate the type of data to download. Profile 
choices include:

• Profile only - downloads only profile data.
• Profile and cameo - download profile and 

cameo data. Transient records only.
• Profile and fault data - downloads both profile 

and fault data.
• Profile and reduced data - downloads the 

selected channels, sample rates and times set 
for each individual recorder. To set these, see 
”Configure - Configure a Recorder” 
on page 2-54. Reduced data is available on a 
TR2000 or TR100+.

Retries Sets the number of times auto-poll tries to contact a 
recorder: 0,1 or 2.

Auto-poll site list Select the recorders to auto-poll.

Auto-poll selections

Lists the Default list and lists you create. Created 
lists can have different polling times, flags and 
recorders. The Auto poll on/off button enables only 
the list selected. However, multiple lists can be 
active at anytime. All selections are automatically 
saved when the selection in this pull down is 
changed.

New Adds a new Auto poll list.

Delete Click to delete a list select the name from the drop 
down.

Auto-poll and Incoming options

Automatically set recorder time to match PC time - 
updates the time on each recorder polled to the 
time on the polling PC.
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Automatically run Expert system on new records - 
runs the Expert System after auto-polling. This 
classifies all the records downloaded and stores the 
results. See Appendix A ”Expert System”.

Automatically retrieve harmonic records - 
downloads harmonic logger records while 
auto-polling. The logger interval is set for each 
recorder in the ”Harmonics Configuration – 
TR100” on page 2-60 or ”Harmonics 
Configuration – TR2000, TR100+ & PQR” 
on page 2-61. Other logger records are not 
recovered automatically.

Exclude Cross-Triggered records during Auto-poll - 
ignores all cross triggered records. This can be 
useful at locations where there are many cross 
triggered recorders to reduce the volume of polled 
data.

Automatic Polling
& Incoming Calls

Operations

Automatic polling & Incoming calls procedures

To configure this window:

1. Select a list from Auto poll selections.

2. Click Auto poll on/off. 

3. Select Auto poll site list Regions or Recorders:

• Select a recorder and that recorder is selected. The Region is also 
selected, but not all recorders in the Region.

• Select a region and all recorders in the Region are selected.

4. Configure:

• Auto poll & incoming options
• Automatic record downloading options
• Auto poll date/ time options

5. Click OK.
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To add a new Auto poll selections list:

1. Click New and Figure 2.13 appears. 

Figure 2.13  Name this autpoll setup

2. Enter a unique list name.

3. Click OK.

Auto-poll now
Use this window (Figure 2.14) to force the system to do an auto-poll 
immediately. The Auto-poll/call and Auto-poll now windows are almost 
identical, the difference being that Auto-poll now does not have the 
date/time facility.

Figure 2.14  Immediate Automatic Polling
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Buttons and Fields

See Buttons and Fields in ”Auto-poll disturbance logger now….” 
on page 2-18

Immediate
Automatic Polling

Operations

Immediate automatic polling procedures

To configure this window:

1. Select a list from Auto poll selections.

2. Click Auto poll on/off. 

3. Select Auto poll site list Regions or Recorders:

• Select a recorder and that recorder is selected. The Region is also 
selected, but not all recorders in the Region.

• Select a region and all recorders in the Region are selected.

4. Configure:

• Auto poll & incoming options
• Automatic record downloading options
• Auto poll date/ time options

5. Click OK.

Auto-poll disturbance logger now….
Use this window (Figure 2.15) to allow the continuous disturbance 
logger data to be recovered from a number of recorders.

Figure 2.15  Immediate Disturbance Logger Polling
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Buttons and Fields

Reduced data Enables the download of only reduced data.

Disturbance Logger Start and End

Set the Start and End Date/Time for the disturbance 
logger data required. If logger data is not available 
for the date and time entered here then nothing is 
downloaded. Disturbance logger data is available 
for the previous two weeks.

Auto-poll site list

Select the recorders for auto-poll.

Auto-poll Selections

Select a list of recorders to poll. This list is set up 
using the”Auto-poll & Incoming calls” 
on page 2-14.

Immediate
Disturbance

Logger Polling
Operations

Immediate disturbance logger polling procedures

To configure this window:

1. Select a list from Auto poll selections.

2. Click Reduced data on/off, if required. 

3. Select Auto poll site list Regions or Recorders:

• Select a recorder and that recorder is selected. The Region is also 
selected, but not all recorders in the Region.

• Select a region and all recorders in the Region are selected.

4. Click OK.

Security
The Security menu consists of the operations consist of:

• Unlock - Use this option to unlock Display Station 32. This 
changes the security level to 1 or 2; whichever was last set.

• Lock - Use this option to lock Display Station 32, i.e. to set its 
security level to 0.

• Change Keys - Changes the security keys.
• Import Recorder Passwords - Imports recorder passwords.
• Export Recorder Passwords - Exports recorder passwords.
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There are three security levels in Display Station 32, level 2, level 1 and 
level 0. The level allow the following access to program functionality:

• Level 2 - Top level access (default), you can download data, 
change recorder configurations and delete records.

• Level 1 - Medium access, you can connect to recorders and 
download data but cannot change recorder configurations or 
delete records.

• Level 0 - Restricted access, you can view data currently on the 
PC, but cannot connect to recorders or change configurations or 
delete records.

NOTE If auto-poll has been configured using Level 2 and the security is 
changed to level 0, Auto-poll still operates. Auto-poll Now requires 
Level 1 security.

Buttons and Fields

Security Key Level 1

Changes the key used for accessing Security Level 
1. If the level 1 security key has not been set before 
then Old is disabled.

Security Key Level 2

Changes the key used for accessing Security Level 
2. If the level 2 security key has not been set before 
then Old is disabled.

Security
Operations

Change security keys

To change security keys:

1. Select System > Security > Change Keys and the Change security keys 
dialog appears (Figure 2.16).
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Figure 2.16  Change Security Keys

2. Click the Change check box for each Security Key Level, if required.

3. Enter a password the New and Confirm fields.

NOTE Enter a different password for each Security Key Level.

4. Click OK.

Security Unlock/Lock

To unlock/lock:

1. Select System > Security > Unlock and the Enter Security Access Key 
dialog appears (Figure 2.17).

Figure 2.17  Enter Security Access Key

2. Enter the password here of the security level desired.

3. Click OK.

A dialog appears informing you of the security level in force.

To set the security level back to zero:

• Select System > Security > Lock.
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Import/Export Recorder Password operations

To import or export recorder passwords:

1. Select the appropriate menu item and a dialog box appears 
(Figure 2.18 or Figure 2.19).

Figure 2.18  Import recorder passwords

Figure 2.19  Export recorder passwords

2. Click OK.

An Open, for Import, or Save As dialog (for Export) appears.

3. Select the desired directory and click Save or Open.
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Comms Manager
From version 2.0 of DS32 onwards Windows-configured modems can be 
used for recorders connections. The actual procedure used depends on 
the operating system (2000, XP) (see ”Windows 2000 Configuration” 
on page B-3).

If:

• Dial up networks or pseudo machines are used, then dial out and 
dial in connections must be configured, see ”Windows 2000 
Configuration” on page B-3.

• 3Com 56k LAN modem are used for dial-up networking, see 
Appendix B ”3Com 56k LAN Modem Configuration: Manual and 
Autopolling”.

• 3Com LAN modem is to be used for Auto-poll, see ”3Com 56k 
LAN Modem Configuration: Manual and Autopolling” 
on page B-1.

Figure 2.20 shows the Comms Manager.

Figure 2.20  Comms Manager
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Button and Fields

Incoming connections

Use both network and modem connections if 
auto-call is used. Select the Listen on TCP/IP check 
box for LAN/WAN or dial-up networking. Select 
the modem for use for auto-call connections for 
direct modem connections.

Serial port connections

Sets the COM port for direct serial connections to a 
recorder and the baud rate. The default baud rate 
for a TR2000, TR100+ and PQR is 57600 bps. The 
default baud rate for a TR100 is 19200 bps.

Connection Parameters

Sets the number of connection retries and retry 
delays for modem and network connections. For 
each connection type a different Timeout can be 
set. For most types the default is 4500 msec. 

Inactivity timer Sets an inactivity timeout for any connection. This 
is the amount of time with no data being sent in 
either direction before the connection is dropped.

Max sockets Sets the maximum number of available sockets for 
network connections. This limits the maximum 
concurrent network connections. The default value 
is 20.

Keep parser log Saves all the recorder commands in a parser log 
file before testing. Do not use this during normal 
operation.

Bulk transfer listings Activate to retrieve directory listings using a more 
robust method that takes longer. Use this option for 
noisy lines where problems occur getting directory 
listings.

Modems Lists all the modems available for use.

Ignore/Use Click to ignore a selected modem. IGNORE 
appears next to the modem name.

Configure Use to check or change the configuration of a 
modem.
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Comms Manager
Operations

To configure communications:

1. Select System > Comms Manager and the Comms Manager appears 
(Figure 2.20).

2. Click the Listen on TCP/IP check box for LAN/WAN or dial-up 
networking.

3. Select the modem for use from the Listen on modem drop down.

4. Click the browse button next to Listen on modem to configure the 
modem, if required.

5. Select an available com port from the Port drop down for direct serial 
connections to a recorder.

6. Select the baud rate from the Speed drop down.

7. Enter the Number of retries and the Delay between retries.

8. Select the connection type using the Timeouts and enter the timeout.

9. Click the Use timer check box and enter a Disconnect after time, if 
required.

10. Enter the Max sockets.

11. Click Bulk transfer listings and Keep parser log check boxes, if 
required.

12. Click OK and a dialog appears.

13. Click OK and restart for changes to take effect.

Data Directory
Displays the directory (Figure 2.21), set up during installation, where the 
database is stored and where the fault records are downloaded. The data 
directory can reside on the local machine or on a network file server.

Figure 2.21  Data Directory

NOTE The data directory is defined when the application is installed and 
cannot be changed by DS32
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Options
Two functions are configured using Options (Figure 2.22):

• Whether the directory entries are refreshed when Display Station 
is started. 

• Determining if transient records and/or disturbance records are 
recovered manually or automatically for automatic export in 
COMTRADE format. This is useful if another analysis or display 
application is being used. The COMTRADE files conform to the 
1999 standard.

Figure 2.22  Options

Figure 2.23 shows the Options Advanced - Export File Prefix window.

Figure 2.23  Advanced - Comtrade Export File Prefix
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Buttons and Fields

Refresh file list on start up

Click to refresh the file list on startup. If the number 
of records is large it may be better to leave this 
switched off. The file list can be refreshed 
manually by using the Refresh file list on the 
System menu.

COMTRADE Export Options

Export after Autopoll/Export after Autopoll/

Export after Manual Download

Automates the export of transient/disturbance 
records using the check boxes.

Export Disturbance Phasor Channels

Automates this export with COMTRADE export.

Binary/ASCII Select the data file format radio button.

Export Directory Select the destination directory.

Filename prefix Select either the:

• Simple radio button to enter a prefix.
• Advanced radio button to use the Advanced 

window. You can choose a file naming 
convention that uses details of the actual 
record itself for the filename.

COMTRADE Export - Advanced File Naming

Use this window to set up different options for file naming of exported 
COMTRADE records. The filename must firstly be represented by:

Date, Time, Time Code, Station ID, Device ID

Automatically populated by DS32.

Company Name Enter a name.

Additional filename parts can be selected from the following list:

• Duration - Click the check box to append this 
to the file name.

• Type - Click the check box to append this to 
the file name.

• Option1 ...4 - Click the check box to append 
text.
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An example exported file is:

050202,142116261,UT,LocationB,A 
Machine,AmetekPI,000000000210,wave,opt1.cfg
This represents file created at date 2nd Feb 2005, 
time 14:21:16.261, Universal Time, LocationB, 
Machine A. 
Company name is AmetekPI, and the record 
duration was 210 mSecs.
It is a waveform file and one option (opt1) was 
included.

Options
Operations

To configure Options:

1. Select System > Options and the Options window appears 
(Figure 2.22 on page 2-26).

2. Click the Refresh file list on start up check box, if required.

3. Click the Binary or ASCII radio button.

4. Click any Export check boxes, as required.

5. Click the browse button and use the Browse for Folder dialog to 
navigate to and select a folder, as required.

6. Configure Filename prefix by clicking the radio button for either:

• Simple and entering a file name in the field.

or

• Advanced and clicking > to open the Advanced window 
(Figure 2.23 on page 2-26) and:
a. Enter a Company Name.
b. Click the Duration and Type check boxes, as required.
c. Click an Option check box(es) and enter text, as required.
d. Click OK.

The Options window reappears.

7. Click OK.
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Edit Menu
There menu options available are:

• ”Delete”
• ”Copy”
• ”Paste comment”
• ”Select All”
• ”Import COMTRADE”
• ”Export COMTRADE”
• ”Recorder Network”
• ”Communications Status”

Delete
Deletes records from the main window's list of records. Security level 2 is 
required.

Record Delete
Operations

To delete a record:

1. Select a record.

2. Select Edit > Delete or press the <Delete> key.

Copy
Copies the directory entries for all the selected records to the clipboard. 

Record Copy
Operations

To copy a record(s):

1. Select a record(s).

2. Select Edit > Copy or press the keyboard Ctrl-C.

3. Copy into any word processor.

Paste comment
Use this to add the same comment to a number of records 
simultaneously. This could be used for records with the same source such 
as voltage dips and loss of supply.

Record Past
Comment

Operations

To paste a comment:

1. Select a record(s).

2. Select Edit > Paste comment and the Paste comment to selected 
records dialog appears (Figure 2.24).
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Figure 2.24  Paste comment to selected records

3. Enter a comment and click Paste this comment to selected records.

A dialog appears.

4. Click Yes.

Select All
Selects all the records in the main window.

Import COMTRADE
Opens COMTRADE files for viewing in Display Station and Display 
Station Analysis.

Import Comtrade
Operations

To import a COMTRADE file:

1. Select Edit > Import COMTRADE...

The Open dialog appears (Figure 2.25).

Figure 2.25  Import Comtrade Selection

2. Navigate to the desired directory and select the .cfg file.

3. Click Open.
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The Comtrade Record window appears (Figure 2.26).

Figure 2.26  Comtrade Record

4. Click:

• Analyze - Open DSA for that record.
• Analogues - Opens the Analogue fault level - RMS dialog 

(”Analogue Profile” on page 3-41) if the file has profile data.
• Add to database - Adds the record to the DS database.
• OK - Closes the dialog with no import.

Export COMTRADE
Use this window (Figure 2.27) to export Display Station 32 records in 
COMTRADE Format.

Export Comtrade
Operations

To export a COMTRADE file:

1. Select a location in the Display Station 32 window

2. Select Edit > Export COMTRADE.

The Export Comtrade dialog appears (Figure 2.27).

Figure 2.27  Export Comtrade
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The dialog fields appear populated. If changes are required:

a. Click Change Details.

The Options dialog appears (”Options” on page 2-26). 

b. Change the Export Directory, Prefix, Export options or the For-
mat, as required.

c. Click OK.

The Export Comtrade dialog reappears.

3. Click Export.

Recorder Network
Display Station 32 stores a list of all the recorders to which it can 
connect, as well as the connection information for each recorder. The 
Recorder Network - Edit window is used to enter and edit this 
information. 

Select Edit > Recorder Network and the Recorder Network - Edit window 
appears (Figure 2.28). This lists all the recorders in the network and uses 
a tree control very similar to Windows.

The recorder hierarchy is:

• World - All recorders belong to the Recorder Network shown as 
the world symbol at the top of the tree.

• Region - Each region is used to group a number of locations. 
Recorders without a region are all listed under No Region 
Specified.

• Location - Each location is used to group a number of recorders. 
This aids easier selection from a larger number of recorders.
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Figure 2.28  Recorder Network - Edit

Button and Fields

Search Tree

Searches the recorder network to find a particular 
region, location or recorder. This is very useful if 
there are a large number of recorders in the 
network. Check the relevant box to enable other 
options:

Whole word Ensures that a word must match completely in a 
search. The default is that partial matches can be 
found.

Case sensitive Activates case sensitivity for the search.

Search up Makes the search go up the tree. The normal 
search order is top down. 

Enable ToolTips Enables the display of information about an object 
when the cursor moves over its name.
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Recorder
Network - Edit

Operations

Right-click on the machine and select Edit Recorder Details (Figure 2.29).

Figure 2.29  Recorder Network - Recorder Details

Perform A Recorder Search

To perform a recorder search:

1. Enter the name in the text box. If the full name is not known use a 
partial entry.

2. Click the appropriate search criteria check boxes.

3. Click Search Next.

If an item is found it is highlighted.

Add a Region

To create a new region:

1. Select Edit > Recorder Network and the window appears 
(Figure 2.28).

2. Select Add Region (Figure 2.30).
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Figure 2.30  Recorder Network - Add Region

A New Region line appears (Figure 2.31).

3. Right-click on New Region and select Rename Region.

Figure 2.31  Recorder Network - Rename Region

The New region text is now editable.
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4. Enter a name of up to 24 characters to uniquely identify the region 
and click in the window area.

To Remove a Region:

1. Select Remove region and a warning message appears (Figure 2.32).

Figure 2.32  Remove Region Warning

2. Click Yes.

Any locations at the deleted region are moved to the No Region 
Specified region.

Add a Location

To add a location:

1. Right-click on the renamed Region and select Add Location.

The location appears as New Location (Figure 2.33).

Figure 2.33  Recorder Network - Add Location
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2. Right-click and select Rename Location.

The text is now editable.

3. Enter a name of up to 24 characters to uniquely identify the location 
and click in the window area.

NOTE Once created, locations can be dragged into other regions.

Remove a Location:

To remove a location:

1. Select Remove location and a warning message appears 
(Figure 2.32).

Figure 2.34  Remove Location Warning

2. Click Yes.

Any machines and pseudo machines for the location are removed. 
For details on the Pseudo Machine see ”Pseudo Machine” 
on page 2-46.
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Add a Recorder

To create a new recorder:

1. Right-click on the location and select Add Machine.

A default Machine line appears (Figure 2.35).

Figure 2.35  Recorder Network - Add Machine

2. Right-click and select Rename Location.

The text is now editable.

3. Enter a name of up to 24 characters to uniquely identify the recorder 
and click in the window area.

Remove a recorder

To remove a recorder:

1. Select Remove recorder and a warning message appears.

2. Click Yes and all recorder details are deleted.
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Edit recorder details
Modem Tab Figure 2.36 shows the Modem tab.

Figure 2.36  Recorder Details - Modem Tab

Buttons and Fields

Recorder Name Display only.

Recorder Type Select the recorder type from TR2000, TR100, 
TR100+ or PQR. Aides in the creation of the 
recorder configuration before a connection has 
been made.

Auto-poll uses

Select the preferred mechanism for auto-poll for 
recorders with two types of remote connection. In 
later versions of Display Station 32, both these 
types are available if the recorder has support for 
both peripherals.

Recorder Password Opens the Recorder Password dialog to add 
password security for the recorder.
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Dialing parameters Enter the phone number for the substation 
including all the required access and area codes. If 
a DTMF line sharing unit is used to route calls at a 
location to the recorder, for best results make the 
two appended digits different.

Login sequence Some forms of code operated switch require a 
sequence of commands and responses after a 
modem call is answered and before a recorder 
connection is made. This sequence can be 
automated using a series of commands. Three 
types of command are supported:

• Waitfor - Wait for the defined string with a 
time-out

• Delay - Wait for the defined number of seconds
• Send - Send the defined string

Based on these commands a log on script can be 
created which supports most switches. An example 
script for an RFL switch is:

waitfor 30 "access." 
delay 1 
send "^M" 
waitfor 30 "word:" 
send "LER^M" 
waitfor 30 "MOTE>" 
send "2^M" 
delay 2
end

The ^M sequence represents a carriage return 
which is equivalent to holding down the Ctrl key 
and pressing M on a keyboard. Other control 
characters are created in this way.   

Command/Code serial switching unit

Click the check box to activate this and the Login 
Sequence added using Insert Line.

Insert Line Opens the Insert Login dialog to add a sequence 
for a serial code switch unit to connect to the 
recorder.
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TCP/IP Tab Figure 2.37 shows the TCP/IP tab.

Figure 2.37  Recorder Details - TCP/IP Tab

Buttons and Fields

Recorder Password See ”Modem Tab” on page 2-39.

Network parameters – IP address

Enter a unique IP address. The IP address is a 
unique 12-digit number that must be entered in the 
form:

123.156.189.012

Each group of 3 digits can have a value from 0 – 
255. This address must be the same as that in the 
recorder configuration network definition. A 
subnet mask and router address can be entered in 
the network set up of the recorder configuration.

Within a network or intranet IP addresses are 
normally issued by a system administrator or IT 
department. An IP address should not be assigned 
without consulting the relevant authority.
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Network parameters – Dial Up Networking

Select from the drop down, which also requires 
that a recorder IP address is entered. There is an 
option to connect to a remote recorder (or 
recorders) linked to a network using Windows Dial 
Up Networking. If this is required, the connection 
set up the connection in Windows before entering 
the recorders into the Recorder Network. For 
details on setting up Dial Up networking see 
Appendix B ”3Com 56k LAN Modem 
Configuration: Manual and Autopolling” and 
Appendix C ”DS32 3Com/Remote TR 3Com LAN 
Modem Connection Configuration (Autocall)”.

Login sequence Click Follow login sequence to activate. If there is 
a firewall in the router to access individual 
recorders a logon script can be created to 
automatically issue the correct commands and 
connect to the recorder. 

If a User name and Password are required for Dial 
up Networking, enter them as part of the 
connection set up in Windows.
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Recorder Details
Operations

To edit recorder details:

1. Right-click on a recorder and the Recorder details window appears 
(Figure 2.38).

Figure 2.38  Recorder Network - Modem Tab

2. Select a Recorder Type from the drop down, during original 
configuration only.

3. Click a radio button in Autopoll uses.

4. Click Recorder Password and the Recorder Password appears dialog 
(Figure 2.39).

Figure 2.39  Recorder Password
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5. Enter the password in both fields, if required, and click OK.

6. Enter a Telephone No.

7. Click the DTMF line sharing unit check box, if required, and enter 
the two-digit number to append to the phone number in the Append 
field. For best results the two digits should be different.

8. Configure the Login sequence, if required, by:

a. Clicking the Command/code serial switching unit check box.
b. Click Insert Line and the Insert Login dialog appears 

(Figure 2.40).

Figure 2.40  Insert Login

c. Click a Command radio button and enter a value in the String 
field, if active, and a Timeout (1-60 seconds), if active.

To delete a line:

• Select the line and click Delete Line.

To insert a missing line:

• Click on the line below where the line is to go and click Insert 
line and use the Insert Login dialog.
d. Click OK.
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9. Click the TCP/IP tab (Figure 2.41).

Figure 2.41  Recorder Network - TCP/IP Tab

10. Select a Recorder Type from the drop down, during original 
configuration only.

11. Click a radio button in Autopoll uses.

12. Click Recorder Password and the Recorder Password appears dialog 
(Figure 2.39).

Figure 2.42  Recorder Password

13. Enter the password in both fields, if required, and click OK.
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14. Enter the Network Parameters IP Address.

15. Select a Dial-Up Networking option from the drop down.

16. Configure the Login sequence, if required, by:

a. Clicking the Follow login sequence check box.
b. Click Insert Line and the Insert Login dialog appears 

(Figure 2.40).

Figure 2.43  Insert Login

c. Click a Command radio button and enter a value in the String 
field, if active, and a Timeout (1-60 seconds), if active.

To delete a line:

• Select the line and click Delete Line.

To insert a missing line:

• Click on the line below where the line is to go and click Insert 
line and use the Insert Login dialog.

17. Click OK.

18. Click OK to exit Recorder Network - Edit.

Pseudo Machine A pseudo machine (PM) allows the viewing of a number of co-sited 
recording instruments as one large recorder from Display Station. Using 
this you can create an instrument with up to 160 analogue and 320 
digital channels with record generation that includes all the key signals 
from a large substation.
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The following rules must be met:

• The constituent recorders of a pseudo machine must be the same 
type and must be cross-triggered.

• A common time sync source must be used (GPS, IRIG-B, etc.).
• The recorders use a local Ethernet network connection.
• For a network enabled site, the recorders are linked to the LAN.
• For a site accessible via PSTN, connect the recorders to a dial-up 

LAN modem.

Configuration Display Station configures the common parameters in each recorder of a 
pseudo machine to be identical. These include:

• Sampling rates
• Recording times (transient & disturbance)
• Time & date
• Peripherals (network)

NOTE It is important that individual configurations are not edited. If the 
pseudo machine configuration is edited using Display Station all the 
recorders are updated together.

The channels of the individual machines are concatenated so that the 
maximum channel number available is 160. Display Station determines 
that the correct channel configuration is assigned to the correct machine. 
If 32 channel recorders are used, there may be up to 5. If 8 channel 
recorders are used, there may be up to 20. Recorders are not required to 
have the same channel counts.

Communica-
tions

A PM can be contacted in the same way as standard instruments, either 
manually or via auto-poll or auto-call. Display Station determines 
whether there are actually a number of instruments making up the PM. 
Records recovered from the recorders of a PM are combined to form a 
single record that is available in the record directory for viewing and 
analysis in the normal way. All record types are included:

• Transient records
• Disturbance records
• Disturbance logger
• Long term logger
• Harmonics logger
• Flicker logger
• Imbalance logger
• Energy logger
1086-339  Rev. A   11/05 2-47



Display Station 32 Software
Pseudo Recorder
Operations

The most efficient manner to create a PM is to create individual 
recorders, add a pseudo machine at the site, click and drag each recorder 
onto the PM and then re-order the recorder sequence, if required.

There may be multiple pseudo machines at a location as well as 
individual recorders.

To add a pseudo recorder:

1. Edit Network Dial-up Networking for a PM accessed over a dial up 
circuit. This is not required if the recorders are available on a 
WAN/LAN.

2. Add individual recorders for use in the PM as per ”Recorder Network 
- Edit Operations” on page 2-34 using the recorder IP address and 
selecting Dial-Up Networking.

The individual recorders that make up a pseudo machine must all be 
configured the same way. The hardware set up must have:

• Cross-triggering
• Network support
• Common time sync

The Modem, Terminal Adapter and Network Hub can all exist in the 
same unit. These are normally termed a dial-up network modem. 
Specifically, this could be a product like a 3Com OfficeConnect 56k 
LAN modem. Up to four recorders can be connected to this but more 
may be included by adding a standard Ethernet hub.

NOTE It is important that the network administrator is contacted before 
selecting the IP addresses and subnet masks for the recorders that make 
up a PM.

Refer Table 2.2 for pseudo recorder channel assignments.

Table 2.2  Pseudo Machine Channel Assignments

Recorder
Name

Individual recorder
channel numbers

Pseudo recorder
channel numbers

Recorder #1
Recorder #2
Recorder #3
Recorder #4
Recorder #5

1 – 32
1 – 32
1 – 32
1 – 32
1 – 32

1 – 32
33 – 64
65 – 96
97 – 128
129 – 160
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NOTE Use the substation as the connection name for simplicity. A login 
sequence is not normally used for this type of connection.

3. Repeat this for all the recorders that are to make up the PM. 

4. Build a Pseudo Machine by:

a. Right-clicking on the Location Name and selecting Add 
Pseudo recorder.

b. Right-clicking on the new default PM name and select 
Rename Pseudo Recorder and changing the name to the 
required one.

c. Click and drag the individual recorder names in the Recorder 
Network - Edit window onto the pseudo recorder name.

5. Click OK.

NOTE Individual recorders must be listed in the correct order as this 
determines the sequence of the input channels. If the initial order is not 
correct:

a. Click on the PM name and select Edit Pseudo Recorder 
Details (Figure 2.44).

Figure 2.44  Pseudo Recorder Details

b. Select an offending recorder name and click Up or Down to 
move it to the correct location.

c. Click OK.
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Merge Records Now
Use this option to manually initiate the record merging process. Records 
that have originated from a pseudo machine but have not been merged 
are now processed. This process happens automatically after the 
recorders have been auto-polled. Cross-triggered records that can be 
merged may have slightly different trigger times.

Communications Status
Displays the status of any active communications process.

Buttons and Fields

The display window lists for each active process:

• Machine Name
• Location
• Job Description
• Step
• Progress - for file transfers
• Speed

For a file transfer the number of bytes transferred, the data rate and the 
time remaining are all displayed.

Cancel Cancels a communications process for the active 
entry. You are required to confirm before jobs are 
cancelled.

Cancel All Cancels all communications processes. You are 
required to confirm before all jobs are cancelled.

Hide Hides the display.

Always on top Click to keep the status display on top of any other 
window.

Communications
Status Operations

To open Communications Status:

1. Select Edit > Communications Status or double-click on the blue 
status bar at the bottom of the main window.

The Communications Status window appears (Figure 2.45).

2. Select an active communications process using the mouse or by 
holding down the <Alt> and pressing the <Tab> key repeatedly until 
the Task window shows Communications Status, then release both 
keys.
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Figure 2.45  Communications Status

3. Click on an entry to see the details in the text boxes at the bottom of 
the window. If only one process is running its details automatically 
appear.

Recorder Menu
This menu is used to connect to recorders, configure them and to 
download records from them. Most options are not available until a 
connection is made. The options available are:

• ”Connect” on page 2-52
• ”Disconnect” on page 2-54 
• ”Configure - Configure a Recorder” on page 2-54
• ”PQR Set up Wizard (PQR)” on page 2-133
• ”Event Log” on page 2-141
• ”Manual Trigger” on page 2-142
• ”Transient Record Download” on page 2-143
• ”Harmonic Records” on page 2-150
• ”Logger Records” on page 2-152
• ”Disturbance Records (TR2000, TR100+ & PQR)” on page 2-154
• ”Disturbance Logger (TR2000)” on page 2-158
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Connect
Connects to a recorder locally or remotely via a modem or network 
(Figure 2.46). This is identical to the tree control used to configure the 
Recorder Network. There is a hierarchal structure of:

• Recorder Network
• Regions
• Locations
• Recorders

Figure 2.46  Recorder Network - Connect

The status bar includes a description of the number of active connections 
and jobs active and pending at any time. To view details on individual 
connections double click on the text box and the Communications Status 
window appears (”Comms Manager” on page 2-23).

At the bottom left of the main window are two colored boxes for a 
manual and automatic connection. The colors indicate:

• Red - No connection active
• Yellow - Connection in progress and incomplete
• Green - Connection complete
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Buttons and Fields

Search Tree

Searches the recorder network to find a particular 
region, location or recorder. This is very useful if 
there are a large number of recorders in the 
network. Check a relevant box to enable other 
options:

Whole word Ensures that a word must match completely in a 
search. The default is that partial matches can be 
found.

Case sensitive Activates case sensitivity for the search.

Search up Makes the search go up the tree. The normal 
search order is top down. 

Enable ToolTips Enables the display of information about an object 
when the cursor moves over its name.

Direct Opens a connection to a local serial-connected 
recorder. This may be password protected.

Recorder
Network -

Connect
Operations

Connect to a Recorder

To connect to a recorder:

1. Select Recorder > Connect or click .

The Recorder Network - Connect dialog appears (Figure 2.46).

2. Select a recorder and click Connect to make a remote connection or 
click Direct to make a local serial connection.

A Recorder ID Mismatch dialog may appear (Figure 2.47 
on page 2-54) if a connection is made to a recorder and the recorder 
name has been changed, either on the recorder itself or in Display 
Station network definition, since the last time the recorder was 
connected.
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Figure 2.47  Recorder ID Mismatch

The following appears on the dialog:

• Recorder identification - Displays the Location and Machine 
Name that the recorder has stored in its configuration.

• Expected Recorder Identification - Displays the Location and 
Machine name for the Network definition that Display Station has 
stored.

• Click Update the Recorder to change the names on the recorder 
to the names in Display Station 32's Network definition.

• Click Update the Network Definition to update the names in 
Display Station’s Network definition to the names on the recorder.

• Click Ignore to do nothing. In this case, the next time the recorder 
is connected, this window appears again.

The main window reappears.

Disconnect
To disconnect a connected recorder:

• Select Recorder > Disconnect or click . It takes a modem 
several seconds to disconnect.

Configure - Configure a Recorder
Use this window (Figure 2.49) to select a recorder and configure or 
change its set-up parameters. If a recorder is:

• Connected, then the edits are made on-line with a real time 
display of recorder input signals. To save changes on the recorder, 
click Setup.

• Disconnected edits are made off-line and are downloaded to the 
recorder the next time it is connected. In this case, you must 
select the recorder.
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To select the recorder:

1. Select Recorder > Configure or click .

2. Navigate to the recorder and click Configure.

Figure 2.48  Recorder Network - Configure

A Recorder ID Mismatch dialog may appear. Refer to ”Recorder 
Network - Connect Operations” on page 2-53.

If there is any concern about the validity of a current configuration 
this option can be forced by holding down the Shift key while 
clicking on Configure. This allows the viewing of the file without 
changing the file on the PC. The Recorder or Local configuration can 
then be updated to ensure they are identical.

NOTE See ”Recorder Network” on page 2-32 for an explanation of the buttons 
and fields on this window.
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Its Recorder Configuration window appears (Figure 2.49).

Figure 2.49  Recorder Configuration

Buttons and Fields

The type of recorder dictates the options available and whether it is 
on-line or off-line.

Hardware Describes the type of recorder connected or 
selected. The recorder type and model, the number 
of channels, whether a battery is installed, the 
frequency of the mains supply and software 
revision number appear.

Recorder Identification

Displays the Location and Machine name to 
uniquely identify each recorder.

Memory

Indicator Shows how much of the recorders memory 
(including hard disk) is currently used up (on-line 
only). 

Total/Free Indicates how many seconds of potential transient 
recording time there are on the recorder and how 
many seconds of potential recording time are 
currently available.
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NOTE Take care, as this does not take into account the 1024 event limitation 
in the recorders.

On memory full Use these radio buttons to specify an action if 
recorder memory becomes full. The choices are:

• Stop - stop recording.
• Overwrite - overwrite the memory starting from 

the oldest record.
• Overwrite read - overwrite the memory starting 

from records marked as read.

Setup/Save Click to save changes, either locally or to a 
connected recorder.

CAUTION A warning appears when connected to a TR100 with no hard disk 
indicating that changes made to the sample rate affects recorder 
records. As the recorder has no hard disk, the configuration is not 
stored separately for each record.

Acquisition Specifies general record duration parameters. 
Parameters can be specified for transient and 
disturbance records (TR2000 & TR100+).

If the extended waveform capture option is 
available on the PQR it is also editable. If not, the 
values are 4, 12, 0, 1(Figure 2.50). Refer to 
Table 2.3 for recommended settings. The PQR can 
have adjustable parameters for both the transient 
and disturbance recording.

Figure 2.50  Recorder Configuration Window - Acquisition Parameters
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* PQR requires the Extended Waveform option to modify the transient 
recording times.
+ On larger TR-2000 systems, at higher sample rates, the buffer memory 
limits the maximum record size. 

Transient Tab

Pre-fault Number of cycles to record before a fault occurred 

Min post-fault Minimum number of cycles to record during a fault 

Safety window Number of normal cycles that must be recorded 
after all new triggers return to normal state, 
including hysteresis, before recording terminates. 

Max record size The maximum size of a record in seconds 

Disturbance Tab

Pre-fault Number of seconds to record before disturbance 
occurred 

Min post-fault Number of seconds to record during a disturbance 

Safety window Number of normal cycles that must be recorded 
after all new triggers return to normal state, 
including hysteresis, before recording terminates. 

Max record size The maximum size of a record in seconds

Table 2.3  Acquisition Transient and Disturbance Tab Settings

Recording times TR100 TR100+ TR2000 + PQR *

Pre-fault (Trans) 2 – 600 c 2 – 300 c 2 – 600 c 4 – 30 c

Min post-fault 8 – 100 c 8 – 100 c 8 – 100 c 4 – 50 c

Safety window 0 – 16 c 0 – 16 c 0 – 16 c 0 – 20 c

Max record length 1 – 60 c 1 – 30 c 1 – 60 c 1 – 2 c

Pre-fault (Dist) NA 2 – 600 s 10 – 600 s 1 – 10 s

Min post-fault NA 4 – 300 s 30 – 300 s 1 – 10 s

Safety window NA 0 – 120 s 0 –120 s 0 –20 s

Max record length NA 10 – 1200 s 60 – 1800 s 1 –2 s
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Sample Rate Sets the rate at which the recorder samples the data 
on each channel. To adjust the sample rate:

• Select a new sample rate from the drop down. 
For TR2000 recorders, the rate at which digital 
samples are sampled can be set independently 
of analog channels. To select a new digital 
sample rate, select the required rate from the 
Digital sub counter drop down.

Harmonics The configuration is different for:

• ”Harmonics Configuration – TR100” on page 2-60
• ”Harmonics Configuration – TR2000, TR100+ & PQR” 

on page 2-61

Use this window (Figure 2.51) to set up the parameters for recording and 
retrieving harmonic data.

Figure 2.51  Harmonics Configuration
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Harmonics 
Configuration – 
TR100

Use this window (Figure 2.52) to set up the parameters for recording and 
retrieving harmonic data.

Figure 2.52  Harmonics Configuration - TR100

Buttons and Fields

Measurement Group

Use the phase group drop down to choose which 
phase group to use for recording harmonics.

Timing Set up a recorder to record harmonic data on a 
weekly or a monthly basis. 

TR100 Harmonics
Configuration

Operations

To configure TR100 Harmonics:

1. Click either the:

• Week radio button and select a weekday from the drop down. 
• Month radio button and enter a day of the month in the edit box.

2. Enter the time of day for the harmonic recording to start in the Start 
Time.

3. Enter a value in the Number of Samples field and enter the Number of 
Harmonic Samples, if required. Samples can be taken every 10, 30 or 
60 minutes. The total time being recorded is appears in the blue edit 
box at the bottom of the main window.

4. Click OK.
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Harmonics 
Configuration – 
TR2000, 
TR100+ & PQR

A TR2000, TR100+ & PQR records harmonics over all phase groups 
continuously. This creates a harmonic log that can be recovered 
manually or automatically during auto-poll. Automatic recovery is 
enabled in the auto-poll menu and the individual parameters are set in 
each recorder.

Buttons and Fields

Record retrieval times

States the number of hours of harmonic data to 
retrieve when the recorder is auto-polled. During 
an autopoll, if the option to get harmonics is set, 
the recorder sends back the number of hours of 
harmonics data required or at least from the start of 
the current logger block if it is fragmented.

Record interval Specifies the intervals at which the harmonics data 
is retrieved. Choose from 10, 30 or 60 minutes. 
The default is 10 minutes.

Record Format Select the data to retrieve for each harmonic. The 
options available are:

• Average - Average magnitude of Harmonics 
over a specified time period.

• Max, Min, Average - Max, Min and Average 
magnitude of Harmonics over a specified time 
period.

• Max, Min, Average, Magnitude & angle - Max, 
Min and Average magnitude of Harmonics over 
a specified time period and the Magnitude and 
angle at the start of that period.

• Magnitude, Angle - Magnitude and angle of 
Harmonics at the start of each specific time 
period.

The TR100+ records only the average harmonic 
values.

Maximum number of Harmonics

Enter the maximum number of harmonics to 
retrieve. Allowed values are 1- 64.
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TR2000, 100+
and POR

Harmonics
Configuration

Operations

To configure TR200, TR100+ and PQR harmonics:

1. Click Harmonics and the Harmonics Configuration dialog appears 
(Figure 2.51).

2. Use the spinner to set the Retrieval times in hours to capture back to.

3. Use the spinner to set the Record interval in minutes.

4. Use the spinner to set the Record format.

5. Enter the Maximum number of harmonics.

6. Click OK.

Record Reduction Record reduction consists of:

• ”Record Reduction – Transient (TR2000 & TR100+)”
• ”Record Reduction – Disturbance (TR2000 & TR100+)” 

on page 2-63
• ”Record Reduction – Disturbance logger (TR2000)” on page 2-64

Record 
Reduction – 
Transient                                   
(TR2000 & 
TR100+)

Use this window (Figure 2.53) to reduce the amount of transient record 
data downloaded from a recorder during auto-poll, auto-call or a manual 
connection. The data specified here is selected from the records of the 
recorder. The complete records are left on the recorder and can be 
downloaded at a later stage, if required.

Figure 2.53  Record Reduction Parameters - Transient Tab

Buttons and Fields

Channel Selection Select channels for download. To select multiple 
channels hold down the <Shift> or <Ctrl> keys 
while clicking on the channel names.
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Sample rate Use the drop down to select a sample rate for the 
reduced data. The samples per cycle for the 
selected sample rate appear to the right.

Record Length Use Pre-fault to enter the number of pre-fault 
cycles to retrieve. This is taken immediately before 
the trigger point (range 2 - 100).

Use Post-fault to enter the number of post fault 
cycles to return. This is taken from immediately 
after the trigger point. (range 2-100).

NOTE Pre/post settings are not compared to the recorder configuration to 
ensure values set are less than actual settings.

Record 
Reduction – 
Disturbance 
(TR2000 & 
TR100+)

Use this tab (Figure 2.54) to reduce the amount of disturbance record 
data downloaded from a recorder during auto-poll, auto-call or a manual 
connection. The data specified here is selected from the records of the 
recorder. The complete records are left on the recorder and can be 
downloaded at a later stage if required.

Figure 2.54  Record Reduction Parameters - Disturbance Tab

Buttons and Fields

Channel Selection Select channels for download. To select multiple 
channels hold down the <Shift> or <Ctrl> keys 
while clicking on the channel names.
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Record Length Use Pre-fault to enter the number of pre-fault 
seconds to retrieve. This is taken immediately 
before the trigger point (range 10 - 600).

Use Post-fault to enter the number of post fault 
seconds to return. This is taken from immediately 
after the trigger point (range 30-300).

NOTE Pre/post settings are not compared to the recorder configuration to 
ensure values set are less than actual settings.

Digital data (TR2000 & TR100+)

Check this box to include the digital data with the 
record. This can be viewed in SER format from the 
record header window.

Sample rate Reduces the effective sample rate from 100 
samples per second to 50 or 25. For a 60 Hz 
system the value is reduced from 120 to 60 or 30.

Record 
Reduction – 
Disturbance 
logger (TR2000)

Use this tab (Figure 2.55) to select download channels.

Figure 2.55  Record Reduction Parameters - Disturbance Logger Tab

Buttons and Fields

Channel Selection Select channels for download. To select multiple 
channels hold down the <Shift> or <Ctrl> keys 
while clicking on the channel names.
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Record Reduction
Operations

To configure record reduction parameters:

1. Click Reduced records and the Record reduction parameters dialog 
appears (Figure 2.53).

2. Configure the Transient tab by:

a. Selecting an Analogue and/or a Digital channel.
b. Using the spinner to set the Sample rate.
c. Enter the Record length Pre-fault and Post-fault in cycles.

3. Configure the Disturbance tab by (Figure 2.56):

Figure 2.56  Record Reduction Parameters - Disturbance Tab

a. Selecting an Analogue channel(s).
b. Using the spinner to set the Sample rate.
c. Enter the Record length Pre-fault and Post-fault in cycles.
d. Click the Retrieve digital data check box, if required.
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4. Configure the Disturbance Logger tab by (Figure 2.57):

Figure 2.57  Record Reduction Parameters - Disturbance Logger Tab

• Selecting an Analogue channel(s).

5. Click OK.

System Clock Use this window to check the time and date of a recorder and to set it to 
the same time as the local PC.

Figure 2.58  System Clock

Buttons and Fields

System time Shows the time on the recorder.

Local Time Shows the time on the PC.

Adjustment Shows the difference between the two clocks.

Adjust System Time Sets the recorder time to the same time as the PC. 
This can only be done on a TR2000 if there is no 
GPS clock present.
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If there:

• Is a GPS clock a G appears after the time if it 
locked to GPS time

• Is not a GPS clock an X appears.

Recorders with serial time code inputs can be 
updated but the time reverts to the serial code if it 
is present and valid. When the time is locked to a 
serial time code an L appears after the time. An 
automatic time update can be done during 
Auto-poll (see ”Options” on page 2-26).

If the PC running DS32 has daylight saving (DLS) 
enabled, then the recorders that are synchronized 
from it will also include DLS. A TR2000 that is 
synchronized to GPS will not include DLS. If DLS 
is required, change the GMT Deviation value by 
one hour.

GMT Deviation (TR2000) 

Used to express the time difference between the 
recorder and UTC, that is the time derived from the 
GPS receiver in the TR2000. This is the time zone 
the recorder is in relative to GMT; e.g. the GMT 
deviation for the east coast of USA is –5:00 hours 
or -300 minutes, if there is no DLS active.

System Clock
Operations

To configure the system clock:

1. Click Configure system time and the recorder time System clock 
dialog opens (Figure 2.59).

Figure 2.59  System Clock

2. Use the GMT Deviation spinners to adjust the time and click Adjust 
system time.
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A warning appears (Figure 2.60).

Figure 2.60  System Clock Warning

3. Click Yes.

Input Channels Use this to set up the recorder input channel(s) parameters. For TR100 
recorders, Analog channels, Digital Channels, Phase groups and 
frequency channels are configurable. For TR2000, TR100+ & PQR 
recorders line groups are also configurable, i.e. the combination of the 
voltage and current for a particular line or feeder.

The Input Channel Selection window has six possible sections:

• ”Analog channels” on page 2-68
• ”Digital Tab (TR100, TR100+ & TR2000)” on page 2-71
• ”Phase Groups Tab” on page 2-72
• ”Frequency Tab” on page 2-73
• ”Line Group Tab(TR2000, TR100+ & PQR)” on page 2-74
• ”Phasor Display (TR2000 with synchrophasor option)” 

on page 2-75

Analog channels This tab lists of the analog channels available. Select multiple channels if 
configuring them for the same values.

Buttons and Fields

Channel Name Enter up to a 16-character name to identify each 
channel with meaningful text.

Nominal Enter the normal RMS line voltage or current. This 
is used when values that are displayed as a 
percentage of nominal or PU are required such as 
trigger levels. Give neutral current channels a 
non-zero value so PU triggers can be set.
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Full scale Enter the maximum RMS line level for use as the 
scaling factor for each analog channel. The value 
for a voltage channel is:

• VT primary * 212.13 / VT secondary
• For a current channel with an interposing CT 

the maximum level is:
• CT primary * 1.41412 / (CT secondary / ratio * 

burden)
• For a current channel with a shunt resistor the 

maximum level is:
• CT primary * 20 * nominal shunt value/CT 

secondary

Specify the full-scale levels for a current channel at 
least as large as the maximum expected fault 
current. This is fixed based on the output of the 
shunt or interposing scaling CT.

Specify a full-scale value for transducer inputs that 
is the maximum value corrected for the input 
voltage level. This is 300V for a voltage type or 2V 
for a current type. The TR2000 and TR100+ have a 
12V max. input level available. Other input levels 
can be specified as a 4th range for these recorders 
for special applications.

Adjust the full-scale level value slightly to correct 
for errors in transformer ratios, amplifier gains, etc. 
If a reliable true RMS signal level is known for an 
input voltage or current and it differs from the 
value shown in the analog channel trigger display, 
correct the value by adjusting the full-scale level 
thus:

• New full-scale = Old full-scale * measured 
value / required value

Take care when correcting current channels as 
normal load current levels are small compared to 
the full-scale value. For VT (PT) or CT signals the 
Full Scale would normally be quoted as a primary 
value.
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Units Enter up to an eight character text string normally 
be chosen from: A, kA, V or kV or can be any valid 
engineering unit. It is passed with the record data 
to the display and to DSA so that data appear in 
real units. 

Frequency Channel (TR2000)

Select the frequency channel for use in correcting 
calculations for the selected channel. The 
calculation of RMS, phasor and harmonic levels 
are slightly affected by changes in system 
frequency. By selecting a frequency channel these 
effects are minimized. This correction is 
automatically set for the TR100+ & PQR.

Channel Set-up (TR2000 & TR100+)

Defines the input signal as either AC or DC or OFF. 
Defining a signal as AC or DC is used to determine 
whether the Full Scale value is an RMS quantity. 
Inputs from normal VTs and CTs are AC and most 
transducers are DC. 

By defining an input as OFF the input data is not 
processed, downloaded or included in a fault 
record. This saves communications bandwidth and 
disk storage space.

Phase Correction (TR2000, TR100+ & PQR)

Enter the phase correction value associated with an 
interposing CT. This value is used to correct RMS 
and vector calculations for power and impedance. 
The procedure for this is included with the 
calibration manual. 
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Digital Tab 
(TR100, TR100+ 
& TR2000)

This tab (Figure 2.61) sets the parameters of the recorder's digital 
channels.

Figure 2.61  Input Channel Selection - Digital Tab

Buttons and Fields

Channel Name Enter up to a 16-character name to identify each 
channel with meaningful text. 

Normal state Click Open or Closed to dictate the normal state of 
the input contact. For a normally closed input there 
is current flowing through the input circuit.

Enable channel profiling

Enable and the recorder creates a list of all digital 
channel transitions on enabled channels within a 
fault or disturbance record so this data is available 
when retrieving only a record profile.

In Use (TR2000) Turns an unused channel off completely.
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Phase Groups 
Tab

This tab (Figure 2.62) lists the channels that make up a three-phase 
voltage or current group to help the graphical display of recorded data 
and for sequence component triggering. Four phase groups can be 
defined in a 16 channel system and two are possible in an 8 channel 
one. There are 10 phase groups available on both the 24 and 32-channel 
systems.

The Phase Group Name list consists of a list of the phase groups already 
defined and a group of controls used for selecting the channels for each 
group. All phase groups should be defined even if they are not used.

Figure 2.62  Input Channel Selection - Digital Tab

Buttons and Fields

Phase Group Channels

Select the appropriate channels for each phase 
group. Once a change is made, it appears 
immediately in the list above.

It is important for correct sequence component 
triggering that the channels selected for the A, B & 
C phases are in positive sequence order.

Phase Group Name Enter up to a 16-character name used to identify 
the phase group with meaningful text.
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Voltage Set-up (TR2000, TR100+ & PQR)

Set the type of voltage measurements for use as 
either phase-to-phase or phase to neutral. This 
controls the computation of power.

Flicker Phase Group (TR2000)

Defines the voltage phase group used to record 
flicker in a TR2000. If the current configuration 
belongs to a pseudo recorder then a Flicker Phase 
Group can be set up for each individual recorder.

Frequency Tab This tab (Figure 2.63) defines an analog channel for measuring system 
frequency. A TR100, TR100+ & PQR recorder allows one frequency 
channel to be specified and a TR2000 allows two. To ensure an accurate 
frequency measurement a voltage input is better than a current and phase 
– phase is better than phase – neutral.

Figure 2.63  Input Channel Selection - Frequency Tab

Buttons and Fields

Frequency measurement channel one/

Frequency measurement channel two

Select the Channel for each.
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Analogue channel range (PM)

Set up frequency channel, if the current 
configuration belongs to a pseudo recorder, for 
each individual recorder. To select the range of 
Analogue channels to pick from:

• Click on the down arrow to the right of the field 
and click on the required range.

Line Group 
Tab(TR2000, 
TR100+ & PQR)

Use this tab (Figure 2.64) to define a line group. A line group is made up 
of two phase groups, one voltage, one current, both from the same line. 
This is used to compute power and impedance. Define all line groups, 
even if they are not used.

Figure 2.64  Input Channel Selection - Line Group Tab

Buttons and Fields

Line Group Name Enter up to a 16-character name to identify each 
channel with meaningful text. 

Line Group Phases Enables the selection of the phase groups for each 
line group:

• Voltage Phase - Select a voltage phase group 
for the line group. The units must be V or kV.

• Current Phase - Select a current phase group for 
the line group. The units must be A or kA.
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Line Group Channels

Enables the selection of the neutral channels for 
each line group:

• Voltage Neutral - Select a channel to associate 
the neutral voltage to this line group. If none is 
available select (none).

• Current Neutral - Select a channel to associate 
the neutral current to this line group. If none is 
available select (none).

Phasor Display 
(TR2000 with 
synchrophasor 
option)

This window (Figure 2.65) sets up a TR2000 recorder for exporting PMU 
data using the IEEE C37.118 format and for making differential 
synchrophasor measurements. 

Figure 2.65  Phasor Display
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Differential synchrophasor triggering

In the Phasor display configuration screen there are 
two sections, Local and Remote:

• The Local section refers to the recorder that is 
currently being configured.

• The Remote section refers to the other recorder 
that is being used to make the comparisons. 
The details of the Remote section only appear if 
the other recorder is currently connected and 
set up correctly. Both recorders receive PMU 
data from the remote end and compute the 
absolute angle difference and rate of change of 
angle difference.

C37.118 IEEE Standard for Synchrophasors

When configured, the TR2000 responds to requests 
for Header and Configuration frames. The Data 
frames are on by default but can be turned off by 
using the Data Off command. The Phasor data is in 
signed 16-bit integer Cartesian format. For more 
information on the implementation of the C37.118 
standard see the TR2000 Application note on 
Synchrophasor Output

Buttons and Fields

Information

• Header
• Station Name
• ID

These three fields uniquely identify the recorder. To 
edit the Header text click on the square button to 
the left. The communications format conforms to 
IEEE C37.118 that has not yet been ratified.

Baud Rate Sets the Baud rate for the two recorders. The same 
rate must be set at both ends of the line. When 
selected, the communications link is made from 
the Remote comms connector at the rear of the 
TR2000.
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Period Sets the period used to set the rate at which 
synchrophasor data frames are sent and received. 
As this value gets lower, the sample rate gets 
higher. The same period must be set at both ends of 
the line. The unit of period is one hundredth of a 
supply cycle; i.e. a period of 200 would output a 
PMU data frame every 2 cycles. These frames are 
synchronized to the 1PPS frame marker from the 
GPS receiver.

Phase Group This sets the Phase Groups for monitoring by the 
recorder.

To select a phase group:

• Click Add.

To remove a phase group:

• Select it and click Remove.

The order in which phase groups are added is 
important. When differential phasor triggering is in 
use, the phase group at the local end is compared 
with the phase group at the remote end that has the 
same number. The maximum number of phase 
groups is 10. 

Differential synchrophasor triggering is set up in 
the Disturbance Triggers - Phase Difference 
window.

Analogs Select analog channels for inclusion in the PMU 
output frame. These would normally be inputs that 
are not used in the generation of the selected Phase 
Groups. Analog channels are not used for 
differential triggering.

Digitals Select the digital channels for inclusion in the PMU 
output frame.
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Input Channel
Operations

To configure input channels:

1. Click Input channels and the Input channel selection dialog appears 
(Figure 2.66).

Figure 2.66  Input Channel Selection - Analogue Tab

2. Configure the Analogue tab by:

a. Entering/editing the Channel Name.
b. Selecting a channel in the display area.
c. Using the down arrow to select a Frequency Channel.
d. Use the down arrow to select a Channel Setup.
e. Enter values for Nominal and Full Scale.
f. Use the down arrow to select Units.
g. Enter a Phase Connection.
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3. Configure the Digital tab by (Figure 2.67):

Figure 2.67  Input Channel Selection - Digital Tab

a. Entering/editing the Channel Name.
b. Selecting a channel in the display area.
c. Click a Normal state radio button.
d. Click an In use radio button.
e. Click Enable channel profiling, if required.
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4. Configure the Phase Group tab by (Figure 2.68):

Figure 2.68  Input Channel Selection - Phase Group Tab

a. Entering/editing the Channel Name.
b. Selecting a Phase Group Name in the display area.
c. Using the down arrow to select a Phase Group Channel for 

each phase.
d. Using the down arrow to select a Flicker Phase Group.
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5. Configure the Frequency tab by (Figure 2.69):

Figure 2.69  Input Channel Selection - Frequency Tab

• Using the down arrow to select a channel for Frequency 
measurement channel one and Frequency measurement channel 
two, if required.
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6. Configure the Line Group tab by (Figure 2.70):

Figure 2.70  Input Channel Selection - Line Group Tab

a. Entering/editing the Line Group Name.
b. Using the down arrow to select a Voltage Phase and Current 

Phase for the Line Group Phases.
c. Using the down arrow to select a Voltage Neutral and a Cur-

rent Neutral for each Line Group Channel.

7. Configure the Phasor Display tab by (Figure 2.65 on page 2-75), if 
applicable, by:

a. Clicking Add to add a new Phasor group on the Phasor Group 
tab.

b. Entering Header, Station name and ID names.
c. Using the down arrow to select a Baud rate and Period.

8. Click OK.
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Peripherals Use this window (Figure 2.71) to set up the peripheral devices for the 
recorder. The actual items shown depend on the type of recorder and the 
options chosen at time of order.

There are six peripherals available: 

• Modem - Sets up a modem-to-modem connection between the 
recorder and Display Station. If the modem is internal to the 
recorder the default port is COM 3. This leaves the rear port 
(COM 2) for DNP, serial time code or synchrophasor (TR2000).

• Fax - Sets-up a recorder to fax records on auto-call. This uses the 
fact that the data modem is also fax compatible. The fax output of 
a record is similar to the printed output from the recorder.

• Network - Shows the connection parameters of a recorder when it 
is connected over a network.

• Printer - Is only available if there is a printer selected on the 
configuration switches of the recorder.

• Distributed Network Protocol - Edit the parameters for a DNP 
connection, if embedded in the recorder firmware.

• Serial clock - Is only available when the recorder is configured for 
linking to an external serial clock. The clock is connected through 
the recorder's rear serial port. This option cannot be used at the 
same time as the DNP 3.0 option. This is also used for some 
IRIG-B systems. The addition of a PC 104 card or similar device 
allows a serial time interface in parallel with DNP or PMU.
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Figure 2.71  Recorder Peripherals - Modem Tab

Modem Tab Buttons and Fields

Modem String

Init String Click the check box and enter an initialization 
string for the modem. The character ^M translates 
to an ASCII carriage return and ~ translates to a 
half second delay (entered between commands). 
The default initialization string, which is suitable 
for most modems, is:

AT&F^M~~~~ATS0=1^M

For US Robotics modems the initialization string is:

AT&F^M~~~~ATE1&B1C1&D2S0=2S7=120^M

Dialing Prefix Click the check box and enter the string that 
precedes the phone number. This is used to 
determine the type of dialing – tone or pulse. This 
normally is:

ATDT
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Communications port

Baud rate Select the data rate for the recorder to talk to the 
modem. This should be greater than the connect 
speed of the modem: i.e. for a 33600 modem use a 
baud rate of 57600.

Inactivity timer Enter the length of time a recorder stays connected 
if no communications are occurring (range 2 – 30). 
This limits costly long distance bills after 
inadvertently leaving a recorder connected.

Auto-call

Switch on and the recorder automatically calls the 
PC when a new fault is recorded.

NOTE Auto-call is via either modem or TCP/IP, not both.

Phone Number Enter the number to dial.

Auto-call parameters

Connect time Enter the amount of time a recorder waits for a call 
to be answered (range 3 – 300).

Retry pause Enter the length of time between the end of one 
dial attempt and the start of the next (range 0 – 
999).

Retries Enter the number of times a recorder tries to 
connect to a PC before giving up (range 0 – 99).

DTR control Activate to drop DTR when the connection is 
inactive. This required for some modems.

Fax Tab

Buttons and 
Fields

Auto fax Click either/both buttons to activate: Alarms and 
Records:

• Alarms sends internal alarms to the fax when 
they occur. 

• Records sends transient records to the fax when 
they occur.

Phone number Enter the fax phone number.

Init string Enter the init string for the recorder modem.
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Fax options Use the drop downs to select display options for 
the target fax. They are not normally changed from 
the defaults.

Comms Options Use the drop downs to select the communications 
options between the recorder and the target fax. 
These are not normally changed.

Connection Parameters

Attempt pause Enter the length of time to delay between each 
attempt at dialing the fax.

Attempts Enter the number of times to try re-dialing the fax 
before quitting.

Network Tab

Buttons and 
Fields

Network Parameters

IP Address, IP Subnet Mask and Router IP Addr

Enter values in the fields to give the recorder a 
unique identity on the network. These parameters 
can only be changed when the recorder is 
connected to the PC directly using the RS-232 port.

Auto-call

Auto-call Switch on and the recorder automatically calls, via 
TCP/IP, the PC when a new fault is recorded.

IP address Enter the address of the host PC. If this is used the 
Router IP Addr must also be entered. The host PC 
must have a fixed address. DCHP is not supported.

Auto-call connection parameters

Retry pause Enter the number of seconds a recorder waits after 
trying to connect to a PC before trying again (range 
0 – 999).

Retries Enter the number of times the recorder attempts to 
connect to the PC (range 0 – 99).

Distributed Network Protocol Tab (DNP 3.0)

Buttons and Fields

DNP Parameters 

IED Address Set a number to identify the recorder on the 
network (range 1 – 65534).
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Transmission delay Set the time to disable the master transmitter on an 
RS485 network (range 0 – 65535) (not currently 
used).

Data Link Confirm

Confirm mode Set as Never, Sometimes or Always. The default 
value is Never.

Retries Set the number of times the recorder retries to 
connect if Data Link confirmation is required 
(range 0 – 255).

Time-out Set the time the IED waits for a Data Link 
confirmation. Valid numbers are 0 – 65535.

Select/Operate arm time

Set the time period after the select command is 
received that the operate command is performed 
(range 0 – 65535) (Not currently used.)

Communications port

Enter the Baud rate of the recorder's rear serial 
port.

Printer Tab (TR100, TR100+ & TR2000)

Buttons and Fields

Printer type Select a printer type from the drop down. This 
defines the escape sequences used by the recorder 
to set the output printer for graphics printing. The 
range of available printers includes dot matrix, ink 
jet and laser types. Most printers can be set to 
emulate the Epson FX80 or IBM Proprinter.

Auto print Select Auto print and the recorder prints all records 
and events as they occur. This can be switched off 
during set-up to disable records generated during 
testing from being printed. 

Serial Clock Tab

Buttons and Fields

Serial Clock parameters

Time Code Select a time code type. LER (RCC8000), NGTS 
3.7.9 & IRIG-B are supported.
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Baud rate Select the baud rate for communication. IRIG-B 
defaults to 9600 baud.

Serial Format Select the appropriate data bits, parity and stop bits 
for communication with the clock. For NGTS 3.7.9 
the default format is 7 data bits, 2 stop and even 
parity. IRIG-B defaults to 8 bits, 1 stop and no 
parity.

Peripherals
Operations

To configure the peripherals list:

1. Click Peripherals and the Recorder Peripherals dialog appears with 
the Modem tab active (Figure 2.72).

Figure 2.72  Recorder Peripherals List - Modem Tab

2. Configure this tab by:

a. Clicking the Int. String and Dialing prefix check boxes to acti-
vate the fields and enter values, as required.

b. Using the down arrow to select a Communications port Baud 
rate.

c. Click on/off in Auto call and enter a Phone number, then 
enter values in all the Auto call parameter fields.

d. Click the Drop DTR when no connection active check box.
e. Enter a value in the Inactivity timer field.
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3. Configure the Network tab by (Figure 2.73):

Figure 2.73  Recorder Peripherals List - Network Tab

a. Entering values in the IP Address, IP Subnet Mask, and Router 
IP Addr fields.

b. Clicking on/off in Auto call and entering:
• An IP Address
• Retry pause and Retries.
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4. Configure the Fax tab by (Figure 2.74):

Figure 2.74  Recorder Peripherals List - Fax Tab

a. Clicking on/off for Alarms and/or Records and entering:
• A Phone number
• An Int string

b. Using the Fax options down arrows to select a:
• Page length
• Scan line time - recommended setting is Coarse 10 ms, 
Fine 5 ms
• Vertical resolution

c. Using the Comms options down arrows to select a:
• Bit rate - set the speed no faster than 1/4 the modem speed
• Flow control
• Modem class

d. Entering values in the Connection parameters:
• Attempt pause
• Attempts

5. Click OK.
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Password Use this dialog to configure password security to the connected recorder.

Password
Operations

To add a password:

1. Click Password.

The Recorder Password Dialog appears (Figure 2.75).

Figure 2.75  Recorder Password

2. Enter a password in Type Password and Confirm Password.

3. Click the Save Password check box to save the password as part of 
the recorder's network details allowing for seamless connections to 
that recorder in the future.

4. Click OK.

The Recorder Configuration window reappears.

5. Click Setup to assign the password to that recorder.

Transient Trigger 
Settings

Use this window (Figure 2.76) to set up the conditions that make a 
recorder recognize a fault condition and transient record. There are five 
tabs for transient trigger settings:

• Analog Tab
• Digital Tab
• Phase Group
• Frequency
• External (PQR)
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Figure 2.76  Trigger Settings - Analogue Tab

Analog Trigger 
Tab

Four types of triggering can be set for the analog channels: Over Trigger, 
Under Trigger, Rate of Change and THD (or Sub-cycle drop out for a 
TR100).

Buttons and Fields

on/off Enables/disables each trigger type.

Over trigger/Under trigger indicator

Each has a triggered state indicator to the right of 
the controls. When a recorder is connected, if 
either of the level trigger values causes a trigger 
condition, then this indicator turns red as a 
warning. This is an indication only and may not be 
accurate if the waveform is distorted.

Channel Name

Select the analog channel for which the triggering 
levels are to be set.

Over Trigger % Sets a high threshold which, when exceeded by a 
single cycle RMS level of the channel, causes a 
trigger condition. The trigger condition continues 
as long as the signal is over the threshold level. 
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The blue background box shows the actual RMS 
value that the channel has to reach before 
triggering. The threshold is calculated as a 
percentage of the channel’s nominal value.

Under Trigger % Sets a low threshold which, when dipped below by 
a single cycle RMS level of the channel, causes a 
trigger condition. The trigger condition continues 
as long as the signal is under the threshold level. 

The blue background box shows the actual value 
that the channel has to dip below before triggering. 
The threshold is calculated as a percentage of the 
channel’s nominal value.

Hysteresis - Over trigger/Under trigger

Dictates the difference between the levels required 
to initiate and terminate a level trigger. The value is 
defined as a percentage of the channel’s nominal 
value. For example, a 150% over trigger with a 5% 
hysteresis requires the input level to exceed 150% 
of the nominal value to start a trigger condition and 
a level of less than 145% to end it. Hysteresis is 
most useful for stopping multiple triggers being 
generated if the signal level is close to the trigger 
level.

Rate of change trigger

This is a more sensitive mode than threshold 
triggering, as it is independent of normal input 
variations, i.e. the daily and annual cycles of load 
current. For correct application, the pre-fault 
length must be longer than the duration of the rate 
of change. Rate of change triggering is based on a 
peak signal measurement in the TR100 and an 
RMS signal in the TR2000, TR100+ and PQR. Two 
values are required to define a rate of change 
trigger:
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% - Select the percentage change in the input level 
over which the change is measured. The 
percentage is that of the pre-fault level so the 
absolute change is smaller for smaller signals. The 
minimum change that triggers a record is 
equivalent to 1% of the full-scale value. The 
change can be positive or negative. 

Cycles - Select the number of cycles over which 
the change is measured.

Sub Cycle Drop Out (TR100)

Activate this trigger mode for very subtle single 
cycle distortion events to be recorded. The purity 
of the input signal is measured and variations are 
recorded as a percentage difference in the area of 
the input signal relative to a sinusoidal waveform 
with the same peak amplitude. Enter the difference 
in the field, the minimum being 5%. For this trigger 
mode the trigger point is marked as the start of the 
half cycle that contains the variation.

Total Harmonic Distortion (TR2000, TR100+ & PQR)

Activate this trigger mode and set the percentage 
(%) to use the TR2000, TR100+ & PQR for quality 
monitoring. The maximum permissible level of 
THD can be set for each channel. THD is 
computed using the fundamental and RMS values 
every half cycle. This trigger responds to single 
cycle events.

Waveform Display Shows a waveform if a recorder is currently 
connected and displays the signal from the 
currently selected channel. Over and Under 
triggers appear on the display as blue and green 
lines respectively. Hysteresis values are indicated 
by dashed lines.

At the bottom of the display, two edit boxes show 
the signal RMS value, in real units and as a 
percentage of the defined nominal value. This is an 
estimate based on peak values and will not be 
accurate if the waveform is distorted.
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Digital Tab Figure 2.77 shows the Digital tab.

Figure 2.77  Trigger Settings - Digital Tab

Buttons and Fields

Channel details Displays the name of the channel currently 
selected.

Current State Displays the current state of the channel, either 
Normal or Alarm, if a recorder is currently 
connected.

on/off Enables/disables triggering on the selected 
channel.

Trigger Type Level triggering causes triggering when the channel 
goes from normal to alarm state and keeps 
recording until the channel returns to normal state. 
Edge triggering, in concert with selecting the 
Return to Normal check box, causes both the 
Normal to Alarm and Alarm to Normal changes to 
generate a minimum length record, if this is the 
only trigger present.
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Debounce Set a debounce value for all the digital input 
channels. This can be from 1 to 10 ms. Inputs must 
remain stable for this time before a change of state 
is recognized. The transition time is taken as the 
original change of state.

Phase Group 
Tab

Figure 2.78 shows the Phase Group tab.

Figure 2.78  Trigger Settings - Phase Group Tab

Buttons and Fields

Phase Group Name

Lists box holds a list of the phase groups for the 
recorder. To edit the trigger settings for a phase 
group, select it from the list.

Channel Names Displays the phase group constituent channels (A, 
B & C) and the nominal value for the first channel 
(100% = ). This nominal value is used as a 
reference for calculating the thresholds of the 
phase group triggers.

on/off Enables/disables each type of triggering.
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Zero Sequence Trigger

The zero sequence value is calculated by adding 
the three components of the phase group with no 
vector rotation. In a balanced system the result is 
zero.

% Enter a percentage of the nominal, which the 
magnitude of the result exceeds before a fault is 
triggered. In the TR2000 and TR100+ this can be 
set to a resolution of 0.1%.

Negative Sequence Triggering

The negative sequence value is calculated by 
adding the three components of the phase group 
with negative vector rotation. In a balanced system 
the result is zero. 

% Enter a percentage of the nominal, which the 
magnitude of the result exceeds before a fault is 
triggered. In the TR2000 and TR100+ this can be 
set to a resolution of 0.1%.

Positive Sequence Triggering (TR2000 & TR100+)

The positive sequence value is calculated by 
adding the three components of the phase group 
with positive vector rotation. In a balanced system 
the result equals the nominal value. 

Over Trigger Enter a percentage of the nominal that the 
magnitude of the result exceeds before a transient 
record is triggered.

Under Trigger Enter a percentage of the nominal that the 
magnitude of the result dips below before a 
transient record is triggered.

Rate Of Change Trigger (TR2000 & TR100+)

Rate of Change trigger 

Select a percentage by which the rate of change 
must change before causing a trigger situation. The 
trigger is calculated from the rate of change of the 
result of the positive sequence calculation.

Cycles Enter the number of cycles across which the rate of 
change is calculated.
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Waveform Display Displays the waveform if a recorder is currently 
connected showing the signals from the selected 
phase group. Below the display the computed 
positive, zero and negative sequence levels are 
displayed. This is also a convenient way to verify 
proper input wire and system configuration.

Triggered State Indicator

The sequence triggers (+, - and 0) have a triggered 
state indicator. When a recorder is connected, if 
any of the set values of the triggers would causing a 
trigger condition, then this indicator becomes red 
as a warning.

Frequency Tab A TR2000 recorder can have two frequency channels, a TR100 and 
TR100+ only one.

Figure 2.79 shows the Frequency tab.

Figure 2.79  Trigger Settings - Frequency Tab
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Buttons and Fields

on/off Enables/disables each type of triggering.

Frequency measurement channel 1 & 2 

Both of these sections have identical functions. For 
a TR100 or TR100+ configuration, the Frequency 
measurement channel 2 is disabled.

Channel 1/Channel 2 

Displays the name of the channel selected to act as 
the frequency channel.

Current Frequency Displays the frequency currently being measured 
for a connected recorder.

Under Trigger Enter a lower frequency limit. If a frequency is 
detected which is less than this setting for greater 
than two cycles then the recorder is triggered.

Over Trigger Enter an upper frequency limit. If a frequency is 
detected which exceeds this setting for greater than 
two cycles then the recorder is triggered.

Rate of change trigger

Enter two values to define a rate of change of 
frequency trigger:

• Rate of change trigger - the change in absolute 
frequency.

• Cycles - the number of cycles over which the 
change is measured.

The maximum interval for rate of change is 8 
cycles. Both positive and negative changes are 
recorded. Only changes within 40 - 60 Hz are 
accepted for a 50 Hz system and only changes 
within 50 – 70 Hz are accepted for a 60 Hz system.

Frequency difference (TR2000)

Displays the difference in frequency between 
frequency channel 1 and frequency channel 2 for a 
connected recorder. For a TR100 or TR100+ 
configuration, the Frequency difference section is 
disabled.
1086-339  Rev. A   11/05 2-99



Display Station 32 Software
Frequency difference trigger (TR2000)

Enter a value in Hz as the difference in frequencies 
of frequency channel 1 and frequency channel 2 
that if exceeded causes a frequency difference 
trigger.

Analogue channel range (PM)

Select the range of Analogue channels to pick from 
by clicking on the Analogue channels drop down, 
then click on the required range. If the current 
configuration belongs to a pseudo recorder then 
triggering for frequency channels can be set up for 
each individual recorder. For Frequency difference 
triggering the two source channels must be in the 
same recorder.

External Tab (PQR)

Select a radio button for the normal state of the 
PQR digital input that triggers the recorder. This 
input is not recorded. A normally closed contact 
has current flowing through the input circuit.
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Disturbance 
Triggers (TR2000)

Use this window (Figure 2.80) to set up the conditions that makes a 
TR2000 recorder recognize a disturbance fault. There are eight trigger 
tabs:

• Analog Fundamental - Sets up a recorder to trigger on changes to 
the fundamental of an analog channel. There are three types of 
trigger available: Over trigger, Under Trigger and Rate of Change 
Trigger.

• Power - Sets up a recorder to trigger on variations of power of a 
line group.

• Voltage Imbalance - Is the ratio of the negative phase sequence 
over the positive phase sequence expressed as a percentage.

• Power Factor - Sets the conditions that cause a disturbance record 
trigger due to a change in the power factor of a line.

• Impedance - Set up the TR2000 recorder to trigger due to 
impedance changes of a line group.

• Power oscillation - Set up triggers to trigger the recorder on power 
oscillations. The phase groups to be used for each line group 
measurement are specified in the Input channels - Line Group 
window.

• Frequency oscillation - Set up triggers to trigger the recorder on 
frequency oscillations. The channels to be used for frequency 
measurement are specified in the Input channels - Frequency 
window.

• Phase difference (synchrophasor) - Set up a synchrophasor trigger. 
Before this trigger is set up, set up the Phasor measurement 
channels on the Input Channels - Phasor Display window.
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Figure 2.80  Disturbance Trigger Settings - Analogue Fundamental Tab

Analog 
Fundamental Tab

Buttons and Fields

on/off Enables/disables each type of triggering.

Analog Channel Select the analog channel to alter. The settings of 
the selected channel appear below.

Over Trigger Select a percentage that is a trigger value as a 
percentage of the nominal for that channel. If the 
magnitude of the fundamental rises above this, 
then a disturbance is triggered. The actual trigger 
value appears in the blue field to the right.

Under Trigger Select a percentage, which is a trigger value as a 
percentage of the nominal for that channel. If the 
magnitude of the fundamental falls below this, then 
a disturbance is triggered. The actual trigger value 
appears in the blue field to the right.
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Hysteresis Sets the difference between the levels required to 
initiate and terminate a level trigger for both Over 
Trigger and Under Trigger. The value is defined as a 
percentage of the nominal input. For example, a 
150% over trigger with a 5% hysteresis requires the 
input level to exceed 150% of the nominal input 
value to start a trigger condition and a level of less 
than 145% to end it. Hysteresis is most useful in 
stopping multiple triggers being generated if the 
signal level is close to the trigger level.

Rate of Change Trigger

Enter two values to define a rate of change of the 
fundamental:

• Rate of change trigger - the amount by which 
the fundamental must change as a percentage 
of the nominal.

• Cycles - the number of cycles over which the 
change is measured.

Both positive and negative changes are detected.

Power Tab Figure 2.81 shows the Power tab.

Figure 2.81  Disturbance Trigger Settings - Power Tab
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Buttons and Fields

on/off Enables/disables each type of triggering.

Line Group Channel

Select from the line groups set up in the Line 
Group section of the Input Channels window.

Apparent Power

Over trigger Sets the upper limit for the apparent power as a 
percentage of the nominal apparent power. When 
apparent power exceeds this level, a disturbance 
record is triggered.

Under trigger Sets a lower limit for the apparent power as a 
percentage of the nominal apparent power. When 
apparent power drops below this level, a 
disturbance record is triggered.

Rate of change trigger

This setting is a measurement of how much the 
apparent power changes over a number of cycles:

• % - sets how much the apparent power must 
change.

• Cycles - sets the number of cycles over which 
this change must occur to cause a disturbance 
trigger.

Both positive and negative changes are detected.

Real Power

Over trigger Sets an upper limit for the real power as a 
percentage of the nominal real power. When real 
power exceeds this level, a disturbance record is 
triggered.

Under trigger Sets a lower limit for the real power as a 
percentage of the nominal real power. When real 
power drops below this level, a disturbance record 
is triggered.
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Rate of change trigger

This setting is a measurement of how much the real 
power changes over a number of cycles:

• % - sets how much the real power must 
change.

• Cycles - sets the number of cycles over which 
this change must occur to cause a disturbance 
trigger.

Both positive and negative changes are detected.

Reactive Power

Over trigger Sets an upper limit to be set for the reactive power 
as a percentage of the nominal reactive power. 
When reactive power exceeds this level, a 
disturbance record is triggered.

Rate of change trigger

This setting is a measurement of how much the 
reactive power changes over a number of cycles:

• % - sets how much the reactive power must 
change.

• Cycles - sets the number of cycles over which 
this change must occur to cause a disturbance 
trigger.
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Voltage
Imbalance Tab

Figure 2.82 shows the Voltage Imbalance tab.

Figure 2.82  Disturbance Trigger Settings - Voltage Imbalance Tab

Buttons and Fields

on/off Enables/disables each type of triggering.

Line Group Channel Select the required line group.

Over trigger Adjust the voltage imbalance ratio.

Power Factor Tab

Line Group Channel

Select the required line group. The trigger details of 
the selected line group appear below.

on/off Enables/disables each type of triggering.

Upper Limit Set an upper limit to the true power factor (W/VA). 
If the power factor rises above this limit for the 
selected line group, a disturbance trigger occurs.

Lower Limit Set a lower limit to the true power factor. If the 
power factor falls below this limit for the selected 
line group, a disturbance trigger occurs.
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Rate of Change

Set a trigger on the variation of the power factor:

• % - sets how much the power factor must 
change.

• Cycles - sets the number of cycles over which 
this change must occur to cause a disturbance 
trigger.

For example if these are set to 10% over two 
cycles, there must be a 10 % variation within two 
cycles for the trigger to occur.

Displacement Power Factor

Upper Limit Set an upper limit to the displacement power 
factor. If the displacement power factor rises above 
this limit for the selected line group, a trigger 
occurs.

Lower Limit Set a lower limit to the displacement power factor. 
If the displacement power factor falls below this 
limit for the selected line group, a trigger occurs.

Rate of Change Set a trigger on the variation of the displacement 
power factor:

• % - sets how much the displacement power 
factor must change.

• Cycles - sets the number of cycles over which 
this change must occur to cause a disturbance 
trigger.

For example if these are set to 10% over two 
cycles, there must be a 10 % variation within two 
cycles for the trigger to occur. Both positive and 
negative changes are detected.
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Impedance Tab Figure 2.83 shows the Impedance tab.

Figure 2.83  Disturbance Trigger Settings - Impedance Tab

Buttons and Fields

on/off Enables/disables each type of triggering.

Line Group channel Select a line group and the line group's impedance 
trigger settings appear below.

Over Trigger Enter the percentage of the nominal impedance 
that the line group's impedance must exceed 
before an impedance trigger occurs. A nominal 
value is calculated and appears in the Ohms field 
for the line group's impedance from the nominal 
voltage and current of that group.

Under Trigger Enter the percentage of the nominal impedance 
that the line group's impedance must dip below 
before an impedance trigger occurs. A nominal 
value is calculated and appears in the Ohms field 
for the line group's impedance from the nominal 
voltage and current of that group.
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Rate of Change Trigger

Set a trigger on the variation of the impedance:

• % - sets how much the impedance must 
change.

• Cycles - sets the number of cycles over which 
this change must occur to cause a disturbance 
trigger.

Power 
Oscillation Tab

Figure 2.84 shows the Power Oscillation tab.

Figure 2.84  Disturbance Trigger Settings - Power Oscillation Tab

Buttons and Fields

on/off Enables/disables each type of triggering.

Line Group Channel

Specifies the line group for triggering.

Band For each line group there are four frequency bands 
within which triggers are set. Each band represents 
a different rate within which the real power may be 
changing.

% Sets, for each band, a threshold of the power 
oscillation above which a trigger occurs.
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Seconds Enter a dwell time in seconds. This is the length of 
time for which the rate of change of power must 
remain above the threshold for a trigger to occur. 
This can be set to 0 if required.

Frequency 
Oscillation Tab

Figure 2.85 shows the Power tab.

Figure 2.85  Disturbance Trigger Settings - Frequency Oscillation Tab

Buttons and Fields

on/off Enables/disables each type of triggering.

Channel 1/Channel 2

Displays frequency channels.

Band For each frequency channel there are four bands 
within which triggers are set. Each band represents 
a different rate within which the frequency may be 
changing.

% Sets, for each band, a threshold of the frequency 
oscillation above which is a trigger.
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Seconds Enter a dwell time in seconds. This is the length of 
time for which the rate of change of frequency 
must remain above the threshold for a trigger to 
occur. This can be set to 0 if required. Ensure that 
when setting this as a time constraint that it is at 
least one and a half times the period of the 
frequency band.

Analogue channel range (PM)

If the current configuration belongs to a pseudo 
recorder then oscillatory triggering for the two 
frequency channels can be set up for each 
individual recorder. Select the range of Analogue 
channels to pick from and then click on the 
required range.

Phase Difference (TR2000 with synchrophasor)

Figure 2.86 shows the Phase Difference tab.

Figure 2.86  Disturbance Trigger Settings - Phase Difference Tab

Buttons and Fields

on/off Enables/disables each type of triggering.
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Phasor Channel Set the phase group to be used for a phase 
difference trigger.

Angle Difference Trigger

Set the phase difference angle at which the 
recorder triggers. The diagram to the right shows 
the angle being set in blue.

Rate Of Change Trigger

Set to make the recorder trigger on a change of 
angle over a number of cycles.

Phase angle difference

Set the number of cycles over which this phase 
difference must occur. Both positive and negative 
changes are detected.

If another TR2000 is currently configured for 
phasor measurement and connected, the phase 
angles of both recorders appear in the diagram.

Trigger
Operations

Transient triggers

To configure the Transient triggers:

1. Click Transient triggers and the Trigger Settings dialog appears with 
the Analogue tab active (Figure 2.87).
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Figure 2.87  Trigger Settings - Analogue Tab

2. Configure the Analogue tab by (Figure 2.87):

a. Selecting a Channel Name in the display area.
b. Clicking on/off for Over trigger, using the spinner, or entering 

a value, to set an Over trigger percentage, then using the 
down spinner to set a hysteresis percentage.

c. Clicking on/off for Under trigger, using the spinner, or enter-
ing a value, to set an Under trigger percentage, then using the 
down spinner to set a hysteresis percentage.

d. Clicking on/off for Rate of change trigger, and using the spin-
ner, or entering a value, to set a Rate of change trigger per-
centage.

NOTE Multiple channels can be selected and set simultaneously using the Shift 
or CTRL keys, if settings are the same.
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3. Configure the Digital tab by (Figure 2.88):

Figure 2.88  Trigger Settings - Digital Tab

a. Selecting a Channel Name in the display area.
b. Clicking on/off for Channel Details. The Channel and Cur-

rents State appear in their fields.
c. Clicking a Trigger Type radio button for Level or Edge.
d. Clicking the Return to normal check box, as required.
e. Using the spinner to enter a Debounce time, if required.

NOTE Multiple channels can be selected and set simultaneously, if settings are 
the same.
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4. Configure the Phase Group tab by (Figure 2.89):

Figure 2.89  Trigger Settings - Phase Group Tab

a. Selecting a Phase Group Name in the display area.
b. Clicking on/off for Zero sequence trigger and using the spin-

ner to set a Zero sequence trigger percentage.
c. Clicking on/off for Negative sequence trigger and using the 

spinner to set a Negative sequence trigger percentage.
d. Clicking on/off for Positive sequence trigger Over trigger and 

using the spinner to set an Over trigger percentage.
e. Clicking on/off for Positive sequence trigger Under trigger and 

using the spinner to set an Under trigger percentage.
f. Clicking on/off for Rate of change trigger, using the spinner to 

set a Rate of change trigger percentage and to set the Cycles.
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5. Configure the Frequency tab by (Figure 2.90):

Figure 2.90  Trigger Settings - Frequency Tab

a. Clicking on/off for Frequency measurement channel 1 Over 
trigger and using the spinner to set a frequency value.

b. Clicking on/off for Frequency measurement channel 1Under 
trigger and using the spinner to set a frequency value.

c. Clicking on/off for Frequency measurement channel 1 Rate of 
change trigger, using the spinner to set a frequency and to set 
the Cycles.

d. Repeat a, b and c for Frequency measurement channel 2.
e. Clicking on/off for Frequency difference trigger and using the 

spinner to set a frequency.
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6. Configure the External tab (Figure 2.91) by:

Figure 2.91  Trigger Settings - External Tab

a. Clicking on/off for External Trigger.
b. Clicking a radio button:
• Open - indicates an NO condition.
• Closed - indicates an NC condition.

7. Click OK.
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Disturbance
Triggers

Click on the Disturbance Triggers button to open the Disturbance Trigger 
Settings dialog for adjusting the conditions, which indicate a disturbance 
fault. (TR2000 only).

Figure 2.92  Disturbance Trigger Settings - Analogue Fundamental Tab

1. Configure the Analogue Fundamentals tab by (Figure 2.92):

a. Selecting a Channel Name in the display area.
b. Clicking on/off for Over trigger, using the spinner to set an 

Over trigger percentage, then using the down spinner to set a 
hysteresis percentage.

c. Clicking on/off for Under trigger, using the spinner to set an 
Under trigger percentage, then using the down spinner to set a 
hysteresis percentage.

d. Clicking on/off for Rate of change trigger, and using the spin-
ner to set a Rate of change trigger percentage.

NOTE Multiple channels can be selected and set simultaneously, if settings are 
the same.
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2. Configure the Frequency Oscillation tab by (Figure 2.93):

Figure 2.93  Disturbance Trigger Settings - Frequency Oscillation Tab

a. Clicking on/off for Frequency channel 1 oscillation triggers 
bands, using the spinners to set the frequency and entering a 
time in the field.

b. Repeat a for Frequency channel 2 oscillation triggers.
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3. Configure the Power oscillation trigger tab by (Figure 2.94):

Figure 2.94  Disturbance Trigger Settings - Power Oscillation Tab

a. Using the spinners to select a Line Group Channel.
b. Clicking on/off for each band, using the spinners to set the 

power percentage and entering a time in the field.
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4. Configure the Power tab by (Figure 2.95):

Figure 2.95  Disturbance Trigger Settings - Power Tab

a. Using the spinners to select a Line Group Channel.
b. Clicking on/off for Apparent power Over trigger and using the 

spinner to set an Over trigger percentage.
c. Clicking on/off for Apparent power Under trigger and using 

the spinner to set an Under trigger percentage.
d. Clicking on/off for Apparent power Rate of change trigger, 

using the spinner to set a Rate of change trigger percentage 
and the Cycles.

e. Repeat b, c and d for Real power.
f. Repeated and d for Reactive power.
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5. Configure the Impedances tab by (Figure 2.96):

Figure 2.96  Disturbance Trigger Settings - Impedance Tab

a. Selecting a Line Group Name in the display area.
b. Clicking on/off for Over trigger and using the spinner to set an 

Over trigger percentage.
c. Clicking on/off for Under trigger and using the spinner to set 

an Under trigger percentage.
d. Clicking on/off for Rate of change trigger, and using the spin-

ner to set a Rate of change trigger percentage and the Cycles.
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6. Configure the Power factor tab by (Figure 2.97):

Figure 2.97  Disturbance Trigger Settings - Power Factor Tab

a. Using the spinners to select a Line Group Channel.
b. Clicking on/off for the Power factor Upper limit and using the 

spinners to set the power factor percentage.
c. Clicking on/off for the Power factor Lower limit and using the 

spinners to set the power factor percentage.
d. Clicking on/off for the Power factor Rate of change timer and 

using the spinners to set the trigger percentage and the Cycles.
e. Repeat b, c and d for the Displacement power factor.
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7. Configure the Voltage Imbalance tab by (Figure 2.98):

Figure 2.98  Disturbance Trigger Settings - Voltage Imbalance Tab

a. Using the spinners to select a Line Group Channel.
b. Clicking on/off for the Over trigger and using the spinners to 

set the trigger percentage.

8. Click OK.

Cross Triggering Use this window (Figure 2.99) to set up the relationship between 
transient triggers and disturbance triggers. This is used for a number of 
functions including, extending the transient pre and post fault times using 
a disturbance record (TR2000 only).

Buttons and Fields

Transient trigger -> Disturbance trigger

Switch on and when a transient trigger causes a 
transient record to be generated, a disturbance 
record is generated. The disturbance record has the 
same Trigger Type as the transient record
2-124 1086-339  Rev. A   11/05



Fault Recorder Operations Manual
Disturbance trigger -> Transient trigger

Switch on and when a disturbance trigger causes a 
disturbance record to be generated, a transient 
record is generated. The transient record has the 
same Trigger Type as the disturbance record.

Cross Triggering
Operations

To configure cross triggering:

1. Click Cross triggering and the Cross triggering dialog appears 
(Figure 2.99).

Figure 2.99  Cross Triggering

2. Click on/off for Transient trigger -> Disturbance trigger and/or 
Disturbance trigger -> Transient trigger.

3. Click OK.

Operating limits - 
Transient triggers 
(TR2000 only)

This window (Figure 2.100) sets a number of disturbance or transient 
triggers that can occur within a certain time span on any one particular 
channel.

Figure 2.100  Trigger Limits

Operating limits -
Transient triggers

Operations

To configure this:

1. Click Operating limits and the Trigger limits dialog appears.

2. Click on/off.

3. Enter the maximum number of triggers that can occur.

4. Enter the time span in minutes for these triggers to occur.

5. Enter the length of time to disable triggering if the maximum number 
of triggers is reached within the time specified.

6. Click OK.
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Real Time Display Use this window (Figure 2.101) to view a combination of actual values 
and calculated values on a connected recorder. On a:

• TR100 recorder, analog and digital values only are available.
• TR2000, TR100+ and PQR, disturbance and power values are 

also available.

The values in the real time displays are updated approximately once a 
second, depending on the speed of the connection.

Figure 2.101  Real Time Display - Analogue Values Tab

There are up to five tabs:

• Analog Values - Displays the values being read on the connected 
recorder's analog channels.

• Digital Values (TR100, TR100+ & TR2000) - Displays the status of 
the recorder digital channels.

• Disturbance Values (TR2000, TR100+ & PQR) - Displays 
magnitude and phase information for each line group.

• Power Values (TR2000, TR100+ & PQR) - Displays the values 
calculated for power on each line group.

• Energy Meters (PQR) - Displays the accumulating energy meters.
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Analog Values 
Tab

Buttons and Fields

Channels Select a range of channels to view. Channels 1-8, 
9-16,17-24, and 25-32 are available, although the 
latter three depend on the channel size of the 
recorder. If a Pseudo Machine is viewed, many 
more channels may be available.

Frequency Displays the frequency being recorded on the 
defined frequency channel. For a TR2000 this is 
Frequency Channel 1.

Analog Displays the analog channels and their current 
values. The label of each configured channel 
appears on the left.

RMS Shows the true RMS value of each analog channel.

PU% Shows the PU (Per Unit) value of each analog 
channel, expressed as a percentage of the set 
nominal value.

Quality Displays a measure of the harmonic distortion of 
each channel. The value shown is a percentage 
difference between the input signal and a perfect 
sine wave. Do not confuse this with total harmonic 
distortion (THD).
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Digital Values 
Tab (TR100, 
TR100+ & 
TR2000)

Figure 2.102 shows the Digital Values tab.

Figure 2.102  Real Time Display - Digital Values Tab

Buttons and Fields

Channels Select the channels to show i.e. channels 1 – 16, 
17 – 32, 33 - 48 or channels 49 – 64. The 
maximum number of channels available depends 
on the connected recorder. If a Pseudo Machine is 
viewed, many more channels may be available.

Digitals The values of the digital channels being monitored 
appear. Channels in the:

• Normal state appear with a green background 
and the letter N (Normal).

• Alarm state appear with a red background and 
the letter A (Alarm).
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Disturbance Val-
ues (TR2000, 
TR100+ & PQR) 
Tab

Figure 2.103 shows the Disturbance Values tab.

Figure 2.103  Real Time Display - Disturbance Values Tab

Buttons and Fields

Line Group Channel

Select the line group to view and the values 
currently being recorded and calculated appear. 
There is only one line group in a PQR.

Frequency Channel Displays the frequency channel measurement for 
the selected line group.

Phasor group components

Voltage phase group

Displays the voltages measured for the line group. 
For the three phase inputs the fundamental 
frequency magnitude, angle and total harmonic 
distortion (as a percentage) appear. Further to the 
right, the sequence components appear: positive, 
negative and zero sequence, the resultant 
magnitude in rms and angle appear.
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Current phase group

Displays the currents measured for the line group. 
For the three phase inputs the fundamental 
frequency magnitude, angle and total harmonic 
distortion (as a percentage) appear. Further to the 
right, the sequence components appear: positive, 
negative and zero sequence, the resultant 
magnitude in rms and angle appear.

Phasor Diagrams Display the relationship between the three phases 
for both voltage and current. All angles are relative 
to the first voltage channel. If the voltage phase 
group has been defined as phase-to-phase the 
vectors are shown as a triangle.

Power Values 
Tab (TR2000, 
TR100+ & PQR)

Figure 2.104 shows the Power Values tab.

Figure 2.104  Real Time Display - Power Values Tab

Buttons and Fields

Line Group Channel

Select a line group to view. There is only one line 
group in a PQR.

Frequency Channel Displays the frequency channel value for the 
selected line group.
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Resultant Components

Phases Displays, for each phase, the apparent power, real 
power, reactive power, displacement power factor 
and impedance. 

Total Displays the circuit totals of each of these 
quantities. If the VT phase group is defined as P-P 
then only total power appears.

Metered Power 
Tab (PQR)

When a recorder is connected this gives on-line displays of live data from 
its input channels.

Figure 2.105 shows the Metered power tab.

Figure 2.105  Real Time Display - Metered Power Tab

Buttons and Fields

Line Group Channel

Select a line group to view. There is only one line 
group in a PQR.

Resultant Components

Phases Displays, for each phase, the apparent power, real 
import power, real export power, reactive 
inductance and capacitance. 
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Total Displays the total circuit apparent energy, imported 
and exported real energy, inductive and capacitive 
reactive energy per phase. If the VT phase group is 
defined as P-P then only total power appears.

Clear Meter Resets all the registers.

Real Time
Display

Operations

To use the real time display:

1. Click RealTimeDisplay and the Real Time Display window appears 
(Figure 2.106).

Figure 2.106  Real Time Display - Analogue Values Tab

2. Use the spinner to select a:

• Channel Group for the Analogue Values and Digital Values tabs 
or, 

• Line Group Channel for the Disturbance values or Power values 
tabs.

3. Click OK.

4. Click Cancel to close the display.
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View Configuration 
File

Use this window (Figure 2.107) to view the complete configuration of the 
recorder in a basic text format.

CAUTION Do not edit or alter this file.

To view the configuration file (Figure 2.107):

• Click View configuration file.

Figure 2.107  Configuration File

PQR Set up Wizard 
(PQR)

Use this wizard (Figure 2.108) to quickly configure a PQR recorder. The 
wizard creates names for each channel and sets the nominal and 
full-scale values for each channel. Once the set-up wizard has been used 
to configure a recorder, the configuration can be viewed and edited in 
the normal way using the Recorder - Configure option.

The wizard also provides a real time input check facility that lets you 
confirm that the inputs to the recorder are wired correctly.

A PQR recorder must be connected to DS32 before the wizard appears in 
the menu. The wizard runs a sequence of screens to enter simple 
information about interposing transformers, triggering and 
communication peripherals.
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PQR Set-up
Wizard

Operations

To use the PQR Set-up Wizard:

1. Select Recorder > PQR Set-up Wizard.

The PQR Set-up Wizard - Recorder Identification dialog appears 
(Figure 2.108).

Figure 2.108  PQR Set-up Wizard - Recorder Identification

2. Enter a Location and a Machine Name and click Next and the 
Voltage Channel Setup dialog appears (Figure 2.109).

Figure 2.109  Voltage Channel Setup
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3. Click the Voltage Transformer for Va, Vb & Vc, enter Primary, 
Secondary, and Nominal values, if required.

4. Click the Voltage Transformer for Vn, enter Primary, Secondary, and 
Nominal values, if required.

NOTE If values in the fields in the two steps above conflict an error dialog 
appears asking you to confirm your selections.

5. Click either the Wiring Phase to Neutral or phase-to-phase radio 
button and click Next.

The Current Channel Setup dialog appears (Figure 2.110).

Figure 2.110  Current Channel Setup

6. Click the Main CT (optional) check box in CT Ratings for Ia, Ib & Ic, if 
required, and enter Primary and Secondary values.

7. Enter Interposing CT Primary, Secondary and Nominal values, if 
required.

8. Click the Main CT (optional) check box in CT Ratings for In, if 
required, and enter Primary and Secondary values.

9. Enter Interposing CT Primary, Secondary and Nominal values, if 
required and click Next.
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The PQR Input Check dialog appears (Figure 2.111).

Figure 2.111  PQR Input Check

10. Wait until the message in the Diagnostic field reads as in Figure 2.111 
and click Next.

The PQR Set-up Wizard Triggering dialog appears (Figure 2.112).

Figure 2.112  PQR Set-up Wizard Triggering
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11. Use the spinners to set the Over Trigger, Under Trigger and Total 
Harmonic Distortion percentages.

12. Use the spinner to select a trigger set and click Apply.

13. Click Next.

The PQR Modem dialog appears (Figure 2.113).

Figure 2.113  PQR Modem

14. Click the Init. String and Dialog Prefix check boxes and enter values 
in the associated fields, if required.

15. Use the spinner to set the Baud Rate.

16. Click on/off for Auto call and enter a Phone Number.

17. Enter values in the Connect Time, Retires and Retry pause fields and 
click Finish.

A dialog appears asking if you want to overwrite any previous PQR 
setup.

18. Click Yes.
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Button and Fields

Recorder Identification

Location/Machine Identification

Enter the Location and Machine Name used to 
uniquely identify the recorder. Each name can 
have up to 24 characters.

Voltage Channel Setup

This dialog can be used to define the ratio of an 
interposing VT. The PQR has a maximum input of 
150V, 300V or 600V rms. The wizard reads this 
value from the PQR and shows it as the default 
full-scale value (FSD). If a Voltage Transformer (VT) 
is not being used, then these default values for 
nominal and FSD are used. The nominal voltage 
can be edited, if required.

Voltage Transformers

Click on the Voltage Transformer check box if a VT 
is in use to step down a higher voltage for the 
recorder.

Primary/Secondary Enter the primary and secondary ratings for the VT. 
The wizard automatically works out and displays 
the nominal and FSD for the phase voltage inputs.

Nominal/FSD Set these for the phase channels (a, b & c) and 
individually for the neutral channel (n).

Wiring Set the VT wiring as Phase to Phase (P-P) or Phase 
to Neutral (P-N). A diagram shows how to connect 
the recorder's voltage inputs for each of these 
methods. The wizard names the voltage channels 
and voltage phase group automatically; e.g. 
Channel 1 is called Va, Channel 2 is Vb, etc.

Current Channel Setup

Use this dialog to define the ratios of primary and 
interposing current transformers (CT).
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The PQR can be fitted with an internal shunt 
resistor. If a shunt is fitted, then the interposing 
Current Transformer (CT) must have a current 
output, otherwise it must have a voltage output. 
The PQR wizard knows if a shunt is fitted and 
change the units for the secondary rating of the 
interposing CT accordingly. The full-scale input for 
the PQR is 1.414V rms, which gives ~40% 
overrange for a 1V output clamp CT.

CT Ratings

Nominal/FSD Enter the nominal and FSD values.

Primary/Secondary Enter the ratings of the interposing CT.

Main CT Activate the check box and enter the primary and 
secondary ratings for the main CT. The nominal 
and FSD are calculated automatically when all the 
values are entered.

The Current Channel Setup part of the wizard 
names the current channels and current phase 
group automatically. Channel 5 is called Ia, 
channel 6 – Ib etc.

PQR Input Check

This dialog provides real time information on the 
inputs of the currently connected PQR. For this to 
operate correctly all three phase voltages and 
currents must be connected to the PQR.

Phasor Displays The two phasor displays show the magnitude and 
phase angle of each channel for both the current 
and voltage inputs. The input check does a number 
of diagnostic checks on this input and shows any 
errors along with the actions necessary to correct 
them in the diagnostic window.

The checks performed are as follows:

1 - Magnitude of the Voltage and Current Phasors 
are compared with the nominal values for each 
channel.

2  - The magnitudes of the three vectors within a 
phase group should be roughly the same.
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3 - The angle between phases should be 
approximately 120 degrees.

4 - The vectors of each phase should be in positive 
sequence order; i.e. a -> b -> c

5 - Angle between equivalent Voltage and Current 
phases should be roughly the same.

Triggering

Use this dialog to set up the triggering for the 
voltage channels. Each trigger set is applied to all 
the phase voltage channels.

Voltage

Over Trigger Set to the percentage of the nominal that the phase 
voltages must exceed in order to cause a Voltage 
Over Trigger.

Under Trigger Set to the percentage of the nominal, which the 
phase voltages must drop below in order to cause a 
Voltage Under Trigger.

Harmonics Set to a value that causes a THD trigger on the 
phase voltages.

Trigger Settings Stores sets of triggers for all the above. Select a 
value from the drop down and click Apply to set 
the triggers to the pre-defined values.

Peripherals Depending on the communications options 
reported by the PQR two different dialogs are 
available. For systems fitted with a modem or a 
network card a number of parameters are set.

Modem Use this to set up a modem-to-modem connection 
between recorder and PC. Several parameters must 
be set. Normally these values are set at the factory 
and should not be changed.

Modem string These values are critical to the correct operation of 
the modem and should only be changed by an 
experienced person.

Init String Click the check box and enter an initialization 
string for the modem. The character ^M translates 
to an ASCII carriage return and ~ translates to a 
half second delay (entered between commands).
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Dialing Prefix Click the check box and enter the string that 
precedes the phone number while dialing for the 
modem in use.

Communications port

This value controls the rate that the PQR talks to 
the modem (DTE rate).

Baud rate Set to 57600 baud to maximize the 
communications speed.

Auto-call Switch on and the recorder automatically calls the 
PC when a new fault is recorded. Enter the phone 
number to dial in.

Auto-call parameters

Connect time Enter the amount of time a recorder waits for a call 
to be answered (range 3 – 300).

Retry pause Enter the length of time between the end of one 
dial attempt and the start of the next (range 0 – 
999).

Retries Enter the number of times a recorder tries to 
connect to a PC before giving up (range 0 – 99).

Network Displays the connection parameters of a recorder 
when it is connected over a TCP/IP network. If the 
correct values for these parameters are not known, 
consult with the relevant IT department.

Network Parameters

IP Address, IP Subnet Mask and Router IP Addr

Enter these values so the recorder has a unique 
identity on the network. These parameters can only 
be changed when the recorder is connected to the 
PC directly using an RS232 cable.

Event Log The window (Figure 2.114) is a list of internal event and alarm messages 
held in the TR-100, 2000, 100+ and PQR battery backed memory. 
Available while the recorder is connected
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To view the log:

• Select Recorder > Event Log and the log appears (Figure 2.114). 

Figure 2.114  Event Log

When this is done a copy is automatically made at Display Station for 
viewing off line using View - Event Log. The events that are saved are:

• When the system is switched on and off.
• When the main supply is removed (battery option).
• When the memory is full (stop mode).
• When the disk is 85% full (disk option).
• When the system parameters are updated.
• When the Test button is pressed.
• If the modem does not initialize properly
• If the auto-call process failed
• If the printer is off line or out of paper. 
• If the data buffers fill
• If clock sync or GPS is lost
• CPU watchdog
• Acquisition watchdog

Buttons and Fields

Clear all events Clears the event log at the recorder of all events. 
Level 2 security is required to do this.

Manual Trigger Use this dialog, while connected to a TR100, TR100+, PQR or a TR2000, 
to generate a short test record using a manual trigger. If connected to a:

• TR100 only a transient trigger is available.
• TR2000, TR100+ or PQR is connected then transient or 

disturbance records are available.
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The record created by a manual trigger has a minimum post fault period 
and the Trigger type is Manual. This record can be downloaded and 
displayed to check that all the recording and communications functions 
are operating correctly.

Figure 2.115  Manual Trigger

Manual Trigger
Operations

To use a manual trigger:

1. Select Manual trigger and the Manual trigger dialog appears 
(Figure 2.115).

2. Click either the Transient trigger or Disturbance trigger radio button.

3. Click Issue trigger.

Transient Record 
Download

Use this option to manually recover selected transient records from the 
connected recorder. The process is implemented in two stages:

• The first is to recover a listing of records available
• Then a final selection is made of required files.

There are a number of options available to control the directory listing.

Buttons and Fields

New Records Select New Records (Figure 2.118 on page 2-149) 
and only records that have not been marked as 
read by Display Station appear.

NOTE If more than one version of Display Station is in use in a region this 
option may not show all unread records since they may have been read 
by another PC running Display Station.
There is no way to specify master or slave mode during installation. To 
configure slave mode after installation, add a line to the ds32.ini entry 
SlaveMode=1 to the DS section.

All Records Select this and the directory listing includes all the 
records held at the recorder. This could be a large 
number if the system has a hard disk. 
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Latest Recovers a list of the most recent number of 
records specified.

Records since Recovers a list of all records created after a specific 
date. This may be the date of the last connection to 
the recorder.

Include Profile information

Download the analog and digital profile 
information for each record with the directory. This 
makes the transfer time longer but the profile data 
is available immediately. If this is not done, each 
profile has to be fetched individually on request.

Transient Records Directory (Figure 2.119 on page 2-149)

This window lists the headers of all the records that 
were requested for download in the Transient 
Record Selection window. All records appear by 
date and time and those records that have not been 
previously copied to the Display Station have a tick 
in the New column.

Each record header is transferred to the Display 
Station with its profile (if selected) which contains 
the signal levels before, during and after the trigger, 
the maximum and minimum values during the 
record (Analog profile) as well as the contact 
transition times (Digital profile). These data are 
viewed by double clicking on the record entry. 

Fault Data Shows if the data is available on the recorder or 
whether it has been overwritten.
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Action Tells Display Station 32 what to do with the records 
listed. To set the value of this field, see the Right 
Click and Double Click sections below. There are 
four possible values, each of which refers to what 
Display Station 32 does with the record when 
Continue is clicked:

• Ignore - Nothing is done with the record 
(default). The event is marked as read, if 
Continue is clicked.

• Fault data - The record's fault data is 
downloaded

• Profile - The record's profile is downloaded
• Reduced - Reduced data is downloaded for the 

record (as set up in Record reduction 
parameters)

Clear All Records Deletes ALL the transient records on the connected 
recorder.

Reduction Parameters

Opens the Record Transfer Options window, which 
is used to reduce the data being downloaded for 
the selected record.

Right Click Position the mouse over a record in the list and 
right-click and a popup menu appears. This menu 
has several options that can be used to manipulate 
and view the record. Four of the options are used 
to set the Action column, i.e. Ignore, Mark fault 
data, Mark profile only and Reduced fault data, 
when selected set the Action column to Ignore, 
Fault data, Profile and Reduced (TR2000, and 
TR100+ only) respectively.
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If the profile flag has been set in the Transient 
Record Selection window then three more options 
are available, for viewing the profile. These are:

• Analogs - Selecting analogs brings up the 
Analog Fault Levels – RMS window showing a 
summary of RMS levels one each channel 
before, during and after a fault.

• Digitals - Selecting Digitals brings up the 
Digital Transitions window, showing digital 
transitions during the fault. If Digital input 15 is 
used for cross triggering transitions on this 
input are not reported.

• Cameo - Selecting Cameo downloads the 
record in cameo form, and shows the record in 
the Cameo record window.

Double Click Double-clicking on a record brings up the Record 
window (Figure 2.116), which shows the record's 
header information and gives options for viewing 
and manipulating the record.

Figure 2.116  Record with Cameo Function

This window displays header information of 
whichever record was selected in the Transient 
Records window and allows cameo data, analog 
profile data and digital transition data to be 
viewed.
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Recorder Identification

Displays the location and machine name of the 
selected recorder.

Trigger Information

Trigger type Display what caused the trigger.

Trigger Time Displays the date and time at which the trigger 
occurred, to the nearest millisecond. 

Record Length Displays the number of cycles in the whole record.

Comment Enter a comment pertaining to the record.

Action Specifies what information is required for the 
selected record. The option selected here is shown 
in the Action column of the Transient Records 
window.

Cameo record

View Cameo Downloads the record in cameo form, and shows it 
in the Cameo record window (Figure 2.117). The 
Cameo is an RMS version of the waveform data.

Figure 2.117  Cameo Record
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Analogs Opens the Analog Fault Levels – RMS window 
showing a summary of RMS levels on each 
channel before, during and after a fault.

Digitals Opens the Digital Transitions window, showing 
digital transitions during the record. The transition 
times are relative to the trigger point.

Analog Profile

Displays the RMS levels of the cycles immediately 
before and after the start and end of the trigger 
condition. The maximum and minimum values 
throughout the duration of the record are also 
included.

The fault duration is the time in ms, between the 
start and end of the trigger condition. For a digital 
edge or manual trigger this value is zero. 

This information is used to give an indication of the 
type and level of a line fault without having sight of 
the complete graphical record.

Digital Transitions Displays the transition times of digital inputs that 
have profiling enabled. These times are relative to 
the trigger point. The fault duration is defined as 
the time from the start of the first trigger to the end 
of the last trigger (which may not be on the same 
channel or of the same type as the initial trigger).

Both analog and digital profiles are the same as 
those displayed on a printed record. These 
windows are also available in Display Station 
Analysis.

Transient Record
Download
Operations

To retrieve transient records:

1. Select Transient Records and the Record selection dialog appears 
(Figure 2.118).
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Figure 2.118  Record Selection

2. Click the radio button associated with the record range required. For:

• New Records only- selects only records not previously 
downloaded

• All Records - selects all records
• Latest - use the spinner to select the number of records
• Records since - use the spinner to select the record start date

3. Click the Include profile information check box to download the 
profile data for the records, if required.

4. Click OK.

The Transient records available on connected recorder dialog appears 
(Figure 2.119).

Figure 2.119  Transient Records Available

5. Click Reduction parameters to download reduced records 
(Figure 2.120).
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Figure 2.120  Record Reduction Parameters

6. Configure parameters on the dialog as required and click OK.

The Transient records available on connected recorder dialog 
reappears.

7. Click Mark all records for fault data to download all associated fault 
data. Alternatively, right-click or double-click on a record to 
download.

8. Click Continue and the records are downloaded.

Harmonic Records Use this window (Figure 2.121) to download harmonic records. 

AMETEK recorders produce an average harmonic reading every 10 
minutes. Some recorders also store the min., max, average and a 
snapshot with the angle value. The amplitude and phase of channels 
assigned to a phase group are recorded up to the 64th harmonic. Content 
may be limited by the sample rate of the recorder.

Buttons and Fields

Retrieval parameters

Select the start and end times and dates from the 
log. The default is the complete interval.

The sampling interval can be reduced from every 
10 minutes to 20, 30 or 60 minutes

Max. number of harmonics

Select the maximum harmonic number up to the 
48th for the TR100, 64th for the TR2000 and 63rd 
for the TR100+ and PQR.
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Record format Select the data format for a TR2000 & PQR:

• Average
• Max, Min, Average
• Magnitude, Angle
• Max, Min, Average, Magnitude, Angle

For a TR100 and TR100+ the format is Average.

Harmonic Record
Retrieval

Operations

To retrieve harmonics records:

1. Select Harmonic Records and the Harmonics Data Available On 
Connected Recorder dialog appears (Figure 2.121).

Figure 2.121  Harmonics Data Available On Connected Recorder

Individual harmonic logs are listed with their times and dates.

2. Double-click on a record and the Retrieve harmonic data record 
appears (Figure 2.122).

Figure 2.122  Retrieve Harmonic Data Record

3. Use the spinners to set the From and To dates for the records 
required.

4. Use the Interval spinner to set the interval.

5. Use the spinner to set the record format.
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6. Enter the Maximum number of harmonics.

7. Click OK and a dialog appears.

8. Click Yes and the records are downloaded.

Logger Records Use this window to download the logger data available on connected 
recorder.

Each logger file contains a continuous sequence of data samples. Certain 
events can cause the start of a new log file to ensure that the recording in 
each file is continuous. These include switching the system off, updating 
the system parameters and changing the system time.

Buttons and Fields

Clear Logger Deletes all logged data on the connected recorder. 
Level 2 security is required.

Retrieve Logger Data Record

Use this window to retrieve logger data from a 
connected recorder. Depending on the recorder 
type and options a range of continuous quantities 
are saved in separate logs in the recorder.

Data range available

Indicate the range of time over which logger data is 
available.

Retrieval Parameters

From Enter the date and time when the retrieval record 
starts. Enter the date and time when the retrieved 
record should end.

Interval Select the interval required between logged 
samples, in minutes.

For the TR2000 & PQR there are five different 
logger files. The standard logger (RMS & 
frequency), Energy, Imbalance & Flicker logs are all 
available from this screen. The harmonics log is 
available from the Recorder – Harmonic Records 
menu. For the TR-100+ the standard RMS and 
frequency logger and optional Power Logger are 
available. For the TR-100, the flicker and standard 
(RMS and frequency) optional logger files are 
available.
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Logger Record
Retrieval

Operations

To retrieve logger records:

1. Select Logger Records and the Logger Data Available On Connected 
Recorder dialog appears (Figure 2.123).

Figure 2.123  Logger Data Available On Connected Recorder

Individual logger files are listed with their times and dates.

2. Double-click on a record and the Retrieve Logger data record 
appears (Figure 2.124).

Figure 2.124  Logger Retrieval Options - Logger Tab

NOTE Each of the four tabs functions in the same manner.

3. Use the spinners to set the From and To dates for the records 
required.

4. Use the Interval spinner to set the interval.
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5. Click either:

• Download this interval for logger.
• Download this interval for all logger types.

A dialog appears.

6. Click Yes.

Disturbance 
Records (TR2000, 
TR100+ & PQR)

Use this window (Figure 2.125) to download disturbance records. It lists 
the headers of all the records that were requested for download in the 
Record Selection window. All records are displayed by date and time and 
those records that have not been previously marked as read to the 
Display Station are marked with a tick in the New column.

Each record header is transferred to the Display Station with its profile (if 
selected) which contains the signal levels before, during and after the 
trigger, the maximum and minimum values during the record (Analog 
profile) as well as the contact transition times (Digital profile). These data 
may be viewed by double clicking on the record entry. 

Figure 2.125  Disturbance Records Available

Buttons and Fields

Fault Shows if the data is available on the recorder or 
whether it has been overwritten.
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Action Tells Display Station 32 what to do with the records 
listed. To set the value of this field, see the Right 
Click and Double Click sections below. There are 
four possible values, each of which refers to what 
Display Station 32 does with the record when the 
Continue button is clicked:

• Ignore - Nothing is done with the record 
(default)

• Fault data - The record's fault data is 
downloaded

• Profile - The record's profile is downloaded
• Reduced - Reduced data is downloaded for the 

record (as set up in Record reduction 
parameters)

Clear All Records Deletes all the disturbance records on the 
connected recorder.

Reduction Parameters

Opens up the Record Transfer Options window, 
which is used to reduce the data being 
downloaded for the selected record.

Right Click Right-click over a record in the list a popup menu 
appears. This menu has several options used to 
manipulate and view the record. Four of the 
options can be used to set the Action column, i.e. 
Ignore, Mark fault data, Mark profile only and 
Reduced fault data, when selected sets the Action 
column to Ignore, Fault data, Profile and Reduced 
(not TR100) respectively.

If the profile flag has been set in the Transient 
Record Selection window then more options are 
available, for viewing the profile. These are:

• Analogs - Opens the Analog Profile window 
showing a summary of RMS levels on each 
channel before, during and after a fault.

• Digitals - Opens the Digital Transitions 
window, showing digital transitions during the 
fault.
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Double Click Double-clicking on a record with the left mouse 
button opens the Record window, which shows the 
record's header information and gives options for 
viewing and manipulating the record.

Analog Profile Displays the RMS levels of the cycles immediately 
before and after the start and end of the trigger 
condition. The maximum and minimum values 
throughout the duration of the record are also 
included.

The fault duration is the time in ms, between the 
start and end of the trigger condition. For a digital 
edge or manual trigger this value is zero. 

This information is used to give an indication of the 
type and level of a line fault without having sight of 
the complete graphical record.

Digital Transitions

Displays the digital transitions that occurred during 
a disturbance record.

Disturbance
Record Retrieval

Operations

To download disturbance records:

1. Select Disturbance Records and the Record selection dialog appears 
(Figure 2.126).

Figure 2.126  Record Selection

2. Click the radio button associated with the record range required. For:

• New Records only- selects only records not previously 
downloaded

• All Records - selects all records
• Latest - use the spinner to select the number of records
• Records since - use the spinner to select the record start date
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3. Click the Include profile information check box to download the 
profile data for the records, if required.

4. Click OK.

The Disturbance records available on connected recorder dialog 
appears (Figure 2.127).

Figure 2.127  Disturbance Records Available

5. Click Reduction parameters to reduce the records being downloaded 
(Figure 2.128).

Figure 2.128  Record Reduction Parameters

6. Configure parameters on the dialog as required and click OK.

The Disturbance records available on connected recorder dialog 
reappears.
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7. Click Mark all records for fault data, or select required records 
individually, to download all associated fault data.

8. Click Continue and the records are downloaded.

Disturbance Logger 
(TR2000)

Use this window (Figure 2.129) to download logger disturbance records. 
The TR2000 has an option to continuously log its input quantities and the 
two frequency channels. This is recorded at 25Hz for a 50Hz system and 
30Hz for a 60Hz system. The log is circular and contains the previous 14 
days worth of data. The recovered data contains phasor information so 
DSA can compute derived values such as power and impedance.

Figure 2.129  Disturbance Logger Records Available

Buttons and Fields

Data range available

Displays the range of time over which logger data 
is available for the selected record.

Retrieval Parameters

From Enter the date and time when the retrieval record 
starts.

To Enter the date and time when the retrieved record 
ends. Because of the relatively high sampling rate it 
is recommended that only short intervals be 
recovered at a time.

Reduced Activates whether the recovered file contains 
reduced data. The parameters for this are defined 
in the recorder configuration. The Data Available 
column in the Disturbance directory shows 
Reduced data for these files.
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Retrieve
Disturbance

Logger Records
Operations:

To retrieve logger records:

1. Select Disturbance Logger Records and the Disturbance Logger Data 
Available On Connected Recorder dialog appears (Figure 2.130).

Figure 2.130  Disturbance Logger Data Available On Connected 
Recorder

Individual logger files are listed with their times and dates.

2. Double-click on a record and the Retrieve disturbance logger data 
record appears (Figure 2.131).

Figure 2.131  Disturbance Logger Retrieval Options

3. Use the spinners to set the From and To dates for the records 
required.

4. Click on/off to download reduced data.

5. Click OK and a dialog appears.

6. Click Yes.
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View Menu
This menu is used to view the event and communications logs stored by 
Display Station.

Event Log The Event Log window (Figure 2.132) shows a list of event and alarm 
messages from recorders.

Figure 2.132  Event Log

Buttons and Fields

Location Selection Select the events of a particular location. Only one 
location can be viewed at a time.

Recorder Selection Select a recorder within a location. To make this 
filter active, click on the check box supplied.

Communications 
Log

This window (Figure 2.133) lists the communications messages where 
Display Station has tried to connect to recorders and failed. This is useful 
for auto-poll where the process is normally unattended. There are three 
separate pages controlled by a tab at the top. The Communications Log 
contains all activity and the Successful auto comms and Failed auto 
comms are separated into the other two pages. 
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Figure 2.133  Communications Log

Button and Fields

Clear All Entries Clears all the entries of the communications log.

Database Menu
The options of this menu maintain the Display Station database:

• Update File Links
• Repair 
• Compact
• Create Archive
• Import Archive

Update File Links
The DS database stores the header information for each record in the 
Display Station 32 data directory. The actual record data are stored in the 
data directory as separate files. Each record in the database stores the 
name of its data file. It is possible for these file references to become 
damaged if, for example, records are copied to and from the data 
directory without using the Directory maintenance facility.

To update file links:

• Select Database > Update File Links. 

This forces Display Station 32 to traverse through all of its database 
records and ensure that they are pointing to the correct data files.
1086-339  Rev. A   11/05 2-161



Display Station 32 Software
Repair
Display Station 32 database can become corrupted, for example if the 
computer is turned off while it is being read or written to. Selecting 
Repair attempts to repair any damage that may occur.

NOTE Repairing the database requires exclusive access, if Display Station 32 is 
being run as a multi-user system, then it is essential that no other copies 
of Display Station 32 are running at the same time.

To repair files:

• Select Database > Repair.

Compact
The database system used for Display Station 32 grows in size every time 
records are added but does not decrease again if these are deleted. This 
function reclaims unused space within the database.

NOTE Compacting the database requires exclusive access, if Display Station 
32 is being run as a multi-user system, then it is essential that no other 
copies of Display Station 32 are running at the same time.

To repair files:

• Select Database > Compact.

Create Archive
The DS32 database keeps a copy of the header information and expert 
system results for each record it downloads or imports. Over time, the 
size of the database can become extremely large (greater than 800 
Mbytes). When this occurs, use this window to archive old records out of 
the database.

Buttons and Fields

Dates Use the Start date and End date fields to enter the 
dates when archiving starts and ends.

Archive path Enter a pathname and file name for the archived 
material. Alternatively, use the browse button to 
select a path and filename.

Create Creates the archive. All archived records are 
deleted from the Display Station 32 database.
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Create Archive
Operations

To create an archive:

1. Select Database > Create Archive.

The Create Archive dialog appears (Figure 2.134).

Figure 2.134  Create Archive

2. Click Browse.

The Select or enter a name for the Archive Database dialog appears 
(Figure 2.135).

Figure 2.135  Select or enter a name for the Archive Database

3. Navigate to or enter a name for a new database and click Save.
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The Create Archive dialog reappears (Figure 2.134).

Figure 2.136  Create Archive II

4. Enter a Start Date and an End Date and click Create.

Import Archive Use this window to re-import an archive that was created using Create 
Archive.

Buttons and Fields

Archive path Enter the path and name of the archive file to 
import. Alternatively, use the browse button to find 
the required file.

Import Re-integrates the selected archive into the Display 
Station 32 database.

Import Archive
Operations

To import an archive:

1. Select Database > Import Archive.

The Import Archive dialog appears (Figure 2.137).

Figure 2.137  Import Archive

2. Click Browse.
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The Select an Archive to Import dialog appears (Figure 2.138).

Figure 2.138  Select an Archive to Import

3. Navigate to the archive and click Open.

The Import Archive dialog reappears (Figure 2.139).

Figure 2.139  Import Archive II

4. Click Import.
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3. Display Station Analysis 32 Menus 
and Operations

This chapter describes functions available for manipulating separate 
records and windows.

The chapter consists of the following sections:

• ”DS32 Analysis Window General Operations”, a discussion of the 
main window’s functions and capabilities.

• ”Main Toolbar/PAT Toolbar” on page 3-17, a discussion of the 
items accessed from the toolbar. General discussions and specific 
procedures appear.

• ”Main Menu Bar” on page 3-19, a discussion of the items 
accessed from the toolbar. General discussions and specific 
procedures appear.

DS32 Analysis Window General Operations

This sections consists of:

• ”Graph Window Operations”
• ”Warning Messages” on page 3-14
• ”Phase Group Classification” on page 3-16

There are three ways to open a DSA32 record:

• Double-click a DS32 transient, disturbance or logger record and 
then click Analyze fault data on the record dialog.

• Select File > Open Record and the DS main window appears. 
Double-click a DS32 transient, disturbance or logger record and 
then click Analyze fault data on the record dialog.

• Select File > Open file, use the Open dialog to navigate to the 
record and click Open. This works for COMTRADE files as well.
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Figure 3.1 shows the Display Station Analysis main window.

You can:

• Open multiple records separately
• Create new graphs
• Modify graph presentation and save as your new default 

presentation

The active graph is the graph shown in the window and its record is the 
active record.

Figure 3.1  Display Analysis Main Window

The DSA main window is made up from three parts:

• A menu and toolbar at the top,
• A status bar at the bottom,
• and the waveform displays in between that is divided into a 

number of bands. Each band contains one or a number of 
waveforms.
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A range of display manipulation functions are available to extract the 
maximum amount of useful information from the recorded data. These 
include scaling, zooming, panning, dual cursor measurements, Power 
Analysis Toolkit (PAT), computing new channels and importing channels.

Other analysis functions can be added to the Tools menu. These include:

• Distance to Fault (DTF)
• Expert system

Graph Window Operations
DSA32 displays records in one or more graph windows contained within 
its main window. Each graph window can display any combination of 
channels from a single record together with any channels imported from 
other, open records.

Graph windows are arranged in horizontal bands each of which contains 
one or more channels. Each band is assigned a label. This defaults to the 
name of the first channel added to the band.

For:

• Analog bands the label appears to the left of the signal. The 
vertical zoom (gain) applied to analog bands appears before the 
channel's label (i.e. x10 indicates a times 10 multiplication).

• Digital bands the label appears to the right.

Underneath the bands a horizontal time axis is drawn. Time values 
appear at equidistant points along the axis at an interval suitable for the 
period of time in use.

When the graph has been zoomed a horizontal scrollbar appears below 
the time axis for panning through the record. The axis label depends on 
the record type.

Transient records display times in seconds, milliseconds or microseconds 
depending on the sampling rate during record creation. To keep the 
display manageable it sometimes appears in tens or hundreds of the base 
unit. This is indicated in the unit description given to the right of the axis 
that reads something like x10 ms - this means that each tick on the axis 
gives a value in tens of milliseconds.

Disturbance records display their times on the axis in a minute:second 
format with the seconds given to two decimal places.

Logger records display their times in a day-hour:min format.
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Status Bar
The status bar appears at the bottom of the main DSA32 window and 
displays general status and help information. It is toggled on/off using 
View > Status Bar. Hiding the status bar frees up screen space for use in 
displaying graphs, which may be significant when DSA32 is run at lower 
resolutions.

The main part of the status bar displays text messages such as a brief 
summary of menu operations as the cursor passes over them. Brief help 
messages for both the main toolbar and the PAT toolbar also appear here. 
Some DSA32 options display a progress control here to provide feedback 
during time consuming operations.

The rightmost part of the status bar contains three recessed areas that 
indicate the status of the <Cap Lock>, <Num Lock> and <Scroll Lock> 
keyboard key, respectively.

Bands
The display area of a graph window is divided among the channels 
(Figure 3.2) on display. This division occurs by allocating the screen area 
as an appropriate number of non-overlapping, horizontal bands within 
which signals are drawn. There are two band types:

• Analog bands
• Digital bands 

Their height is set to fill the available space with all analog bands being 
of equal height and all digital bands being of equal height.
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Figure 3.2  Main Window Bands

Each band is used to display one or more channels. DSA32 does not 
require that overlaid channels share the same unit, but if they were 
recorded with differing full scale deflection values, then a warning 
appears that visual comparisons are inaccurate. In other words, a point 
representing 100V in one of the channels may be drawn lower than a 
point representing 50V in the other channel because the latter represents 
a different range of values.

No combination of digital, monopolar and bipolar analog channels is 
permitted within the same band.

Vertical scaling (gain) can be applied separately to each analog band in 
the window. This scaling is applied to every channel in the band and 
may result in the signal moving off the visible range.
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Phasor Display Figure 3.3 shows a blowup of the Phasor Display.

Figure 3.3  Phasor Display

By default the displays appear in a bar at the bottom of the graph window 
where their display size is fixed with respect to the graph size. For more 
flexibility open individual displays in their own free-standing windows.

The free-standing display can be resized but always retains a square 
aspect ratio. To return it to the graph window simply close the window in 
the normal way. Only the free-standing phasor displays of the active 
graph are visible at any given time.

The actual points at which the measurements are made are assigned to 
either the left or right cursor. As the cursors on a transient record are 
moved the phasors rotate. By convention, moving the cursor to the right 
(forward in time) causes the display to rotate counter-clockwise. The 
phasor display does not rotate for a disturbance record.

This dependence on the cursors means that the phasor display is only 
available when the cursors are active. If the cursors are disabled the 
phasor display will be turned off.

If no displays have been configured DSA32 sets up one display on the 
record's first phase group and attaches it to the left hand cursor and 
another display on the second phase group attached to the right hand 
cursor. Both displays show the fundamental vectors.

DSA32 allows the definition of multiple displays. A display is a square 
area in the bar below the signal display in which phasors are drawn. At 
the top of the display there is a title and either an L or R icon indicating 
that the display is reporting on the Left or Right cursor position.

Each display can show the details of one or more phase groups. If 
multiple phase groups are defined for a display they are overlapped. 
Such phase groups are not necessarily scaled identically so visual 
comparisons of magnitude are inaccurate.
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For each phase group assigned to a display any combination of the 
following can be drawn:

• Fundamental phasors
• Positive phase sequence components
• Negative phase sequence components
• Zero phase sequence components

Phasor Display
Operations

To open free standing windows either:

• Right-click on the display and select Free-standing from the 
right-click menu or

• Use the ”Phasor Display” on page 3-6.

To enable the phasors:

1. Switch on the cursors.

2. Click  or select Options > Show Phasors in the Options menu.

To set the reference phasor in Band Settings:

1. Select it as the active channel in the band and the Active sub-channel 
list is filled with entries for Phase A, Phase B and Phase C.

2. Select the one for which cursor reporting is required. If the reference 
phasor is specified here, the cursor always reports an angle of zero.

Band Settings Use this dialog (Figure 3.4) to configure band appearance and select the 
active channel.

Figure 3.4  Band Settings
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Buttons and Fields

Scale Adjusts the scaling factor. Certain channels can 
have small signals that are not easily visible. These 
are automatically magnified to reveal more detail 
when DSA32 is started, as follows:

• TR100 records - magnification is limited to 99 
times for transient records and 1000 times for 
logger records.

• PQR channel - magnification is limited to 500 
times.

• TR100+ and TR2000 - all channels can be 
magnified x1000. 

The magnification scale factor appears to the left of 
the channel name or as a number on the graph. For 
x1 no value appears by the channel name. Limit 
the maximum scale factor using the Preferences 
dialog (”Preferences” on page 3-43).

A waveform magnified so that it expands outside 
its display area is clipped so as not to interfere with 
other channels.

Auto Assigns the largest scale value that keeps the 
visible portion of the signal entirely within the 
band's vertical range. When used with a band 
displaying monopolar channels this also selects an 
optimal range of values to display.

Auto operates solely on the visible portion of the 
channels in the band. If the window is zoomed to 
show only a small section of the record autoscaling 
only looks at that small section. Subsequent 
panning through the record may well reveal that 
parts of the signal are too large or too small for the 
band. Reapply the autoscale operation to bring 
them into view. To ensure that all parts of the signal 
are always visible, unzoom and then autoscale.

Autoscaling is also on the right-click menu.

Channel Colors Lists the names of all the channels in the band in a 
drop down. and its associated color used to draw 
the signal. Select these in the Colors dialog.
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Active channel Select the active channel from this drop down. 
When more than one channel is present in the 
band, the cursors only report values for the active 
channel. It can also be set in the Graph Setup 
dialog (”New Graph/Setup” on page 3-28) and in 
the band right-click menu.

Active sub-channel Select the active sub-channel from he drop down. 
Certain channels contain more than one signal. 
Examples are logger channels that contain 
maximum, average and minimum signals. The 
phase angles computed channel contains signals 
for each phase in the group on which it was based. 
When such channels are active in a band the 
cursors report only on one of these sub-channels. 

Band Settings
Operations

To configure settings:

1. Select Setup from a right-click menu and the dialog appears 
(Figure 3.4).

2. Use the spinners to set the Scale or click Auto for the largest available 
scale, if required.

3. Select the Active channel from the drop down.

4. Select the Active sub-channel from the drop down, if required.

5. Select a color from the Channel Colours drop down, if required.

NOTE The Edit button opens a Windows dialog for configuring special colors. 
See Windows documentation.

6. Click Display RMS in cursors to set it as the display magnitude.

7. Click Close.

Power factor A band containing the:

• Power factor from a TR100+ power logger is bipolar, but is based 
around a center line of 1. 

• Lagging power factor is drawn above the line and cursor 
measurements are appended with L.

• Leading power factor is drawn below the line and cursor 
measurements are appended with C. 
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Transient events Logger records from a PQR fitted with the High Speed Transient Capture 
option may contain information about transient events that occurred 
within the duration of the record. These are indicated by a triangular 
marker against the affected channel (Figure 3.5).

Figure 3.5  PQR Graph with High Speed Transient Capture Markers

• Click on the number above the marker and information about the 
event or events that occurred during the indicated sample interval 
appears (Figure 3.6). 

The time and date of each event is listed along with the peak voltage, the 
time for the pulse to decay to 50% of its peak value and the phase angle 
of the peak relative to the positive zero crossing of the affected channel.

Figure 3.6  High Speed Transient Capture Information
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Display Manipulation
There are three ways to manipulate the waveforms:

• Zooming - Extends a selected portion of the record to the full 
width of the window.

• Panning - Moves a zoomed display through the record, forwards 
or backwards.

• Scaling - Modifies a band’s channels vertical gain.

Panning Once a display is expanded a horizontal scrollbar appears at the bottom 
of the window. Use this to pan over the data:

• Click on the arrows at the data at either end scrolls smoothly. 
Holding down <Shift> key while scrolling minimizes the scroll 
speed.

• Click in the area between the arrow and the moving square 
causes the graph to jump.

• Click and drag the scroll bar thumb pans the display forwards or 
backwards.

If the screen flashes as it is panned or is slow to update see Graph Double 
Buffering in ”Preferences” on page 3-43. Alternatively, use the mouse 
wheel to pan the record (”Mouse Wheel Support” on page 3-12).

Docking Windows In DSA32 both the main toolbar and the PAT toolbar are used in two 
ways:

• Free-floating windows or,
• Docked to the inside of the main DSA32 window.

By default DSA32's toolbars are docked to the top of the main window. 
In this condition they are part of the window's frame and the contents of 
the main window are resized so that it cannot overlap the docking area.

If a window is undocked it appears as a window with its own title bar by 
which it can be dragged. An undocked window overlaps the main 
DSA32 window and graph windows, PAT dialogs etc. ware drawn under 
it.

Toolbar
Undock/Dock

Operations

Undock a docked window

To undock a window:

1. Click between the toolbar buttons and drag it out into the DSA32 
window.
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2. Release the mouse button and the undocked toolbar appears 
(Figure 3.7).

Figure 3.7  Undocked Toolbar

Docking a window

To dock a window:

1. Click on the title bar of the toolbar and drag it to the inside edge of 
the DSA32 window. Dock it to any side - top, bottom, left or right.

2. Release the mouse and the docked toolbar appears (Figure 3.1 
on page 3-2).

Mouse Wheel 
Support

A number of display functions can be duplicated using the mouse control 
wheel

Mouse Wheel
Operations

Pan a record

To pan a record roll the wheel:

• Forward to pan to the left
• Backward to pan to the right

<Shift>+wheel reduces the scroll speed to a minimum.

Zoom a record

To zoom a record:

1. Press <Ctrl> and use the wheel.

2. Roll the wheel:

• Forward to increase the zoom
• Back to reduce the zoom
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Adjust the gain

To adjust gain:

1. Place the mouse pointer over a channel label (the hand cursor 
appears) the wheel scales that channel or band (see ”Band Settings” 
on page 3-7).

2. Roll it:

• Forward to increase the gain
• Back reduces it.

Overlapping 
Records

Set the Preferences Scan for overlapping records on load option and a 
search of the Display Station database occurs as each record is loaded. If 
other records are found in the database that overlap this one, they are 
marked on the horizontal time axis (Figure 3.8).

Figure 3.8  Overlapping Records

This is useful for showing where a transient record exists for a 
disturbance record or logger record. It also indicates if a disturbance 
record is present for a logger display. This provides an easy way to view 
the same event at different levels of detail.

Records have the following indicators:

• A transient record has a red circle with a T. 
• A disturbance record has a yellow circle with a D.
• A logger record has a blue circle with an L.

Overlapping
Record

Operations

To open overlapping records:

1. Double-click on the symbol and the record details appear

If there is more than one record at that time, multiple details appear. 

2. Click on the detail to open its record.
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Right Click Menu Figure 3.9 shows the DSA right-click menu. Menu items are explained 
below.

To access this menu:

• Move the mouse over the band label and  appears - 
right-click.

Figure 3.9  DSA Right-Click Menu

Setup Opens the Band Settings dialog (”Bands” 
on page 3-4).

Autoscale This autoscales the channels in the band.

RMS Cursors Toggles the band cursor display between 
instantaneous and RMS quantities for transient 
records.

Labels for all the band channels appear below. The active channel has a 
checkmark.

Warning Messages
During DSA32 operation a number of warning messages can appear, 
including:

Alternate Phase Group Classification

When working with non-TR2000, TR100+ and 
PQR records it is necessary to provide phase group 
classifications. These classifications are stored in 
the Display Station database.
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Channel Import Synchronization Issues

The Import Channels facility is used with TR2000 
records. Such records are produced with 
synchronous sampling so that any two machines 
will sample the live signals at the same instant. This 
allows DSA32 to synchronize the records exactly 
from their time details.

With non-TR2000 records, there may not be 
synchronous sampling so importing encounters a 
fixed error of up to half the sample period of the 
record into which the channel is imported.

Line Group Information Unavailable

A number of DSA32 dialogs allow the selection of 
a line group. Line groups are not defined in 
non-TR2000, TR100+ or PQR records and so when 
working with these records the line group selection 
is disabled.

Display Station not running

This message appears when selecting Graph > 
Open record. This facility hands control over to 
Display Station for record selection. If Display 
Station is not running the operation cannot 
complete. To remedy this situation, restart Display 
Station.

Phase group information unavailable

Records generated by older recorders, such as the 
TR100, DL8000 or TR1600 and COMTRADE 
records, do not contain some of the phase group 
information held by the TR2000, TR100+ or PQR. 
Specifically:

• VT type, i.e. phase-to-phase or phase-to-neutral
• Group type, i.e. voltage phase group or current 

phase group

These details are required for some of DSA32's 
computed channels. See ”Older Records” 
on page 3-20. 
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A number of features are only available for 
Transient and Disturbance records. These 
operations are unavailable for Logger records.

Phase Group Classification
When non-standard records are opened in DSA32 it is necessary to 
provide a classification of each of the record's phase groups. This is 
required as certain details required to complete some operations are 
provided in some records but missing from previous types. Specifically, 
for each phase group the following details are needed:

• VT type, i.e. phase-to-phase or phase-to-neutral
• Group type, i.e. voltage phase group or current phase group

This classification occurs either as soon as the record is loaded or when 
the first operation requiring the missing information is requested. The 
timing is set in the Preferences dialog (”Preferences” on page 3-43).

The Classify Phase Groups dialog lists three choices:

• Classify this record - the classification provided is recorded 
against this record for all future uses.

• Classify this machine - the classification provided is recorded 
against the machine that produced this record and every record 
retrieved from that machine uses this same classification.

• Use defaults - no classification is provided and DSA32 continues 
with its best guesses as to the phase group details. This temporary 
classification is not recorded and he Classify Phase Groups dialog 
reappears when the record is reopened.

If a record or machine is incorrectly classified use ”Reclassify” 
on page 3-36 to correct it.

See ”Older Records” on page 3-20 for a full procedure.
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Main Toolbar/PAT Toolbar

A number of commonly used operations in DSA32 are accessed through 
the buttons on the main and PAT toolbars.

The main toolbar accesses the following functions listed in Table 3.1.

Table 3.1  DSA Main Toolbar Icons

Icon Function

New graph (”New Graph/Setup” on page 3-28)

Open record (”Open Record” on page 3-19)

Graph setup (”New Graph/Setup” on page 3-28)

Copy the active graph to clipboard (”Copy” 
on page 3-39)

Print the active graph (”Print/Print Preview/Print 
Setup” on page 3-37)

Print preview for the active graph (”Print/Print 
Preview/Print Setup” on page 3-37)

About DSA32 (”About DSA32” on page 3-115)

Zoom the active graph (”Time Axis” on page 3-103)
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The PAT toolbar accesses the following functions listed in Table 3.2. For 
all the options apart from System Frequency, the buttons remain in the 
inactive state as long as their associated dialog is visible. Clicking them 
again closes that dialog. The Phasors button remains inactive as long as 
the phasor display is active.

Unzoom the active graph (”Time Axis” 
on page 3-103)

Toggle cursors in the active graph (”Cursors” 
on page 3-104)

Add an annotation to the current graph (”Add 
Annotation” on page 3-105)

Table 3.2  PAT Toolbar Icons

Icon Function

Open the System Frequency dialog (”Fundamental 
Frequency” on page 3-52)

Open the Single Channel Calculations dialog 
(”Single Channel” on page 3-53)

Open the Power Calculations dialog (”Power” 
on page 3-55)

Open the Sequence Components dialog (”Sequence 
Components” on page 3-60)

Open the Harmonic Analysis dialog (”Harmonics” 
on page 3-63)

Open the Phasors dialog (”Phasor Display Setup” 
on page 3-30)

Table 3.1  DSA Main Toolbar Icons (Continued)

Icon Function
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Main Menu Bar

The Display Station main menu bar consists of:

• ”Graph Menu”
• ”Edit Menu” on page 3-39
• ”View Menu” on page 3-40
• ”Power Analysis Toolkit (PAT) Menu” on page 3-51
• ”Channels Menu” on page 3-66
• ”Tools Menu” on page 3-101

Graph Menu
DSA uses a selected or default layout to display the recorded waveforms. 
This layout is created or edited using ”New Graph/Setup” on page 3-28. 
The layout can be saved for use with the current and other records.

Menus items include:

• ”Open Record”
• ”Open File” on page 3-21
• ”Close” on page 3-22
• ”CSV Export” on page 3-22
• ”COMTRADE Export” on page 3-26
• ”New Graph/Setup” on page 3-28
• ”Setup Colors” on page 3-34
• ”Reclassify” on page 3-36
• ”Print/Print Preview/Print Setup” on page 3-37
• ”Exit” on page 3-39

Open Record
Up to 30 records can be opened at the same time in DSA.

Open Record
Operations

To open a record:

1. Open a new record by either:

• Selecting Open record in the Graph menu
• Clicking  on the main toolbar.

This opens the Display Station scrolling list of records.
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NOTE Older records may need to be reclassified. See ”Older Records”.

2. Double-click on the record entry and the associated record dialog 
appears. The nature of this dialog depends on the record type.

Older Records For older records whose phase groups have not yet been classified the 
Classify Phase Groups dialog appears (Figure 3.10).

Figure 3.10  Classify Phase Groups I

1. Click the appropriate button:

• Classify this record 
• Classify this machine
• Use defaults

The Display Station Analysis Classify - Phase Group dialog appears 
(Figure 3.11) for the first two bullets.

Figure 3.11  Classify Phase Groups II

2. Select a channel from Channels and a Classification for a Phase group 
and click OK.

This repeats until all Phase groups are configured. The Display 
Station Analysis main window appears ready for use.
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NOTE When Current is selected as the Type of the group, the wiring selection 
is disabled and a default of phase-to-neutral is set.

Click Cancel during this process and any classifications already 
confirmed are saved against the record or the machine as appropriate. 
DSA32 continues this session using its best guesses for the unclassified 
phase groups and, if the record is re-opened later, the Classify Phase 
Groups dialog reappears but only previously skipped phase groups need 
be classified.

If the layout of the record has been previously saved the Restore Layout 
dialog appears (Figure 3.12).

Figure 3.12  Restore Layout

• Click the required radio button and use the spinner to select the 
record and click Restore.

The behavior of Classify Phase Groups and Restore Layout is controlled 
by settings selected in ”Preferences” on page 3-43.

Open File
Use this option as a quick way of viewing records that are not in the 
normal list (e.g. archived records on a floppy disk).

NOTE DSA32 supports IEEE C37.111-1999 standard records with no channel 
amplitude offsets and a single recording frequency.

Open File
Operations

To open a file:

1. Select Graph > Open file.

The Open dialog appears.

2. Navigate to a directory and select a file a transient, disturbance or 
logger record. Additionally, a COMTRADE format record can be 
specified for import.
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Close
This closes all active graphs for a record.

To perform this operation:

• Select Graph > Close or click the close box X at the top right of 
the window.

CSV Export
Use this window (Figure 3.13) to export data from the active record. 
Some, or all, of the channel data can be exported to a file. The format 
used for this file is Comma Separated Variable or CSV. This format can be 
read by many third party applications, such as spreadsheets etc.

Figure 3.13  CSV Export

Buttons and Fields

Channels Lists all of the active record channels. Select one or 
more for inclusion in the export.

Select All Selects all of the record's channels.

Samples Click one of the radio buttons: 

All - exports the sample data for the full duration of 
the record.

Advanced
options
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Visible only - export operates in conjunction with 
the Zoom setting to export only that portion of the 
record currently visible in the active graph. If a two 
minute period of a thirty minute log is zoomed, this 
produces a CSV file containing only the data for 
that two minute period.

OK Performs the export operation. The operation 
progress appears on the status bar. For all but the 
largest records, this should take no more than a few 
seconds.

Advanced Export Toggles the Advanced section into view.

There is some variation in the format of the CSV 
files used by other applications. The default 
settings produce a file that can be loaded 
immediately by the leading desktop applications. 
However, other packages may require a slightly 
different CSV format which is the purpose of 
Advanced options.

Delimited by Configures the separator character used in the CSV 
output. By default a comma is used to separate 
values in each line of output. This can be changed 
to a tab or semicolon or, using the Other option, 
any arbitrary character is entered in the text field 
alongside the drop down list.

Text Qualifier Changes the characters that enclose text data. Text 
data, such as channel labels and units, are 
enclosed in standard quotation marks by default - 
e.g. "Channel 1". A pair of apostrophes are 
available, or no distinguishing character at all.

Include labels Enable this check box and extra text items are 
added at the start of the CSV giving the location, 
machine name, trigger time and sample rate of the 
record. Each of these items consists of two pieces 
of text:

• A description of the data e.g. "Location", and
• the data itself e.g. "Moira".

It also includes the channel name and unit at the 
head of each channel's data.
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Multiplexed Toggles the data format from row-based to 
column-based.

With the box unchecked the output for an export of 
three channels, A, B and C might look like this 
(where A-1 represents sample 1 in channel A and 
so on):

A-1, A-2, A-3, A-4, ...

B-1, B-2, B-3, B-4, ...

C-1, C-2, C-3, C-4, ...

With the Multiplexed box checked would appear 
like this:

A-1, B-1, C-1

A-2, B-2, C-2

A-3, B-3, C-3

...,...,...

NOTE Non-multiplexed files may have extremely long line lengths, with many 
thousands of sample items on each line. This could cause problems if 
the file were loaded into a simple text editor or other program.

This setting affects the channel name and unit 
information provided when the Include labels 
option is checked. When the Multiplexed option is:

• Unchecked the items are added at the start of 
each channel's row like this:

"Channel A", "kV", A-1, A-2, A-3, A-4, ...

"Channel B", "kV", B-1, B-2, B-3, B-4, ...

"Channel C", "kV", C-1, C-2, C-3, C-4, ...

• Checked, the items are added at the top of each 
channel's column like this:

"Channel A", "Channel B", "Channel C"

"kV", "kV", "kV"

A-1, B-1, C-1

A-2, B-2, C-2

A-3, B-3, C-3

...,...,...
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Include sub-channels

Activate this check box to include sub-channel 
data in the export.

Include times Activate this check box to include times in the 
export.

CSV Export
Operations

To export into CSV format:

1. Select CSV Export.

The Export dialog appears (Figure 3.14).

Figure 3.14  CSV Export

NOTE The graphic in Figure 3.14 has Advanced features showing. Click 
Advanced to display these items.

2. Select the required Channel(s) and configure other desired Advanced 
items.

3. Click OK and the Save As dialog appears (Figure 3.15).
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Figure 3.15  CSV Save As

4. Navigate to the required directory, enter a name and click Save.

COMTRADE Export
Use this window (Figure 3.16) to export COMTRADE data.

Figure 3.16  COMTRADE Export

Buttons and Fields

Export as Display the names for the three files that are 
created by the export. The browse button to the 
right opens a standard Save as dialog to use a 
different filename or folder. It is the configuration 
(*.cfg) filename that is specified here but on return 
from the dialog, all three filenames are updated 
appropriately.

ASCII/Binary Click a radio button to select the file format:

ASCII - the larger format.

Binary - the more compact format.

This only affects the *.dat file.
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Include calculated channels

Check this and any computed channels created in 
the active record are included in the COMTRADE 
file.

Export Performs the actual export according to the 
specified criteria. If one or more of the output files 
already exists, a confirmation dialog appears 
before they are overwritten.

Comtrade Export
Operations

To export a Comtrade file:

1. Select COMTRADE Export.

The COMTRADE Export dialog appears (Figure 3.17).

Figure 3.17  COMTRADE Export

2. Click the browse button .

The Save As dialog appears.

3. Navigate to the correct directory, name the file and click Save.

The COMTRADE Export widow reappears with the new file name 
and directory.

4. Click the file type and Include calculated channels, if required.

5. Click Export.
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New Graph/Setup
Use this dialog (Figure 3.18) to create or alter the appearance of the 
active graph by arranging the contents of the Channels Selected and 
Channels Available lists. In addition, the Phasor Display configures the 
phasor display (”Phasor Display Setup” on page 3-30). 

Figure 3.18  Graph Setup

Buttons and Fields

Title Enter a unique title for a new graph or edit an 
existing graph name. This appears at the top of the 
graph window. It also appears under the Window 
menu. The active graph has a tick mark. The names 
for the default graphs are Analogs 1-8, Digitals 
1-16 etc.

Channels available Lists all the available analog and digital channel 
names.

Analog and digital channels are added in a similar 
way. The selected channels appear in the order 
that they are displayed. As new channels are added 
to the display they are appended to the Channels 
Selected list.

Insert Inserts a selected Channels Available item above 
the Channel Selected item. One or more items can 
be inserted.
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The digital channels are automatically interlaced 
with the analog channels. There can be up to two 
digital channels between each pair of analog 
channels.

Remove Select a Channels Selected channel(s) and click 
this to remove a channel(s).

Overlay channels in a band 

Overlays a number of analog channels on the same 
band.

If the channels in a band have different full scale 
values or units a warning message appears 
indicating that visual comparisons of magnitude 
are incorrect. When the cursors are used on a band 
containing more than one channel, only the active 
channel's measurements are shown and its name 
appears in bold text.

Set Active Sets a selected channel as active. This can also be 
set using the ”Band Settings” on page 3-7 or the 
”Right Click Menu” on page 3-14.

New Graph
Operations

To add and configure a new graph:

1. Click  to create a new graph or select Graph > New Graph.

The Graph Setup dialog appears (Figure 3.19) with no selected 
channels.

Figure 3.19  Graph Setup

2. Select a channel in the Channel Available and click Add.
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3. Click a channel in Channels Selected, click a channel in Channels 
available and click Add to Band and it appears as a sub-item of that 
channel, if required.

NOTE The channel selected as a band must be of the same type.

The band is given the name of the first channel added to it.

4. Select the name and click Edit Title and enter the new name, if 
required. Alternatively, double click on the text of the band's name.

5. Overlay a channel by:

a. Add the first channel.
b. Select the target band.
c. Select all the required names from the Channel Available list.
d. Click Add to band.

6. Select a channel and click Set Active, as required.

7. Click Phasor Display to configure this display (”Phasor Display 
Setup” on page 3-30).

8. Click OK.

Phasor Display 
Setup

Use this window (Figure 3.20) to display a number of phasor diagrams 
below the waveform display of a transient or disturbance record. These 
show the relative amplitudes and angles of three phase voltages and 
currents. The absolute length of the vectors is adjusted to use the most of 
the display. The values of RMS amplitude or angle can be superimposed 
on the display. Voltage vectors have an arrow head and current vectors 
have a circle.

Figure 3.20  Phasor Display Setup
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Buttons and Fields

Left cursor Sets the dialog to list all the displays attached to the 
left cursor. New displays created while this 
selection is enabled are attached to the left cursor. 

Right cursor Sets the dialog to list all the displays attached to the 
right cursor. New displays created while this 
selection is enabled are attached to the right 
cursor.

Display selection Select from the list of all displays attached to the 
selected cursor. The title of the display can be 
altered.

Add Adds a new line to Display to title a new phasor.

Remove Removes the selected phasor with confirmation.

Free standing Activate and the display is drawn as an 
independent window. This option can also be 
enabled using the right-click menu (”Right Click 
Menu” on page 3-14 and disabled by closing the 
window.

Phase group list Lists the names of the phase groups to be drawn in 
the selected display. Four columns contain either a 

 or  against the display options for each group. 
Click on the symbols to switch them on or off.

Label Annotates the vectors:

• Angle - annotates with their angle.
• Magnitude - annotates with their RMS 

magnitude.
• None - Switches annotation off.

Add a phase group Adds a phase group so more than one phase group 
appear together. This is the Add button on the 
bottom of the window.

The default vector that appears is the fundamental. 
Alternatively, the positive, negative or zero phase 
sequence can be shown. Any or all of the vector 
types can be shown together but it is advisable not 
to clutter the display with too many vectors. 
Instead create a new display for the different vector 
types.
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Remove a phase group

Removes a phase group. This is the Remove button 
at the bottom of the window.

Phase Group and
Phasor

Operations

Phasor Displays

To add and configure a phasor display:

1. Click Phasor Display and the Phasor Display Setup dialog appears 
(Figure 3.21).

Figure 3.21  Phasor Display Setup - Before Configuration

2. Click Add at the top of the dialog.

3. Enter a Display name or select an existing phasor for modification.

4. Click Add on the bottom of the dialog.

This lists the Channels selected from the Graph Setup dialog.

5. Add an extra phase group to an existing display by:

a. Selecting the display from the drop down list at the top of the 
window.

The phase group name and vector type(s) appear the list 
below. 
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b. Clicking Add at the bottom of the window and the Phase 
Group dialog appears (Figure 3.22).

Figure 3.22  Phase Group

c. Selecting the new phase group and vector type and click OK.

The default vector that appears is the fundamental. Alternatively, the 
positive, negative or zero phase sequence can be shown. To do this, 
click on the red cross below the selected vector. This changes to a 
green tick. 

6. Select a Phase Group and click OK.

The Phasor Display Setup dialog reappears with the Phase Group 
added (Figure 3.23).

Figure 3.23  Phasor Display Setup - After Configuration

7. Click a Label radio button.

Click to toggle between activate/deactivate.

8. Click Close.

The Graph Setup dialog reappears.

9. Click Close.
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To remove a phase group:

1. Select the display.

2. Click on the name of the phase group and click the Remove button at 
the bottom of the window.

A dialog appears to confirm.

3. Click Yes.

Setup Colors
Use this dialog (Figure 3.25) to configure the color of each analog 
channel, as well as the text, background, phasor displays and digital 
inputs.

Figure 3.24  Colour Setup

Buttons and Fields

Display/Printer colours

List the color source settings.

Reset to defaults Resets color section to system defaults for the 
printer: black text and waveforms on a white 
background.

Load Loads settings from a *.col file.

Save Saves settings to a *.col file.

Items Lists items to which colors can be applied.

Edit Colour Opens a standard Windows dialog box for color 
selection.
3-34 1086-339  Rev. A   11/05



Fault Recorder Operations Manual
Color
Configuration

Operations

To configure colors:

1. Select Graph > Color and the Colour Setup dialog appears 
(Figure 3.25).

Figure 3.25  Colour Setup

2. Select Display/Printer colours using the drop down:

• Set colours for screen
• Set colours for b&w printer
• Set colours for colour printer

3. Click OK.

To load a colour scheme:

1. Click Load and the Load Colour settings dialog appears.

2. Navigate to and select the .col file and click Open.

To save a colour scheme:

1. Click Save and the Save Colour settings dialog appears.

2. Navigate to the directory and enter a name and click Save.

NOTE Name files screen.col and printer.col and they are loaded as the default 
colors when DSA is started.

To edit the color of a particular item:

1. Click a name in Items, then click Edit Color.

2. Click on a new color and click OK.

To create custom colors:

1. Click Define Custom Colors.
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2. Use the power bar at the right of the dialog box to create a color and 
click Add to Custom Colors.

The new color appears in the Custom colors area.

To set the color of analog channels:

1. Double-click on the channel name in the main window or select 
Setup on the channel’s right-click menu and the Band Settings dialog 
appears (Figure 3.26).

Figure 3.26  Band Settings

2. Click Edit, select a color and click Close.

Reclassify
When working with TR100 records it is necessary to classify the defined 
phase groups by providing additional information. If incorrect 
information has been entered for a record or a recorder, See ”Older 
Records” on page 3-20 to reclassify them.

TR2000, TR100+ & PQR records contain explicit information as to the 
wiring of their phase groups. However, the type classification (voltage or 
current) is derived from the units defined for the channels in the 
respective groups. If this classification is in error, use Reclassify to 
override it. In this case the option to identify the phase group as 
phase-to-phase or phase-to-neutral is disabled.

NOTE If a classification has already been provided for this specific record, any 
machine classification added in this way is ignored when the record is 
subsequently re-opened since the per-record classification has priority.
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Print/Print Preview/Print Setup

Print Setup To configure print setup:

1. Select Graph > Print Setup and a standard Print Setup dialog appears 
(Figure 3.27).

Figure 3.27  Print Setup

2. Click Properties to display printer-specific settings for configuration. 
The features available for configuration vary with the make of printer 
and the version of the driver software installed.

Print Preview Use this window (Figure 3.28) to preview and print the graph.

Buttons and Fields

Print... Causes the graph as shown to be printed.

Next Page/Prev Page/Two Page

Disabled.

Zoom In Increases the size of the preview for detailed 
examination. Use the button twice to increase the 
magnification in two stages to its maximum.

Alternately, click directly on the preview image 
with the mouse, which displays the icon while 
over the display. This magnifies the image as 
before and also ensures that the resulting display is 
scrolled so that the selected point is visible.

Zoom Out Decreases the magnification, in two stages, until 
the whole page is visible.
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If the preview is fully zoomed, clicking on it with 
the mouse cancels all zoom and restores the full 
page display.

Close Closes the preview and restores the normal graph 
window display. Any PAT dialogs that had been 
hidden are now restored.

Print Preview
Operations

To see a preview:

• Select Graph > Print Preview. The graph window changes to a 
graphical representation of the printed output.

Figure 3.28  Print Preview

Print Graph DSA32 uses the standard Windows® printer drivers, so most printer types 
can be used to print DSA32 graphs.

DSA expands the graph to the maximum allowed by the size of the 
paper.

The printed graph is similar to the screen display but includes:

• A header with the location and name of the recorder, the time and 
date of the record and the cause of the trigger.

• A comment field as a footer at the bottom of the page.
• Displayed cursors printed as solid lines.
• Trigger and end of trigger points printed as dashed lines.
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The fonts used for the main display, the header and footer text are set in 
the Preferences dialog (”Preferences” on page 3-43).

The default color scheme for the printer output is black on white. See 
”Setup Colors” on page 3-34 to change to a color output.

Print Operations To print a displayed graph either:

• Select Graph > Print or click .

For more information on this consult Windows help. 

Exit
To exit DSA:

1. Select Graph > Exit and DSA shuts down.

If the option to automatically save graph layouts is selected in 
Preferences, the Save Layout (”Save Layout” on page 3-109) dialog 
appears for each open record.

2. Click Yes.

Edit Menu
This menu consists only of Copy.

Copy
This places a copy of the active graph on the clipboard for pasting into 
other applications, such as word processors.

The image placed on the clipboard is in the format used for printing the 
graph. It includes the header and footer text and uses the colors defined 
for printed output. Use ”Print/Print Preview/Print Setup” on page 3-37 to 
see exactly what is sent to the clipboard.

The image is stored on the clipboard as an enhanced-format metafile. 
This is a device-independent format that retains shape and proportion on 
any output device as well as allowing it to be easily resized. If the 
application in use does not support this format you won’t be able to paste 
in DSA32 screens.

Copy Operations To copy a record:

• Select Edit > Copy to copy the active graph or click .
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View Menu
This menu consists of:

• ”Record Header”
• ”Analogue Profile” on page 3-41
• ”Digital Profile” on page 3-42
• ”Main Toolbar/Status Toolbar/Status Bar” on page 3-43
• ”Preferences” on page 3-43

Record Header
Use this window (Figure 3.29) as a strictly informational guide that gives 
the various header details of the active record. The type of record dictates 
what appears.

Figure 3.29  Record Header

Buttons and Fields

Recorder Identification

Provides the Location and Machine Name of the 
recorder that generated this record.

Trigger Information Lists the:

• Trigger type
• Trigger time - Presented as a 24 hour clock; 

date and day number along with an indication 
of the time synchronization status.

• Record Length - Given in cycles for transient 
records and in seconds for disturbance records.

Comment Presents any comment attached to the record.
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Logger records only

Recorder Identification- Same as above.

Record Information Includes the:

• Start and end time of the logging period (time, 
date, day number)

• Interval between samples in the record
• Total length of time that the record covers.

View Record
Header

Operations

To open the record:

• Select View > Record Header and the Record dialog box appears 
(Figure 3.29).

Figure 3.30  Record Header

Analogue Profile
Use this window (Figure 3.31) to list any analog profile information 
available for the record. For each channel pre-fault, immediate, final and 
post-clearance RMS values appear together with the defined unit. The:

• Pre-fault measurement is made on the cycle prior to the trigger 
point.

• Immediate measurement is made on the cycle after the trigger 
point.

• Final measurement is made on the cycle prior to the safety point.
• Post-Clearance measurement is made on the cycle after the safety 

point.

Records also contain maximum and minimum RMS values for each 
channel. The duration of the fault appears as the time from the trigger 
point to the start of the safety window.
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Analogue Profile
Operations

To open the Analogue Profile:

1. Select View > Analog Profile and the Analog Fault levels dialog 
appears (Figure 3.31). 

Figure 3.31  Analogue Profile

2. Select an analog channel and click OK and the recorder header 
dialog reappears.

Digital Profile
Use this dialog (Figure 3.32) to list the record’s digital profile information. 
For each transition in the record the following appears:

• the channel
• the state to which it switched
• the time of the transition relative to the trigger time
• the duration of the fault. This is the time from the trigger point 

to the start of the safety window.
Digital Profile

Operations
To open the Digital Transitions:

1. Select View > Digital Profile and the Digital Transitions dialog 
appears (Figure 3.32).

Figure 3.32  Digital Profile
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2. Select a digital channel and click OK and the recorder header dialog 
reappears.

Main Toolbar/Status Toolbar/Status Bar
Hiding the toolbar may free up screen space which can be used to 
display graphs, this may be significant when DSA32 is run at lower 
resolutions.

To toggle these options on/off:

• Click the menu item.

A check appears next to the item when active.

Preferences
Use this window (Figure 3.33) to configure a number of DSA settings. 
These are automatically saved and are always used when DSA32 is 
running.

Figure 3.33  Preferences
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Fields and Buttons

THD Calculation method

Select the Total Harmonic Distortion (THD), which 
is the ratio of the root of the sum of the squares of 
the harmonic amplitudes from two upwards to the 
amplitude of the fundamental voltage or current 
expressed as a percentage. There are two ways to 
express the amplitude of the fundamental:

• IEEE  - Uses the true amplitude of the 
fundamental component. The IEEE function is 
defined in IEEE 1035 – 1989. For transient 
records it is calculated as follows:

For disturbance records it is calculated as follows:

• ANSI  - Uses the RMS value of the signal. The 
ANSI function is also used by CSA and IEC. For 
transient records it is calculated as follows:

For disturbance records it is calculated as follows:

For small values of THD, there is very little 
difference between the two values. For extreme 
levels of harmonics the IEEE scheme for THD can 
exceed 100%, but the ANSI method never can.
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Graph double buffering

Enable this option and the graph display does not 
flicker when it is scrolled. It may slow the screen 
update speed on slower computers.

Live scrollbar update

Improves the update rate for slower computers. 
Enable this option and the cursor measurements at 
the left of a graph are updated when the graph is 
scrolled using the scrollbar. This may slow down 
the re-draw time for a slower computer.

Cursor Acceleration

Disable this option and using the keyboard arrow 
keys moves the cursors left or right one sample at a 
time. If there are many thousands of samples on the 
screen, the cursors move very slowly.

Enable this option and the cursors step multiple 
samples at a time. The size of the step is 
proportional to the number of samples currently on 
display so that the speed at which the cursors 
progress across the screen remains roughly 
constant, no matter how large the data set.

Whether or not to use acceleration depends on 
how keyboard control of the cursors is used.

If the cursors are normally positioned using the:

• Mouse and keyboard control is reserved for 
fine positioning, then turn acceleration off.

• Keyboard, then acceleration makes this less 
tedious with large records.
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Opaque annotations

Enables/disables Opaque annotations. There are 
two ways to draw annotations on a graph window:

• Transparent - Draws text over whatever is 
already present on the screen. This has the 
advantage of reducing the degree to which they 
obscure the signal detail, however they can be 
harder to read. 

• Opaque - Erase the portion of the graph where 
the text appears. These can obscure signal 
detail, but they are generally easier to read.

Scan for overlapping records on load

Enable this option and DSA32 searches the Display 
Station database each time a new record is loaded. 
This search identifies any records, which overlap 
the one being loaded. A marker appears in the 
horizontal axis of the graph window to indicate 
this fact (See ”New Graph/Setup” on page 3-28). 
Disabling this option may improve load times on 
slower systems with many records.

Configure Phase Groups on load

Enables/disables configuration on load. For a 
non-TR2000, TR100+ or PQR record, the type of 
the phase groups are unknown. Before any power 
or impedance calculations are made the group 
type (V or I) and the VT type (p/p or p/n) must be 
confirmed (see ”Older Records” on page 3-20). 
This can be done either when the record is first 
loaded or when a relevant calculation is requested. 
This need only be done the first time the record is 
opened, as the phase group information is saved 
back into the Display Station 32 database.

Annotations on by default

Enable this option and new graph windows are 
created with annotations visible. To suppress the 
drawing of annotations in a given graph window, 
use the Show Annotations option.
3-46 1086-339  Rev. A   11/05



Fault Recorder Operations Manual
Disturbance times relative by default

Enable this option and the radio button in the 
Graph Setup dialog is set to Relative by default. If 
disabled, the default selection is Absolute. This 
determines if the horizontal time axis in the graph 
window shows the times in disturbance records 
either as offsets relative to the trigger point, or in 
absolute terms.

Check line group types

Enable this option and the units of the channels 
that make up the component phase groups for each 
line group are checked for consistency. If an error 
is detected an error message appears (Figure 3.34).

Figure 3.34  Check Line Group Types Error Message

Warn of long lines Enable this option and a warning occurs if long 
lines are discovered in a data record. This helps 
detect data records that are recovered over a 
network can have extra padding characters 
attached.

Autoscaling Autoscale on load - Enable this option and each 
analog input channel fills the available band. There 
are two rules that apply to this:

• Channels in the same phase group have the 
same scale factor

• There is a maximum scale factor depending 
on the recorder resolution

Disable this option and all channels are initially 
drawn with a scale factor of x1.

Cap autoscaling - Enable these options to define a 
maximum scale factor for each recorder resolution. 
The default values are:
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A reason for disabling autoscaling is that very small 
induced currents are magnified and it may appear 
that a line is still energized when, in fact, it is not.

Record Display configuration

Enable these options to control the loading and 
saving of the graph layout. The exact look of a 
record can be saved and used again when the 
record is next opened. Layouts are saved for 
individual records only or for use on all records 
from a particular recorder.

When a record is loaded, the format is treated in 
three different ways:

• Always restore - Always use the previous 
display layout. DSA32 selects a layout by 
searching through those available in this order:
• (1) Search for a default layout for that 

record - if that fails,
• (2) Search for any layout for the record - if 

that fails,
• (3) Search for a default layout for that 

recorder - if that fails,
• (4) Search for any layout for the recorder - if 

that fails,
• (5) Search for the default global layout - if 

that fails,
• (6) Search for any global layout
• If no layout is found, it uses the standard 

layout.
• Never restore - Always use the standard setup
• Ask - Prompt the user to select the layout. If no 

layouts exist, the standard setup is selected.

Bits Recorder Max scale

16 TR2000
TR100+

x1000

14 PQR x500

12 TR100 x100
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When a record is closed, the present display layout 
is in one of three ways:

• Always save - Always remember the layout for 
next time

• Never save - Never save the graph layout
• Ask - Prompt the user to save the layout.

If the setup is Always saved it is used as the default 
layout for that record only.

There are a number of ways this facility can be 
configured:

• The default is to Ask on load and Never save on 
close. This gives maximum control to you, as 
the layout is only saved through explicit use of 
the Save Layout menu option. When loading a 
record, you select any of the available layouts, 
or elect to use none of them.

• Selecting Always close and Always restore 
results in layouts being saved and restored 
transparently without your knowledge. The end 
result is that each record viewed has its layout 
saved and exactly that layout is automatically 
restored when the record is reopened. You can 
save a per-machine layout that acts as a 
template for all records from that machine the 
first time they are opened. As they are closed 
they receive their own layout that they use 
thereafter.

• Selecting Never restore and Never save 
effectively turns off this feature.

Report fonts Enables the Graph print option to add a header and 
footer to the printed output. The font and size of 
the print is selected independently for the header, 
footer and body text. The current font selections 
are given in the titles of the three buttons at the 
bottom of the dialog. Clicking on any one opens a 
standard font selection dialog from which a new 
font is specified. The font style specification is 
ignored by DSA32.
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The body font is also in the on-screen display but a 
newly selected font is only used in graphs created 
after the change.

Preferences
Operations

To configure preferences:

1. Select View > Preferences and the Preferences dialog appears 
(Figure 3.35).

Figure 3.35  Preferences

2. Select the THD Calculation method.

3. Click any of the ten check boxes underneath THD Calculation 
method, as required.

4. Click Auto scale on load, if required.

5. Click Cap autoscaling check boxes, as required.

6. Select an Element from the drop down.

NOTE Click Select in the Fonts area and the Font dialog appears to select font 
specifications.

7. Select When loading and When closing preferences from the drop 
down in Record Display Configuration area.

8. Click OK.

NOTE You must exit DSA for some settings to take effect.
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Power Analysis Toolkit (PAT) Menu
The Power Analysis Toolkit (PAT) is a calculation module for DSA32. A 
wide range of values can be calculated for individual channels and phase 
groups. There are a number of icons on the PAT toolbar (”Main 
Toolbar/PAT Toolbar” on page 3-17) for implementing the power 
calculations. These are also available under the menu. The functions 
available depend on the record type and whether you are connected.

As an alternative, the values can be computed over the entire length of 
the record. These new channels can be added to the graph display. For 
more information on this see ”Channels Menu” on page 3-66.

The PAT functions are:

• Peak, RMS & PU levels
• Form, crest & quality factors
• Harmonic content & THD
• Frequency
• Positive, negative and zero sequence components
• Apparent, real & imaginary power
• Power factor & X/R ratio

The values computed are for the parts of the signals that lie between the 
two cursors so these must be enabled for data to appear. While a PAT 
window is active you can alter the positions of the cursors in DSA32 and 
PAT recomputes and displays the new data. PAT automatically adjusts the 
right hand cursor to give an integer number of cycles between the 
cursors.

NOTE If the graph is zoomed to the extent that less than a cycle of data is 
visible, this adjustment is impossible - a warning appears.

This menu consists of:

• ”Fundamental Frequency”
• ”Single Channel” on page 3-53
• ”Power” on page 3-55
• ”Sequence Components” on page 3-60
• ”Harmonics” on page 3-63
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Fundamental Frequency
Use this window (Figure 3.36) to designate the channel for determining 
the system frequency.

NOTE Set the System Frequency before selecting the other functions.

Figure 3.36  System Frequency

To calculate the harmonics, sequence components and power accurately 
the actual system frequency is required. DSA32 can obtain this from the 
pre-trigger portion of a selected channel. The best signal to use is an 
unfaulted voltage channel.

If no channel is selected for frequency measurement, or the special 
Nominal entry is selected, the nominal value specified in the record is 
used (50.0/60.0 Hz). This correction is quite small for normal system 
frequency variations. The closer the actual frequency is to the nominal 
value, the smaller the correction factor. 

When DSA32 is started, the default is to use the nominal frequency.

Buttons and Fields

Chan Select the channel to calculate the harmonics, 
sequence components and power.

Freq Displays the calculated system frequency.
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System Frequency
Operations

To designate the channel:

1. Select PAT > Fundamental Frequency or click .

The System Frequency dialog appears (Figure 3.37).

Figure 3.37  System Frequency

2. Select the Chan.

The frequency obtained for that entry appears to the right.

3. Click OK.

Single Channel
Use this window (Figure 3.38) to display a number of computed values 
for a specified channel.

Figure 3.38  Single Channel Calculations

If the Print Preview is active for an active graph, it is hidden until the 
preview is closed.
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Buttons and Fields

Chan Select the channel. All channel names are 
available, not just the ones presently displayed in 
DSA32.

Peak Displays the maximum positive or negative value 
between the cursors. If the maximum excursion is 
negative then the value is negative.

RMS Displays the true root mean square value of the 
signal assuming an exact number of samples per 
cycle.

PU Displays the ratio of the RMS value to the nominal 
value of the channel as defined in the recorder 
configuration. 

Crest (peak factor)

Displays the ratio of the peak value to the RMS 
value. For a pure sine wave the ratio is 1.414.

Form Displays the ratio of the RMS value to the mean 
value. For a pure sine wave the ratio is 1.111.

Quality Displays the percentage difference between the 
absolute area under the signal compared with a 
pure sine wave with the same peak amplitude. This 
is the value that is used for sub-cycle triggering in 
the TR100 and DL8000.

Frequency Displays the measurement made by first filtering 
the data with a 12 pole low pass filter, then 
measuring the distance between successive zero 
crossings. For low level signals (i.e. load level 
current) the accuracy of this measurement may be 
degraded.

A minimum of two cycles between the cursors is 
required to measure frequency.

Single Channel
Operations

To use single channel calculations:

1. Ensure cursors are active. All PAT calculations are carried out on the 
samples between the cursors. If the cursors are not active, no values 
appear.

2. Select PAT > Single Channel or click  and the dialog appears 
(Figure 3.39).
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Figure 3.39  Single Channel Calculations

3. Select the Chan.

The values obtained for the entries appear.

4. Click OK.

Power
Use this window (Figure 3.40) to configure parameters for and view 
power calculation results for specific channels. Additionally, you can 
configure aspects of the Phase Groups.

If the Print Preview is active for an active graph, it is hidden until the 
preview is closed.

Figure 3.40  Power Calculations

All power calculations are performed on the fundamental phasors 
extracted from the source channels using the method described in 
”Single Channel Quantities” on page 3-73.

Per Phase Apparent Power

Apparent power is calculated as the product of the 
RMS magnitude of the voltage and current phasors:
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Per Phase Reactive Power

Reactive power is calculated as the product of 
apparent power and the sin of the phase angle:

The phase angle is calculated as the raw angle 
difference between the two phasors plus the 
specified correction value for CT lag.

Per Phase Real Power

Real power is calculated as the product of apparent 
power and the cos of the phase angle:

The phase angle is calculated as for reactive power 
above.

Total Power in Star (Phase-Neutral) Systems

The total system power in phase-neutral 
configurations is calculated by simply summing the 
three per phase power values. These are calculated 
as above.

Total Power in Delta (Phase-Phase) Systems

Total system power in phase-phase configurations 
is calculated by the two-wattmeter method:
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Real

Reactive

Apparent

where,

• Θ - phase angle between Vba and Ia
• ϑ − Phase angle between Vbc and Ic

Buttons and Fields

Line Group Select the line group used for the calculations. 
When working with TR100, TR1600 or 
COMTRADE records there are no line groups 
defined for the record.

Voltage/Current Select the voltage and current phase groups for use 
in the power calculations or click Phase Groups to 
define new ones.

Displays Shows the calculated apparent, real and imaginary 
power figures for each phase with the power factor. 
This uses the amplitude and phase of each of the 
vectors computed from the selected voltage and 
current channels so only the fundamental 
components are used to compute power.

The phase angle, power factor and X/R ratio (the 
ratio between the reactance and the resistance of 
the load) also appear.
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Each power component is displayed in RMS form.

CT Lag Select the lag. Where interposing CTs are used to 
measure current a correction can be made for the 
CT phase lag. Enter the value use the spinners. The 
lag angle is in degrees and fractions of a degree.

For a TR2000 record the type of VT is known but 
for other recorders the type must be declared 
before the power and impedance calculations are 
made. For a TR2000 the CT correction defined in 
the recorder is used as the default.

Power
Calculations

Operations

To use power calculations:

1. Ensure cursors are active. All PAT calculations are carried out on the 
samples between the cursors. If the cursors are not active, no values 
appear.

2. Select PAT > Power or click  and the dialog appears 
(Figure 3.39).

Figure 3.41  Power Calculations

3. Select a Line Group, if required.

4. Select Voltage and Current phase groups when working with TR100, 
TR1600 or COMTRADE records.

5. Select a Phase.

6. Select or enter a CT Lag, if required.

7. Click Phase Groups and the dialog appears (Figure 3.42).
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Figure 3.42  Phase group channels

8. Configure the Phase group channels by:

a. Clicking Phase group and the dialog appears (Figure 3.43).

Figure 3.43  Phase group channel

b. Enter a Label.
c. Select Definitions for all phases.
d. Click OK.

The Phase group channels dialog reappears.

e. Click Close and the Power Calculations dialog reappears.

9. Click OK.
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Sequence Components
Use this window (Figure 3.44) to configure parameters for and view 
sequence component calculation results for specific channels. 
Additionally, you can configure aspects of the Phase Groups.

If the Print Preview is active for an active graph, it is hidden until the 
preview is closed.

Figure 3.44  Sequence Components

Sequence components are calculated for a phase group of three 
channels. For each sample in these three channels a phasor of the 
fundamental harmonic is calculated using the method described in 
”Single Channel Quantities” on page 3-73.

For each sample vector arithmetic is used to generate the sequence 
components:

where:

IR0 Zero sequence component

IR1 Positive sequence component

IR2 Negative sequence component

IR Red phase vector

IY Yellow phase vector

IB Blue phase vector
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a Unit vector 

Buttons and Fields

Group Select the phase group used for the sequence 
component calculations or click Phase Groups to 
define new ones.

Displays Displays the amplitude and phase angle of the 
fundamental component of each channel is 
calculated and the positive, zero and negative 
sequence components computed using vector 
addition with positive, zero and negative 120° 
phase rotation. The phase angles are relative to that 
of the first channel in the phase group.

Phasors Opens the vector phase display, which shows the 
relative phases of the three channels in the phase 
group. The absolute angle is that relative to the 
position of the left hand cursor. This display is 
particularly useful when the display cursors are 
moved from pre-fault into post-fault where the 
relative phase angles may vary. 

Use the check boxes at the bottom left to draw 
circles for the locus of each vector. Use this to 
check relative amplitudes and the identity of each 
vector.

Sequence
Components
Calculations

Operations

To use sequence components calculations:

1. Ensure cursors are active. All PAT calculations are carried out on the 
samples between the cursors. If the cursors are not active, no values 
appear.
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2. Select PAT > Sequence Components or click  and the dialog 
appears (Figure 3.45).

Figure 3.45  Sequence Components

3. Select a Group and the display fields are populated.

4. Click Phase Groups and the dialog appears (Figure 3.42).

Figure 3.46  Phase group channels

5. Configure the Phase group channels by:

a. Clicking Phase group and the dialog appears (Figure 3.47).

Figure 3.47  Phase group channel

b. Enter a Label.
c. Select Definitions for all phases.
d. Click OK.

The Phase group channels dialog reappears.

e. Click Close and the Sequence Components dialog reappears.
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6. Configure the Phasors by:

a. Clicking Phasor and the dialog appears (Figure 3.48).

Figure 3.48  Phasor Diagram

b. Manipulate the diagram using the three check boxes.
c. Click OK.

The Sequence Components dialog reappears.

7. Click OK.

Harmonics
Use this window (Figure 3.49) to configure parameters for and view 
harmonic results for specific channels.

Figure 3.49  Harmonics Analysis

If the Print Preview is active for an active graph, it is hidden until the 
preview is closed.
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Buttons and Fields

Channel Select the channel and this measurement uses a 
discrete Fourier transform (DFT) technique to 
compute the amplitude and phase angle of each 
harmonic of the fundamental including the zeroth 
(DC component). The accuracy of the results 
suffers with low level input signals.

Histogram Scale Contains a logarithmic vertical scale to make small 
levels of harmonics visible.

Harmonics Spinner Varies the actual number of harmonics. 

To ensure an accurate measurement there should 
be at least four samples per cycle of the harmonic 
waveform. PAT limits the maximum harmonic to 
one quarter of the sampling rate; i.e. for a sampling 
rate of 9600 on a 50Hz signal the maximum 
harmonic is the 48th.

THD% Displays the ratio of the power in the harmonics 
from the second upwards relative to the 
fundamental. THD figures for the odd and even 
harmonics only appear. There are two different 
standards for computing THD, which are selected 
in ”Preferences” on page 3-43.

THD values are calculated using as many 
harmonic values as are available. Initially, the 
dialog displays calculations based on values up to 
the 11th harmonic. If this limit is increased, then 
the THD calculations can be refined with the new 
values. If the number of harmonics is subsequently 
reduced, the THD values are not restored to their 
former values. Instead the more accurate results, 
incorporating the greater number of harmonics, are 
retained.

Table Opens the Table dialog with more accurate tabular 
results. This gives a list of the amplitudes and phase 
angles of the harmonics over 0.1% of the 
fundamental. The amplitudes are peak magnitude 
values and the angles are relative to the 
fundamental angle.
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odd %/even % Display data when the active record contains 
disturbance data. Higher harmonic values cannot 
be obtained and so the main histogram display is 
removed. The odd and even harmonic distortion 
values are similarly unavailable. However, a total 
harmonic distortion value still appears. See 
”Preferences” on page 3-43 for details of how it is 
derived.

Harmonics
Operations

To use harmonics calculations:

1. Ensure cursors are active. All PAT calculations are carried out on the 
samples between the cursors. If the cursors are not active, no values 
appear.

2. Select PAT > Harmonics or click  and the dialog appears 
(Figure 3.50).

Figure 3.50  Harmonics Analysis

3. Select a Channel and the display fields are populated.

4. Use the spinners to select a number of harmonics.

5. Click Table, if required, and the dialog appears (Figure 3.51).
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Figure 3.51  Harmonics Table

6. Click OK and the Harmonics Analysis window reappears.

7. Click OK.

Channels Menu
This menu consists of:

• ”Combined Channels” on page 3-68
• ”Single Channel Quantities” on page 3-73
• ”Average” on page 3-75
• ”Sequence Components” on page 3-77
• ”Star/Delta Conversion” on page 3-80
• ”Line Group Quantities” on page 3-85
• ”Phase Group Angles” on page 3-89
• ”Differential Phase Angle” on page 3-91
• ”New Phase Group” on page 3-93
• ”Import Channels” on page 3-95
• ”Synchronize Imports” on page 3-97
• ”Long Term Flicker (Plt)” on page 3-100
3-66 1086-339  Rev. A   11/05



Fault Recorder Operations Manual
Computed 
Channels

The Power Analysis Toolkit (PAT) functions allow for a wide range of 
measurements on the voltage and current signals. There are also 
functions that allow the generation of computed quantities over the 
entire length of a transient or disturbance record. These appear as extra 
channels that are displayed, measured and printed just like the input 
voltage and current channels. These new channels are then used in turn 
to compute further complex channels.

The computed channels are divided into six different groups:

• Combined channels – Simple arithmetic sum and difference 
functions

• Single channel quantities – RMS, frequency & harmonic content 
of one channel

• Sequence components – Positive, negative and zero sequence of 
a phase group

• Star/Delta conversion – Compute the equivalent voltage signals
• Line group quantities – Watts, VARs, VA, ... 
• Phase group angles – Voltage & current phase angles

Once a new channel has been created it can be added to the current 
view using Graph > Setup. The channel can then be selected and added 
to the display in the normal way.

When a new channel is created it is assigned a full-scale deflection value 
for the purposes of vertical scaling. This value is limited by the full-scale 
deflections of the input channels so that the result is not artificially scaled 
beyond the margin of error inherent in the source signals. Thus, in most 
cases, the computed channel's full-scale deflection will only differ from 
that of the source channels when it contains a value that lies outside the 
source's full-scale.

A line group is a pair of phase groups, one voltage and one current, 
defined in the record.

Add to graph Each computed channel window has this check box. If it is:

• Unchecked DSA32 displays an informational alert when the new 
channel is created. It is necessary to select Graph > Setup to 
incorporate the new channel into an existing graph. Alternatively, 
select Graph > New Graph to create a new graph including the 
computed channel.

• Checked, then the newly generated channel is immediately 
added to the active graph without any need to use Setup. No alert 
appears.
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This check box setting is sticky. It retains its setting between uses of any 
of the computed channel dialogs. If it is set in the Combined Channel 
window, then the next time that dialog is used the check box is in the 
same condition as it was left previously. The setting is universal across all 
the computed channel dialogs. If it is in the Combined Channel window 
it is the same in Single Channels Quantities. In addition, when DSA32 is 
shut down the current Add to graph setting is recorded for use when it is 
restarted.

Combined Channels
Use this window (Figure 3.52) to combine channels. A combined 
channel is produced from a simple arithmetic function of one, two or 
three channels. The three functions are sum, difference and inverse. The 
summation of three phase voltages or currents is used to compute a 
neutral channel. The inverse is used to correct an inverted CT. In this 
case, a new phase group can be created to include the new channel. 
Sum and difference calculations are used to compute the missing phase if 
only two phase and neutral channels are available.

Figure 3.52  Combined Channels - Standard Tab
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Buttons and Fields

Action Click on Sum, Difference or Inverse.

For disturbance channels, in which each sample 
consists of both an RMS value and a fundamental 
phasor, Sum adds the corresponding RMS values as 
normal and also performs a vector addition on the 
phasor quantities. Similarly, Difference performs 
simultaneous arithmetic and vector calculations. 
When inverting a disturbance channel the RMS 
value is left unaltered since RMS is an inherently 
positive quantity, however the phasor is inverted 
by means of a 180° rotation. When performing a 
difference on disturbance channels the possibility 
of negative RMS results is unavoidable - in such 
cases DSA32 automatically extends the display 
range of the resultant channel to reflect its bipolar 
character.

Sum Identify either two or three channels.

Difference Identify two channels. For the difference of two 
channels, the first signal is subtracted from the 
second. For a transient record this would have the 
same result as inverting the first channel then 
adding it to the second.

Inverse Identify one channel is required.

Channel Select a channel from the drop down.

Label Select the channels for the operation and DSA32 
dynamically produces a default label for the new 
channel. Enter a new label, if desired. The label 
should be descriptive of its contents; i.e. I neutral 
or -Ir. Use up to 25 characters but it is best to keep 
the label short for display reasons. The default 
labels are commonly long and abbreviation is often 
recommended.

Add to graph Check this box to add the new channel 
immediately. For more information see ”Add to 
graph” on page 3-67.
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Advanced Tab

Figure 3.53 shows the Advanced tab.

Figure 3.53  Combined Channels - Advanced Tab

Formula Enter an arbitrary formula describing the required 
output. Since any text can be entered, take care to 
enter a meaningful expression before it is accepted 
for processing. Essentially, any mathematical 
expression involving the four basic arithmetic 
operators is usable along with parentheses to 
control the order of evaluation.

Valid formulae consist of the following elements:

• Channels - channels from the active record are 
referenced by entering their labels enclosed 
within quotes, e.g. "Vry".

• Constants - integer or floating point values are 
entered in the normal way, e.g. 5.2

• Arithmetic operators - Either + (addition), - 
(subtraction), / (division) or * (multiplication).

• Parentheses - portions of the formula that 
constitute a valid expression in their own right 
can be enclosed in parentheses to ensure that 
they are evaluated first.

Examples are:

• "Vry"+"Vyb"+"Vbr"
• "Vry"+4.9
• ("Vry"*2)+"Vrb"
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Operator Precedence

In the absence of parentheses the operators are 
evaluated with standard rules of precedence. 
Multiplications and divisions are evaluated first 
followed by additions and subtractions. Within 
these constraints operators are evaluated left to 
right as they are encountered.

Nesting When using parentheses expressions can be 
nested, e.g. (("Vry"*2)+"Vrb")/2. There is no limit on 
the level of nesting.

Division by zero Formulae involving division run the risk of 
encountering data that gives rise to a division by 
zero. Such calculations are trapped and the result 
for those points is set to zero. An error message 
occurs if divisions by zero occur during a given 
calculation.

Divisions by zero are encountered less often than 
might be expected. For example, division by a 
sinusoidal quantity typically does not trigger a 
division by zero every time the signal crosses the y 
axis. This is due to the fact that the channel data is 
made up of discrete values sampled at regular 
intervals. In many cases the nearest samples are 
found on either side of the zero crossing. Only 
where a sample has been taken exactly on the 
point of transition does a divide by zero arise.

Unit Enter a unit label. Because of the absolute 
flexibility allowed in generating new quantities 
there is no simple way for the application to 
determine what the appropriate units are for the 
new channel. By default Unknown appears. It is 
important to supply the correct unit if the new 
channel is to be utilized in further operations, such 
as inclusion in a phase group.
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Channels Select a Channel for use. When constructing a 
formula it is necessary to enter the exact name of 
one or more channels from the current record, a 
procedure that is tedious and error prone. To 
minimize this problem, the Channels drop down 
presents all the analog channels in the record - 
select one and its name, enclosed in quotation 
marks, is inserted at the current cursor position in 
the formula field.

Label Enter a descriptive label for the channel being 
created. Since any formula can be entered, 
transforming the input quantities in any number of 
ways, it is not possible to present a meaningful 
default label for these channels.

Add to graph Check this box to add the new channel 
immediately. For more information see ”Add to 
graph” on page 3-67.

Combined
Channels

Operations

To produce a combined channel:

1. Select Channels > Combined Channels and the Combined Channel 
dialog appears (Figure 3.54).

Figure 3.54  Combined Channels - Standard Tab

2. Configure the Standard tab by:

a. Selecting up to three channels using the drop downs.
b. Click an Action radio button.
c. Enter a Label.
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3. Configure the Advanced tab (Figure 3.55) by:

a. Selecting a channel from Channels.
b. Enter a Unit name.
c. Enter a Formula.

Figure 3.55  Combined Channels - Advanced Tab

4. Click Add to graph, as required.

5. Click OK.

A confirmation dialog may appear.

6. Click OK.

Single Channel Quantities
Use this window (Figure 3.56) to enable a number of functions based on 
a single channel input. These are:

• RMS
• Frequency
• Harmonic content

Figure 3.56  Single Channel Quantities

The RMS is calculated using a one cycle sliding window and then uses 
five cycles of information for smoothing.
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Buttons and Fields

Select a source channel

Select the source channel for use.

Channel to produce

Frequency/RMS Click to select that channel type.

Harmonic Content Click the radio button and select the actual 
harmonic number using the spinners. A value of 
zero extracts the DC component and one is the 
fundamental component. The maximum harmonic 
number is limited to one quarter of the sample rate; 
i.e. for a sample rate of 9600 samples per second 
on a 50Hz signal the top harmonic is the 48th. 
Harmonic content cannot be produced from 
disturbance or logger channels.

The harmonic values are generated using a 
Discrete Fourier Transform. The DC component is 
the zeroth harmonic and the fundamental is the 
first. The formula is:

where:

• N = number of samples per cycle
• h = desired harmonic
• r = first sample number of cycle

Label DSA creates a label for the new channel as the 
criteria are specified. Enter a name to alter or 
replace the provided value. Make the label 
descriptive of its contents; i.e. Ir rms or Vr freq. 
Enter up to 25 characters but keep the label short 
for display purposes.

Add to graph Check this box to add the new channel 
immediately. For more information see ”Add to 
graph” on page 3-67.
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Single Channel
Quantities

Operations

To configure this:

1. Select Channels > Single Channel Quantities and the dialog appears 
(Figure 3.57).

Figure 3.57  Single Channel Quantitates

2. Select a channel from Select a source channel.

3. Click a Channel to Produce radio button:

• Frequency
• RMS
• Harmonic Content - use the spinner to set the number of 

harmonics.

4. Enter a Label.

5. Click Add to graph, as required.

6. Click OK.

A confirmation dialog may appear.

7. Click OK.

Average
Use this window (Figure 3.58) to produce an averaged channel. The 
channel is created using a moving window average of specified width 
across the length of the record. Values cannot be computed in two 
regions half the moving window's width at the start and end of the 
record. These portions are filled in with the nearest available calculated 
result.
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Figure 3.58  Average

Buttons and Fields

Channel Select an analog channel whose values are 
averaged to create the new channel.

Period Use the spinners to determine the width of the 
moving window for creating the average. It defaults 
to the period of the current record, for example, 
20ms for a 50Hz transient record. The range of 
permissible values extends from the shortest, 
which contains just three samples to the longest, 
which is half the record length. The period time 
must be an exact multiple of the duration of a 
single sample.

Use the spinners to alter the period in the smallest 
possible steps. Alternatively, enter a period directly, 
but as the focus leaves this field, it is changed 
where necessary to the nearest value that is an 
exact multiple of the sample duration.

Unit Use the drop down to enter the unit. A unit 
appropriate to the duration of the record is selected 
by default but can be changed. Units ranging from 
microseconds to minutes can be used to make the 
period values more manageable.

Label Enter a label for the new channel. A default label is 
provided based on the name of the input channel 
but this can be changed.

Add to graph Check this box to add the new channel 
immediately. For more information see ”Add to 
graph” on page 3-67.
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Average
Operations

To configure this:

1. Select Channels > Average and the dialog appears (Figure 3.59).

Figure 3.59  Average

2. Select a Channel.

3. Use the spinners to set the Period.

4. Use the drop down to set the unit.

5. Enter a Label.

6. Click Add to graph, as required.

7. Click OK.

A confirmation dialog may appear.

8. Click OK.

Sequence Components
Use this window (Figure 3.60) to produce a sequence component 
computed channel. The computations possible are to compute the 
positive, negative or zero sequence components of a selected phase 
group. The amplitude can be plotted in a number of units.

Figure 3.60  Sequence Components
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Buttons and Fields

Phase group Select a phase group whose values are used to 
compute the sequence components.

Component Click on Positive phase, Negative phase or Zero 
phase to select the required component.

Create Click a radio button to select a phase for the 
sequence component. The most common is the 
default value of Phase A.

Plot Click a radio button for the actual value that is 
plotted:

• Phasor magnitude - plots a DC quantity of the 
sequence component amplitude.

• Waveform - plots a rotating vector with the 
same phasor magnitude as the DC plot but with 
the correct absolute angle.

In Units Select the units for an amplitude measurement:

• Peak
• RMS
• Per Unit
• Percentage

Label DSA creates a label for the new channel as the 
criteria are specified. Enter a name to alter or 
replace the provided value. Make the label 
descriptive of its contents; i.e. 230kV Bus +seq or 
Line439 Zero Seq. Enter up to 25 characters but 
keep the label short for display purposes.

Add to graph Check this box to add the new channel 
immediately. For more information see ”Add to 
graph” on page 3-67.
3-78 1086-339  Rev. A   11/05



Fault Recorder Operations Manual
Sequence
Components

Operations

To configure this:

1. Select Channels > Sequence Components and the dialog appears 
(Figure 3.61).

Figure 3.61  Sequence Components

2. Select a Phase Group.

3. Click a Component radio button:

• Positive Phase
• Negative Phase
• Zero Phase

4. Click a Create radio button:

• A
• B
• C

5. Click a Plot radio button

• Phasor Magnitude
• Waveform

6. Select from In Units:

• Peak
• RMS
• Per Unit
• Percentage

7. Enter a Label.

8. Click Add to graph, as required.
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9. Click OK.

A confirmation dialog may appear.

10. Click OK.

Star/Delta Conversion
Use this window (Figure 3.62) to produce three computed channels by 
means of a star/delta conversion.

If the specified phase group is in the star form DSA32 defaults to 
performing a Star»Delta conversion which generates three channels 
plotting the fundamental phase-to-phase voltages. Conversely, if the 
group is in delta form, DSA32 defaults to a Delta»Star conversion, 
generating three channels plotting the fundamental phase-to-neutral 
voltages.

Figure 3.62  Star/Delta Conversion

For non-TR2000, TR100+ or PQR records, the phase group types are 
defined either the first time the record is loaded into DSA or the first time 
a calculation requires the phase group classifications. See ”Preferences” 
on page 3-43 for details.

Both conversions are applied to the fundamental phasors extracted from 
the source channels using the method described in Phasor extraction.

Star to delta

This is accomplished by simply subtracting one phase-neutral phasor 
from another to obtain the phase-to-phase value:

where,

IAB The A to B phase to phase vector

NANBAB III −=
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INA The neutral to A phasor

INB The neutral to B phasor

Delta to star

The three delta form phasors are used first to obtain an assumed neutral 
point by geometric means. In essence the triangle formed by the vectors 
is extended into a parallelogram and a point one third of the way along 
its diagonal is taken as the neutral (Figure 3.63).

Figure 3.63  Delta to Star Calculation Diagram - Balanced System

In an unbalanced system O and C may not be co-incident and so a more 
generalized method is required (Figure 3.64).

Figure 3.64  Delta to Star Calculation Diagram - Unbalanced System
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Vector math is then used to obtain NA, NB and NC. First the neutral point 
is obtained as follows:

Building on this result we derive a vector NA, the first of the three phases:

Similarly for NB:
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And finally for NC:

Buttons and Fields

Voltage phase group

Select the phase group for use as the source for the 
conversion.

Generated channel labels

DSA32 automatically creates channel labels for the 
three new channels. These can be long and can be 
edited if required.

Star >> Delta Delta >> Star

Click the radio button to set the type of translation. 
Since DSA knows what type the VT is it defaults to 
the appropriate translation. If the alternative is 
selected a message appears warning of the 
possibility of incorrect data being produced.

Create a phase group

Creates a new phase group from the new channels. 
This is the same operation available from the New 
Phase Group option and is provided here for 
convenience. Activate this and an x appears. Enter 
an appropriate name for the new phase group. 

Add to graph Check this box to add the new channel 
immediately. For more information see ”Add to 
graph” on page 3-67.
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Star/Delta
Conversion
Operations

To configure this:

1. Select Channels > Star/Delta Conversion and the dialog appears 
(Figure 3.65).

Figure 3.65  Star/Delta Conversion

2. Select a Voltage Phase Group.

NOTE Ensure that it is a voltage phase group.

The Label fields are populated.

3. Edit Label, if required.

4. Click either:

• Star >> Delta
• Delta >> Star

5. Click Create a phase group and enter a name in the field.

6. Click Add to graph, as required.

7. Click OK.

A confirmation dialog may appear.

8. Click OK.
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Line Group Quantities
Use this window (Figure 3.66) to produce computed channels to be 
created for power and impedance values.

Figure 3.66  Line Group Quantities

The fundamental phasors for the specified voltage and current channels 
are extracted using the method described in ”Single Channel Quantities” 
on page 3-73.

The phase angle is calculated as the raw angle difference between the 
two phasors plus the specified correction value for CT lag.

A number of other quantities are based on this result:

Power factor

Resistance

CTLagIV +∠−∠=ϑ

( )ϑcos=dPF

( )
I

V
R

ϑcos
=
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Reactance

X/R ratio

Buttons and Fields

Line group Select the line group for use in calculations.

When working with non-TR2000, TR100+ or PQR 
records there are no line groups defined for the 
record. Use the voltage and current phase groups 
for the power calculations.

Voltage phase group

Select the voltage phase group for use in 
calculations.

Current phase group

Select the current phase group for use in 
calculations.

Manual selection of the voltage and current phase 
groups is only necessary when working with 
non-TR2000, TR100+ or PQR records for which 
line groups are unavailable, or when working with 
user-defined phase groups.

Phase Click on the button for the phase for use in 
calculations. For delta wound VTs a delta»star 
conversion is performed before the parameter is 
calculated. Selecting Total generates values for the 
whole line group, only real, reactive and apparent 
power calculations are available when this option 
is taken. Total power for a phase-to-phase voltage 
group is calculated using the two-wattmeter 
method.

( )
I

V
X

ϑsin
=

( )ϑtan=Ratio
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Computed function

Click the radio button for the parameter to use for 
computing for the length of the record:

• Real power - select from Real, Reactive or 
Apparent in the drop down.

• Reactive power
• Apparent power
• Phase angle
• Power factor
• Resistance
• Reactance
• X/R ratio

All these quantities are based on the fundamental 
voltage and current of the selected phase.

Label DSA creates a label for the new channel as the 
criteria are specified. Enter a name to alter or 
replace the provided value. Make the label 
descriptive of its contents; i.e. A Watts or C pf. Use 
up to 25 characters but it is best to keep the label 
short for display purposes.

CT lag Include the CT phase error in the calculation. The 
correction can be up to +/- 10°. It is assumed that 
the phase error is the same for all three phases. 

For TR2000, TR100+ & P&QR records the CT 
correction defaults to the value defined in the 
recorder.

Add to graph Check this box to add the new channel 
immediately. For more information see ”Add to 
graph” on page 3-67.

Line Group
Quantities

Operations

To configure this:

1. Select Channels > Group Quantities and the dialog appears 
(Figure 3.67).
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Figure 3.67  Line Group Quantities

2. Select a Line Group, if required.

The fields are populated.

3. Select a Voltage Phase Group.

NOTE Ensure that it is a voltage phase group.

4. Select a Current Phase Group.

NOTE Ensure that it is a current phase group.

5. Click a radio button:

• A
• B
• C
• Total
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6. Click a computed function radio button:

• Real power - select from Real, Reactive or Apparent in the drop 
down.

• Reactive power
• Apparent power
• Phase angle
• Power factor
• Resistance
• Reactance
• X/R ratio

7. Enter a Label.

8. Enter a value for CT Lag or use the power bar.

9. Click Add to graph, as required.

10. Click OK.

A confirmation dialog may appear.

11. Click OK.

Phase Group Angles
Use this window (Figure 3.68) to produce computed channels plotting 
the angles between the individual voltage vectors or current vectors.

Figure 3.68  Phase Group Angles

The new channel contains three traces each plotting the angle of one of 
the phasors in the selected phase group. The angles are measured relative 
to one of the phasors - the reference phasor, as user-specified. As a 
consequence, the angle of the reference phasor always reads zero. The 
other two would, in an ideal system, mark out flat traces at 120° and 
-120°, respectively.
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When the channel is included in a graph with the cursors active, they 
display angle values for only one of the phasor traces - by default the top 
one. DSA32 can be set to display the angles of the other two phasors 
through the ”Band Settings” on page 3-7.

Buttons and Fields

Phase group Select the phase group for use as the source in the 
computed channel.

Reference Phasor Specify which member of the selected phase group 
is the reference phasor for the new channel.

Label DSA creates a label for the new channel as the 
criteria are specified. Enter a name to alter or 
replace the provided value. Make the label 
descriptive of its contents; i.e. Vangle or Iangle. 
Use up to 25 characters but it is best to keep the 
label short for display purposes.

Add to graph Check this box to add the new channel 
immediately. For more information see ”Add to 
graph” on page 3-67.

Phase Group
Angles

Operations

To configure this:

1. Select Channels > Phase Group Angles and the dialog appears 
(Figure 3.67).

Figure 3.69  Phase Group Angles

2. Select a Phase Group.

3. Select a Reference Phasor radio button:

• A
• B
• C

4. Enter a Label.

5. Click Add to graph, as required.
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6. Click OK.

A confirmation dialog may appear.

7. Click OK.

Differential Phase Angle
Use this window (Figure 3.70) to produce computed channels plotting 
the differential phase angles.

Figure 3.70  Differential Phase Angle

The angles are obtained for the two specified channels either in degrees 
or radians and the new channel populated with the simple difference 
between the two.

Buttons and Fields

Phase Group 1 Select the phase group for use in computations.

Compare Select the phase for use in comparison.

Using Select the type of comparison:

• Fundamental
• Positive phase
• Negative phase
• Zero phase

Degrees/Radians Select the mode of angle measurement.
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Label DSA creates a label for the new channel as the 
criteria are specified. Enter a name to alter or 
replace the provided value. Make the label 
descriptive of its contents. Use up to 25 characters 
but it is best to keep the label short for display 
purposes.

Add to graph Check this box to add the new channel 
immediately. For more information see ”Add to 
graph” on page 3-67.

Differential Phase
Angle Operations

To configure this:

1. Select Channels > Differential Phase Angle and the dialog appears 
(Figure 3.71).

Figure 3.71  Differential Phase Angle

2. Select a phase group for Phase Group 1.

3. Click a Compare radio button:

• A
• B
• C

4. Click a Using radio button:

• Fundamental
• Positive phase
• Negative phase
• Zero phase
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5. Repeat step 2, 3 and 4 for Phase Group 2, if required.

6. Click either Degrees or Radians.

7. Enter a Label.

8. Click Add to graph, as required.

9. Click OK.

A confirmation dialog may appear.

10. Click OK.

New Phase Group
Use this window (Figure 3.72) to add phase groups not specified in the 
original record.

Figure 3.72  New Phase Group

This is valuable where, for example, a CT has been inverted, as a new 
computed channel can be created that corrects the original. This new 
channel is then incorporated into a new phase group along with the 
unimpaired channels. Or, if a phase group has been created incorrectly, a 
new group is set up in DSA32. New groups created in this way are then 
used to correctly compute sequence component, power or impedance 
values.

NOTE New phase groups created in this way are only available while the 
record is open, they are not written back to the record file on disk. If 
you want to restore the user-defined phase group you must save the 
record layout before closing it. Save it as a record or machine-specific 
layout and it can be recalled.

To create the phase group, select the three channels that make it up. They 
must all have the same unit (kV or A) and must be in positive sequence 
order; i.e. R Y B or A B C.
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Buttons and Fields

Channel Select the channel for use in the new phase group.

Label Enter a name for the new group. Make this 
descriptive of its contents; i.e. Gen volts or I Tx2. 
Use up to 25 characters but it is best to keep the 
label short for display reasons.

Classification Select the type of phase group (V or I) and the type 
of VT (P-N or P-P).

Classification Click on the radio buttons to select the correct 
group type.

New Phase
Group Operations

To configure this:

1. Select Channels > New Phase Group and the dialog appears 
(Figure 3.73).

Figure 3.73  New Phase Group

2. Select the appropriate channel(s).

3. Enter a Label.

4. Click a Classification radio button:

• Voltage
• Current
• Phase to neutral
• Phase to phase

5. Click OK.
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Import Channels
Use this window (Figure 3.74) to import channels.

Figure 3.74  Import Channel

A number of records can be opened by DSA at the same time. These 
normally appear in a number of different graphs. In some circumstances 
it is desirable to compare signals from different records on the same 
graph. This is accomplished by importing the channels from one record 
into another. The imported channels are then available in exactly the 
same way as the native channels.

The imported channels are included in graphs by selecting Setup or New 
Graph from the Graph menu. The names of the imported channels are 
prefixed with *.

The best results are achieved by combining TR2000 records running at 
the same sample rate. If different sample rates were used, a warning 
appears about the potential phase error as samples from the imported 
channel are moved to match them to the nearest sample in the native 
channel. In such cases, it is better to import the lower rate channel into 
the record using the higher rate to minimize this alignment error. 
Attempts to import channels from non-TR2000 records face additional 
sources of error.

When an import operation is performed, DSA32 does not create a new 
channel. Both records are now reading data from the source record. As a 
consequence, if that source record is closed, the imported channel is no 
longer available and is removed from any open graphs.
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Synchronization When a channel is imported it is automatically synchronized with the 
native channels. This is done with respect to the time frame of the native 
record. So, if the source record started 0.002 seconds after the native 
record, then when its channels are imported no values appear for the first 
0.002 seconds of the graph (Figure 3.75). In addition, the last 0.002 
seconds of the imported channel are invisible as it runs past the end of 
the native record.

Figure 3.75  Native Time Frame Correction

If there is no period of overlap between the two records, i.e. one started 
recording only after the other had finished, then the imported channel 
appears as a flat trace always reading zero.

This synchronization is carried out on the basis of the timestamps written 
into the records involved. However, it is possible that the clocks in the 
recorders were incorrectly set when the record was created. In this case, 
use the Synchronize Imports (”Synchronize Imports” on page 3-97) 
dialog to calculate and apply the necessary correction.

Buttons and Fields

Records Lists the records including the Machine name, 
Location and time of the record creation.

Channels Lists the channel associated with a record.

Import Initiates the operation.
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Import Channels
Operations

To import a channel from another open record:

1. Select Channels > Import channels.

The Import Channel dialog appears (Figure 3.76).

Figure 3.76  Import Channel

2. Select the Machine name of the source record.

The channel names from this record appear in the lower scroll box.

3. Click on one or more channels for importing into the current record 
and click Import. 

Synchronize Imports
Use this window (Figure 3.77) to synchronize imports.

Figure 3.77  Synchronize Imports
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When new imported channels have been added to a record they are 
automatically synchronized with the native channels based on the 
difference between the times stored in the two records (see ”Import 
Channels” on page 3-95). If these times are not correct, this dialog is 
used to adjust the relative time to correct for any difference in the 
absolute times.

The alignment is performed on the basis of a correction applied to the 
imported channel. This correction is the amount subtracted from the 
imported channel's times (Figure 3.78). For example, the application of a 
0.01 second correction causes a sample that would normally appear 
0.02 seconds into the record to appear at the 0.01 second point. A 
negative correction advances the imported signal, so that the point which 
would otherwise appear 0.02 seconds into the record now occurs at 0.03 
seconds.

Figure 3.78  Synchronize Correction

DSA32 provides the means to determine the required correction 
automatically by comparing the imported channel to a native one.

Buttons and Fields

Native Channel Lists the channels available.

Imported Channel Lists the channels available for import.

Set from display Produces a correction in seconds that, if applied to 
the imported channel, exactly synchronizes the 
selected points.

Set from trigger Produces a correction in seconds that, if applied to 
the imported channel, synchronizes the trigger 
times in the two records.

Time Enter a time to use as a correction.

Apply Applies the correction time.
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Synchronize
Import

Operations

Synchronizing Non-Transient Records

To determine the correction and synchronize non-transient records:

1. Select Channels > Synchronize Imports.

The Synchronize Imports dialog appears (Figure 3.79).

Figure 3.79  Synchronize Imports

2. Select a Native Channel from the upper drop down list that is 
common to the imported channel selected below it.

Both the imported channel and its common native channel appear in 
the window.

3. Click on the Native Channel and Imported Channel displays and 
DSA32 seeks out the nearest digital transition or zero crossing (rarely 
available). These points are marked out with a white line in each 
display.

4. Select digital transitions, manually enter a time adjustment, or select 
zero-crossings, if available, on both signals that represent the same 
moment in time.

5. Click Set from display.

6. Enter a time.

7. Click Apply to offset the imported channel.
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Synchronizing Transient Records

With transient records in particular, a relatively small error in record 
times can lead to the situation where there is no period of overlap at all 
between the records. Consequently, the imported channel is not visible 
and it is not possible to use the procedure outlined above to determine 
the required correction. 

In such cases:

1. Select Channels > Synchronize Imports.

The Synchronize Imports dialog appears (Figure 3.79).

2. Select a Native Channel from the upper drop down list that is 
common to the imported channel you select below it.

Both the imported channel and its common native channel appear in 
the dialog. If the records do not overlap, a flat trace appears. The next 
steps synchronize the trigger time so the trace appears.

3. Click on the displays and DSA32 seeks out the nearest zero crossing 
or digital transition. These points are marked out with a white line in 
each display after manually selecting the point for TBD.

4. Select zero-crossings or digital transitions on both signals that 
represent the same moment in time.

5. Enter a time, if desired or use the set from trigger display selections.

6. Click Set from trigger.

Sometimes this is sufficient to effect full synchronization but even if it 
is not, it is guaranteed to leave the imported channel visible so that 
the conventional means of synchronization, via a common digital 
transition for example, are available.

7. Click Apply to offset the imported channel.

Long Term Flicker (Plt)
This calculation is only valid for data from a flicker logger.

Buttons and Fields

Pst Channel Used as basis for the production of the long term 
flicker data.

Label Populated with a default label based on the Pst 
Channel selected which can be altered, as 
required.
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Window Width Used as the time period over which the long term 
flicker calculation is performed. The value 
represents the number of 10 minute Pst values to 
use. The default value of 12 dictates that the long 
term flicker is calculated over a period of 2 hours.

Add to graph Check this box to add the new channel 
immediately. For more information see ”Add to 
graph” on page 3-67.

Long Term Flicker
Operations

To produce a long term flicker (Plt) calculated channel from a Pst 
channel:

1. Select Channels > Long Term Flicker.

The Long Term Flicker (Plt) dialog appears (Figure 3.80).

Figure 3.80  Long Term Flicker (Plt)

2. Select the PST Channel, enter a Label and select a Window width for 
the new channel.

3. Click OK.

4. Click Add to graph, as required.

5. Click OK.

A confirmation dialog may appear.

6. Click OK.

NOTE See Appendix A ”Expert System” for details on operation of DTF and 
ES32.

Tools Menu
There is an option within DSA32 where extra analysis modules can be 
added. At present there are two options available. These are:

• Distance to fault calculation (transient records)
• Expert System fault classifier (transient & disturbance records) 
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NOTE If neither of the optional modules has been installed, the Tools menu 
does not appear.

Options Menu
This menu consists of:

• ”Show Analog Labels”
• ”Show Digital Labels”
• ”Show Phasors”
• ”Show Annotations”
• ”Time Axis”
• ”Cursors” on page 3-104
• ”Add Annotation” on page 3-105

Show Analog Labels
Switches on/off analog channel labels to maximize the amount of screen 
for the waveforms.

To do this:

• Select Options > Show Analog Labels.

If the names are not shown the channel numbers from the record 
appear.

Show Digital Labels
Switches on/off digital channel labels to maximize the amount of screen 
for the waveforms.

To do this:

• Select Options > Show Digital Labels.

If the names are not shown the channel numbers from the record 
appear.

Show Phasors
Toggles on/off the phasors on/off on the screen.

To do this:

• Select Options > Show Phasors.
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Show Annotations
Toggles on/off the annotations on/off on the screen.

To do this:

• Select Options > Show Annotations.

Time Axis

Zoom When a graph is first displayed the whole record appears. To expand a 
section in the active graph either:

• Select Options > Time axis > Zoom or click .

The mouse pointer changes to a magnifying glass symbol. While it 
appears in this form its movements are restricted to the signal area of 
the active graph making it easy to select the start or end of the 
display.

To select the display start and end:

1. Move the center of the icon to the start of the region of interest and 
press and hold the left mouse button.

2. Drag the mouse to the end of the region and release the button.

The area selected is highlighted and the selected section expands to 
fill the screen width when the mouse button is released. Alternatively, 
if you have a mouse wheel you can use it to zoom (”Mouse Wheel 
Support” on page 3-12).

3. Repeat this several times. If there are only a few data points in the 
area for expansion a Zoom too strong error message appears. If one 
or more of the PAT dialogs is active and less than a cycle of data is 
visible after the zoom, DSA32 issue a warning since PAT's 
calculations assume that an integral number of cycles are enclosed 
by the cursors.

Unzoom To return the display to the original size:

• Select Options > Time axis > Unzoom or click .

NOTE Even if several distinct zoom operations were performed, a single 
Unzoom will undo them all. The mouse wheel can also be used to 
unzoom the display.
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Cursors
The cursors appear as two vertical lines drawn over the signals in the 
graph. Beside and below each analog channel name or number the 
instantaneous values at the cursor positions appear followed by the 
difference and units. For logger channels the cursor value is for the 
maximum, average or minimum waveform. The default is the average.

The default setting shows the instantaneous values at the cursor points. 
Alternatively, the RMS value of the cycle following the cursor position 
can be displayed (”Right Click Menu” on page 3-14). The display 
changes and RMS appears on the display.

For logger records the maximum and minimum values of the visible data 
appear to the right of the graph. This is the maximum value of the 
maximum channel and the minimum of the minimum channel and are 
the values used if the auto scaling option is chosen. Changing the scale of 
the channel does not alter these values.

For the digital channels, the status at each cursor is shown as a thin green 
line for the normal state or a thick red line for the alarm state.

The times relative to the trigger point appear above the graph (T1 & T2) 
with the differential time (TD) and the time units.

If the waveforms have been greatly magnified the cursors are seen to 
jump from data point to data point.

If one or more of the PAT dialogs is active, the cursor positions are 
adjusted after every movement to ensure that an integral number of 
cycles are enclosed between them. If the graph is zoomed to display less 
than a cycle's worth, a warning appears and the cursors are fixed at the 
left and right edges of the display.

The cursors must be active for the phasor display to be made available.

Cursor
Operations

To toggle the dual cursors in the active graph cursors on/off:

• Select Options > Cursors or click .

To move the left cursor:

• Click and hold the left mouse button and drag it to the new 
position.

To move the right cursor:

• Click and hold the right mouse button and drag it to the new 
position.
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For fine control of both cursors:

• Use the left and right arrow keys to move the cursors 
simultaneously.

For independent cursor control:

• Use <Ctrl>+arrow keys to move the left cursor and <Shift>+arrow 
keys to move the right cursor.

Add Annotation
DSA provides the capability for text notes that are associated with a 
particular point in a specified channel for any supported record type 
(Figure 3.81). Such annotations are drawn directly on the graph display 
in a box with a line indicating the point with which it is associated. They 
are also included in printed graphs.

Figure 3.81  Annotation Example

Once created, annotations are stored alongside the record and appear 
when the record opens. Annotations are associated with the actual data 
in the channel and not just with a particular graph window. Thus, if an 
annotation is created on a channel that appears in more than one graph 
window the annotation appears on all the graphs where that channel is 
found.

Annotations are drawn in one of two ways: opaque or transparent: 

• Transparent annotations are drawn so that the graph details 
underneath the text are still visible.

• Opaque annotations erase the portion of the screen immediately 
under the text so that it is more easily read. The mode in use is set 
application wide in the ”Preferences” on page 3-43.
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Positioning By default, annotations on the left hand side of a graph are drawn to the 
right of the sample they are associated with. If this point is moved to the 
right hand side of the graph, the annotation is drawn on the left. This is 
done so that the text is visible on screen at all times while the annotated 
sample is displayed.

If the automatically assigned position is inconvenient, overlaps other 
annotations or obscures signal detail, than reposition it. Once an 
annotation has been manually positioned in this way it maintains the 
same horizontal and vertical offset from the annotated sample.

Details of manual positioning are not stored along with the record data 
but they can be saved in per-record layouts.

An annotation can be manually positioned and it maintains the same 
horizontal and vertical offset from the annotated sample. As a 
consequence it is possible to horizontally scroll a zoomed graph so that 
the annotation is off-screen while the sample it is associated with is still 
visible.

Modifying 
Annotations: 
Right-Click Menu

Modify annotations by double-clicking on the text and the Annotation 
dialog appears.

It is also possible to display an annotation context menu by right clicking 
on the text of the annotation. The options on this menu are:

Edit Opens the Annotation dialog.

Move Returns to the sample selection mode used when 
creating the annotation. A new sample can be 
chosen to with which associate the annotation. As 
well as moving the annotation to another sample in 
its channel, the annotation can also be placed on 
an entirely different channel.

Delete Removes the annotation.

Add new Opens the Annotation dialog.

Auto-position Appears when the annotation has been manually 
positioned. Selecting this returns the position of the 
annotation to the application-controlled 
positioning method.
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Annotations
Operations

To add an annotation on the active graph:

1. Click either:

• Select Options > Add Annotation.
• Click .
• Select Add Annotation from the right-click menu displayed by 

right-clicking on an existing annotation.

The cursor is confined to the data area of the active graph and, as the 
mouse is moved, the current point in the channel is highlighted with 
its value at that point displayed alongside. For a multi-channel band 
or logger record the annotation attaches to the first or active channel.

2. Click on the left mouse button to select the currently highlighted 
point as the location for the new annotation.

The Annotation dialog appears (Figure 3.82).

Figure 3.82  Annotation

3. Enter the annotation text of the annotation.

4. Click OK to save the annotation.

Suppress Annotations

To suppress the display of annotations:

• Select Options > Show Annotations. This only affects the current 
display and does not delete the annotations.

Repositioning and annotation

To reposition:

• Click on the text and drag the mouse cursor and reposition the 
annotation. 
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Windows Menu
This menu consists of:

• ”Cascade Windows”
• ”Tile Horizontally” on page 3-108
• ”Tile Vertically” on page 3-108
• ”Arrange Icons” on page 3-108
• ”Save Layout” on page 3-109
• ”Delete Layout” on page 3-113
• ”Close” on page 3-22
• ”Close All” on page 3-114
• ”Close All but Current” on page 3-114

Cascade Windows
To cascade windows:

• Select Windows > Cascade and all the graph windows overlap so 
that each title bar is visible.

Tile Horizontally
To tile windows vertically:

• Select Windows > Tile Horizontally to arrange the open graphs in 
smaller sizes to fit next to each other in the main DSA32 window. 

The windows are arranged with each window taking as much of the 
horizontal screen-space as is possible.

Tile Vertically
To tile windows vertically:

• Select Windows > Tile Horizontally to arrange the open graphs in 
smaller sizes to fit next to each other in the main DSA32 window. 

The windows are arranged with each window taking as much of the 
vertical screen-space as is possible.

Arrange Icons
To arrange icons:

• Select Windows > Arrange Icons to arrange a number of 
minimized graph windows evenly along the bottom of the main 
DSA32 window.
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Save Layout
Use this window (Figure 3.83) to save the layout.

Figure 3.83  Save Layout

The layout of a record comprises the visual appearance and 
configuration of all graph windows open on that record. For each graph 
the following details are included:

• Window size and position
• Graph title
• Current zoom applied to the graph
• Cursor status (on or off) and, if they are on, the cursor positions
• Phasor display status (on or off)
• Phasor display configuration
• Phasor display title
• Phasor display cursor association (left or right)
• Included phase groups
• Phase group display properties (fundamental, positive phase 

sequence etc.)
• Phasor display annotation
• The bands defined in the graph
• Band label
• Band gain
• Band's active channel
• Computed channels
• User-defined phase groups
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Since the layout details apply only to a single record the importing of 
channels is not recorded and such imports is not restored when a saved 
layout is used.

Saving these details means that having set up a useful display of a record, 
including perhaps the creation of several computed channels, it is 
possible to save that display and restore it later to continue analysis. In 
addition, it is possible to associate a saved layout with a particular 
recorder that can then be used with any record retrieved from that 
machine.

If a layout is saved for any record from a selected recorder the channel 
scaling reverts to the default autoscale option. This is to ensure that 
waveforms are not cropped for different fault types; i.e. high levels of 
fault current.

Buttons and Fields

Machine name Displays the Machine name for informational 
purposes.

Location Displays the location of the recorder that produced 
the record.

For use with Under that two sets of radio buttons control how 
the layout is saved.

For use with Click an option:

This record - associates the layout exclusively with 
the current record. It is only available when 
working with this record.

All records from this machine - associates the 
layout with the recorder so that it is made available 
with any record generated by the same machine.

Any machine - associates the layout with any 
record from any machine. If the number of 
channels in the record is larger than the layout, 
undefined channels are given default settings.
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Identification Click an option:

• Default - Gives the layout the name Default. 
Save subsequent layouts by selecting a Named 
layout and entering a unique name for the 
layout. If a layout with the same name already 
exists it is replaced. No warning is given if a 
layout is overwritten.

• Named - Enable saving more than one layout 
against a record or a machine. They are 
distinguished by an identifying name.

Save Layout
Operations

To save the layout of the active record:

1. Select Windows > Save Layout.

Figure 3.84  Save Layout

2. Click a For use with radio button:

• This record
• All records from this machine
• Any machine

3. Click a Identification radio button:

• Default
• Normal - enter a name in the field.
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4. Click Save to confirm the save operation.

If the Always save option is selected in Preferences then the Save 
Layout dialog appears as each record is closed in DSA32. When 
DSA32 itself is shut down, the dialog also appears once for each 
record open at that time.

NOTE A layout includes any tiles from the record or machine that may not 
have been visible when the layout is saved.

Restoring a layout Once a layout has been saved DSA32 offers to restore it whenever a 
suitable record is opened (Figure 3.85). How this is done depends on the 
choices made in ”Preferences” on page 3-43.

Figure 3.85  Restore Layout

The normal behavior is as follows: 

• DSA32 checks the record being opened to see if there are any 
per-record or per-machine layouts available for it.

• If there are then the Restore Layout appears with the details of all 
available layouts.

• A radio button provides a choice between Record specific or 
Machine specific layouts - these choices answer to the For use 
with selection made when the layout was saved. For each choice 
a drop down list of the layouts is available. If a default layout is 
available it appears first followed by any named layouts.

Restore Layout
Operations

The Restore Layout dialog appears (Figure 3.85).

Click a radio button and select a suitable layout from the associated drop 
down.
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Click either:

• Restore to recreate the graph windows.

or

• Don't Restore or hit <Escape> to bypass the layouts and simply 
produce graphs following the standard configuration.

Delete Layout
This dialog (Figure 3.86) deletes a saved layout.

Figure 3.86  Delete Layout

Standard layout If DSA32 is allowed to set up the window with its standard layout it 
creates one band for each channel. Up to eight analog channels and 
sixteen digitals are added to each graph window. Digitals and analogs 
are always interleaved by displaying up to two digitals between each pair 
of analog bands. If there are more channels in the record than fit in this 
default allocation DSA32 continues to create new windows until all 
channels appear.

As each band is created an optimal scale is applied to it. This is 
determined by finding the maximum scaling factor that keeps the whole 
signal visible. Members of each of the various phase groups are 
initialized with the same scale.

New windows can be created and the layout of existing windows can be 
altered using the Graph Setup dialog. Each band also has a number of 
display options that are configured through the ”Band Settings” 
on page 3-7.

Buttons and Fields

Lists Contains three lists, one for each type of record 
layout: per-record, per-machine and global. Each is 
filled in with the existing layouts of each type.
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All Selects all of the entries in the associated list.

None Deselects all items in the associated list.

Delete Layout
Operations

To delete a previously saved layout:

1. Select Windows > Delete Layout.

The Delete Layout dialog appears (Figure 3.87).

Figure 3.87  Delete Layout

2. Select one or more layouts from any of the lists and click Delete to 
erase the stored details.

Close All
This closes all open records.

To perform this operation:

• Select Window > Close All.

Close All but Current
This closes all the open records simultaneously except the active record.

To perform this operation:

• Select Window > Close All but Current. 

Help Menu
The Help menu consists of:

• ”Help Topics”
• ”About DSA32”
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Help Topics
The information in the application Help is mostly duplicated in this 
manual.

To open help:

• Select Help > Help Topics and the main contents page for the 
DSA32 help system appears.

About DSA32
This dialog (Figure 3.88) contains copyright and licensing information for 
the product together with its version number. Under the Components 
heading it lists details of a number of system components utilized by 
DSA32. When seeking support you may be asked to provide some of the 
information found here.

To display this dialog:

• Select Help > About Display Station Analysis and the dialog 
appears (Figure 3.88).

Figure 3.88  About Display Station Analysis
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System Information
Table 3.1 list the system capabilities.

NOTE These are theoretical limits. The physical capabilities of the machine or 
of Windows may prevent some of them from being approached in actual 
use.

Table 3.3  System Capabilities

Item Capability

Maximum record size 2 Gbyte

Maximum number of samples per record 2,147,483,648

Maximum number of channels per record 2,147,483,648

Maximum number of records open 
simultaneously

30

Maximum number of windows open 
simultaneously

Unlimited

Maximum number of channel colors in a 
COL file

~1500

Maximum number of installed Tools 9

Minimum point size for scaling text 2.5
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Expert System Overview

This appendix explains the operations of the Expert System and the DS32 
subcomponents that rely on it for operation:

• Distance to Fault,
• Breaker Performance Monitor, and
• Voltage Dips Analysis.

Figure A.1 shows how the Expert System relates to the optional DSA 32 
components.

Figure A.1  Expert System Reliant Components

Expert System

Distance to Fault Breaker Performance 
Monitor

Voltage Dips 
Analysis

DSA 32
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Expert System Introduction
This application is an Expert System fault classifier, opened from the 
Display Station Analysis Tools menu, or set up to run automatically using 
the appropriate Display Station options in Autopoll mode.

Figure A.2 shows the Expert System main window.

Figure A.2  Expert System Main Window

Its purpose is to take the fault record being analyzed in Display Station 
and presenting fault record information, such as the type of fault, and 
whether the switchgear has operated within the correct times. It also has 
a graphing function for viewing the fault currents and voltages in RMS 
form.

Expert System Operation - Background
Run the Expert System from the DSA Tools menu and the Expert System 
uses the location information stored in the current record file to locate a 
Substation Configuration file. This file contains data about how the 
recorder is connected to the substation, how many out going feeders it 
has and information about the protection relays and switchgear. There 
are also values that are used to fine tune the system. This file is currently 
optimized for distribution substations.
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When the fault classifier loads, it attempts to locate the Substation 
Configuration File. If this file is not found, a message appears along with 
the Main Window. You must click Edit/Create to display the Substation 
Details window.

The Expert System then converts all the selected voltage and current 
channel data to RMS format. This information is displayed using the 
Graph Plots option and makes searching for variations much easier. All 
changes in voltage and current levels and digital transitions are measured 
and sent for record classification. 

The classifier looks for fault current on the phase and neutral current 
inputs and voltage dips on the phase voltage inputs. There are a number 
of basic classification categories:

• Single phase fault
• Multi-phase fault
• High impedance fault
• Voltage dip (upstream fault)
• Switchgear closure
• No detectable event

The classifier reports its findings with a list of the basic measurements. 
These include the fault current levels, voltage depression, relay and 
switchgear operating times.

If available and selected, information from the operation of local 
switchgear is exported to BPM, which determines when maintenance is 
due. This is based on three selectable schemes. See ”BPM Menus and 
Windows” on page A-61.

Voltage dip information is also exported to another Voltage Dips 
Analysis, which classifies dips by depression and duration. Over time this 
gives a picture of power quality delivered to customers. See ”Voltage 
Dips Windows and Menus” on page A-44.

When run in automatic mode under Autopoll, the classification 
information for each record is added to the record file for Display Station 
viewing. The classification data for all the records transferred under 
Autopoll is also appended to a text file called AUTOPOLL.OUT in the 
C:\DS directory. This file can be read by a standard text editor, such as 
Notepad or Write. To prevent the file from getting too large, delete or 
copy the data to another file after it is read.
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RMS Graphs Window
The RMS Graphs main window is made up of three parts:

• A menu and toolbar at the top,
• An icon bar to access operations (Table A.1), and
• A status bar at the bottom - displays minimum and maximum 

values for the graph type and for the active cursor, graph values 
for that point on the graph.

Table A.1  RMS Graphs Main Toolbar Icons

Icon Function

New RMS graph (”RMS Graphs Window” 
on page A-4)

RMS Graph setup (”Graph Plots” on page A-15)

Unzoom the active graph (”Unzoom” 
on page A-10)

Toggle Y-Axis origin (”Toggle Origin” on page A-10)

Toggle Y-axis as % (”Toggle % Nominal” 
on page A-10)

Copy the active graph to clipboard (”Edit Copy” 
on page A-10)

Save RMS Graph to File (”Save Graph” 
on page A-10)

Tile Window Horizontally (”Window Menu” 
on page A-10)

Tile Window Vertically (”Window Menu” 
on page A-10)

Cascade Windows (”Window Menu” on page A-10)
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The color of each line is representative of the phase. For example:

• RMS Phase A = Red
• RMS Phase B = Yellow
• RMS Phase C = Blue
• Neutral = Green

The X-axis shows the time in milliseconds for RMS waveforms. This time 
runs for the duration of the fault. Negative time is pre-fault time and 
positive time is post fault time.

The Y-axis represents either Current or Voltage for the RMS waveform. 
The scale is labeled beside the Y-axis. This is A for Amps, V for Volts, or 
kV for Kilovolts, etc. The default origin always represents zero current or 
voltage.

Print the active graph (”Print/Print Preview/Print 
Setup” on page A-10)

Print preview for the active graph (”Print/Print 
Preview/Print Setup” on page A-10)

Help Contents (”Help Menu” on page A-10)

Exit

Table A.1  RMS Graphs Main Toolbar Icons (Continued)

Icon Function
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RMS Graphs 
Right-Click Menu

The right click menu consists of items from the Graph menu. See ”RMS 
Graph Menus” on page A-6.

Figure A.3  RMS Graph Plot

RMS Graph Menus The menus consist of:

Graph Menu The Graph menu consists:

• ”New Graph”
• ”Setup Graph” on page A-7
• ”Save Graph” on page A-10
• ”Toggle % Nominal” on page A-10
• ”Toggle Origin” on page A-10
• ”Unzoom” on page A-10
• ”Print/Print Preview/Print Setup” on page A-10
• ”Edit Copy” on page A-10
• ”Window Menu” on page A-10
• ”Help Menu” on page A-10

New Graph See ”Graph Plots” on page A-15.
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Setup Graph Use this window (Figure A.4) to configure:

• Graph appearance issues
• Automatic creation issues
• Target Platform Resolution
• Graph Footer Text

Figure A.4  RMS Graph Setup - Screen Settings

Buttons and Fields

These items are the same for the Web Settings tab.

Graph Colours/Fonts - Screen

Click a button and use the popup to configure the 
color for that item. Configurable items include:

• Background
• Foreground
• Phase A, B, C and Neutral

Sample Text Displays sample text based on the Change Font 
selection.

Change Font Opens a standard Windows font selection window.
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Figure A.5 shows the Automatic Settings tab.

Figure A.5  RMS Graph Setup - Automatic Settings

Buttons and Fields

Enable Automatic Graph Creation

Activate to enable automatic graph creation and 
activate the inputs in the Graph Creation and 
Graph Types areas.

Graph Creation Enable the types of graphs to auto-create:

• Transient Records
• Disturbance Records
• Both Record Types

Graph Types Enable the types of channels to auto-create:

• Voltage RMS Phase Group
• Current RMS Phase Group

Target Platform Resolution

Enable the target resolution:

• 640 X 480
• 800 X 600
• 1024 X 768
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Graph Footer Text Dictate the graph footer text:

• No Footer Text
• Record Comment
• Classification Summary
• User Defined - enter the text in the field

Setup Graph
Operations

To configure graph settings:

1. Select Graph > Setup Graph.

2. Configure the Screen Settings and Web Settings tabs by:

a. Click a button and the Color dialog appears.
b. Click on a new color and click OK.

NOTE See ”Color Configuration Operations” on page 3-35 to define custom 
colors.

3. Click Change Font, use the dialog to select font choices and click 
Close.

4. Configure the Web Settings tab by:

a. Click Enable Automatic Graph Creation, if required.
b. Click a Graph Creation radio button, if required:

• Transient Records
• Disturbance Records
• Both Record Types

c. Click a Graph Types radio button, if required:
• Voltage RMS Phase Group
• Current RMS Phase Group

d. Click a Target Resolution radio button, if required:
• 640 X 480
• 800 X 600
• 1024 X 768

e. Click Graph Footer Text, if required:
• No Footer Text
• Record Comment
• Classification Summary
• User Defined - enter the text in the field.

5. Click OK.
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Save Graph Use this option to save the graph as a .bmp or .wmf file.

Save Graph
Operations

To save the graph:

1. Click Graph > Save Graph and a standard Save As dialog appears.

2. Navigate to a directory, enter a name and click Save.

Toggle %
Nominal

Use this option to enable/disable the % Nominal axis.

Toggle %
Nominal

Operations

To enable/disable:

• Click Graph > Toggle % Nominal and the axis is toggled.

Toggle Origin Use this option to enable/disable the origin. Enabled and zero becomes 
origin for the graph.

Toggle Origin
Operations To enable/disable:

• Click Graph > Toggle Origin and the origin is toggled.
Unzoom Use this option unzoom a graph.

Unzoom
Operations

To unzoom:

• Click Graph > Unzoom and the graph is unzoomed.
Print/Print

Preview/Print
Setup

See ”Print/Print Preview/Print Setup” on page 3-37.

Edit Copy See ”Copy” on page 3-39.

Window Menu See ”Windows Menu” on page 3-108.

Help Menu See ”Help Menu” on page A-35.
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Distance to Fault Introduction
Distance to fault (DTF32) (Figure A.1) is an optional analysis module for 
Display Station 32.

To start DTF:

• Select Tools > Distance to Fault 32. It is also run automatically 
during the Expert System (ES) classification. The Expert System 
application must be available for DTF32 to operate.

The DTF algorithm is based on the well tried and tested single ended 
impedance model approach first promoted by Takagi in 1982. 
Improvements made by Ericson in 1985 have been included.

Figure A.6  Distance to Fault 32 Menu Dialog

Before a calculation can be made, the line impedance values (Zl) and 
line length (L) must be entered. For parallel lines, a mutual coupling 
value can also be entered. To compensate for remote end power in-feed 
into the fault, enter an estimate for the remote end impedance (Zb). A 
local source impedance (Za) can also be entered, if it is available. The 
line impedances can be entered in either sequence component or phase 
component form (Figure A.7). 
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Figure A.7  Line Impedance

The DTF algorithm measures the pre-fault and fault currents to 
compensate for remote end in-feed. The fault distance is computed 
several times during the fault period, and the results averaged.

Breaker Performance Monitor Introduction
The Breaker Performance Monitor (BPM) records the operations of 
switchgear recorded by the Ametek transient fault recorder and 
interpreted by the Expert System. The database is used to monitor which 
breakers are due for servicing due to cumulative or accumulated contact 
wear worked out using a settable wear formulae.

NOTE The Expert System software must be installed for circuit breaker data to 
be exported to the BPM application.

Each fault record is analyzed and specific parameters on the operation of 
local switchgear are extracted. These are exported to an external 
database and recording over time the performance of the circuit breakers 
are analyzed. The accumulated number of operations, arcing current and 
arcing time all contribute to wear of the main contacts. By selecting one 
of the three standard formulae the service period for each piece of 
switchgear are determined.

The operate times of the protection relay and circuit breaker are also 
recorded.
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Volt Dips Analysis Introduction
The Voltage Dips application records and displays voltage events in the 
form of dips and surges recorded by the transient fault recorder and 
interpreted by the Expert System.

NOTE The Expert system software must be running for data to be 
automatically exported to the dips database.

By accumulating data over time a profile of the power quality in terms of 
voltage variation is generated. This profile is used to compare variations 
in quality at the same site or check voltage variations across many 
locations.

The data stored in the database can be displayed graphically in one of 
two ways:

• A 3D bar chart which graphs dip level against duration against 
the number of events.

• A scatter plot where each event is located on a 2D graph by dip 
and duration. Standard limit curves are also shown for 
comparison.

The records in the database are stored in the Microsoft Access© format 
(.mdb), and they can also be viewed if necessary by Access©, Excel© or 
any other application which can read .mdb files.

Menus and Widows

This section explains the menu items that appear for each of the 
subcomponents. See:

• ”Expert System Menus”
• ”Distance to Fault Menus and Windows” on page A-37
• ”Voltage Dips Windows and Menus” on page A-44
• ”BPM Menus and Windows” on page A-61

Expert System Menus
Figure A.8 shows the Expert System main window.

Access this window by:

• Clicking Expert System from a Record dialog in DS.
• Selecting Tools > Expert System 32 in DSA.
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Figure A.8  Expert System Main Window

For information on:

• Graph Plots see ”Graph Plots” on page A-15.
• Classify Fault see ”Classify Fault” on page A-17.
• Edit Create see ”Substation Menu” on page A-19.

This menu consists of:

• ”Graph Plots”
• ”Classify Fault” on page A-17
• ”Export Switchgear” on page A-18
• ”Export Dips” on page A-18
• ”Save Outputs” on page A-19
• ”Print Outputs” on page A-19
• Exit
A-14 1086-339  Rev. A   11/05



Fault Recorder Operations Manual
Graph Plots
Use this option to open the RMS Graphs window (Figure A.9) where a 
channel(s) appear in RMS format for the voltage and current signals. The 
RMS is calculated using a one cycle sliding window and then uses five 
cycles of information for smoothing.

Figure A.9  RMS Graph Plot

Graph Plots
Operations

To open the RMS Graph window:

1. Open the window by:

• Selecting Expert > Graph Plots in the Expert System main window.
• Clicking Graph Plots from the Expert System main window.
• Selecting Graph > New Graph from the RMS Graphics main 

window.

The RMS Graph Selection dialog appears (Figure A.10)
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.

Figure A.10  RMS Graph Selection

2. Select the channel(s) for display. Either select:

• Individual channels by clicking on the name.
• The three channels that make up a phase group by picking a 

group from Phase Group Selection.

NOTE Only channels with the same unit type (i.e. Volts or Amps) can appear 
on the same graph. 

3. Select an Impedance Plot, if required.

The RMS graph appears with the selected channels shown.
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Classify Fault
Use this function (Figure A.11) to classify a fault.

Figure A.11  Classify Fault

Buttons and Fields

Location & Time Displays the location and time for the record in 
use.

Fault Information

Displays the output from the classification of the 
fault type including, the fault current, and the 
voltage depressions of the faulted circuit(s). A one 
line summary of the fault record is followed by 
detailed data measurements including:

• The trigger cause from the record header 
information. 

• The fault type. e.g. Phase A to Ground
• The over current level in Amps
• The voltage depression expressed as a 

percentage of the nominal voltage.

The types of values determine depends on the 
contents of the fault record file.
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Switchgear Information

Displays classification information on the 
appropriate Digital Inputs including Relay and 
Switchgear operation times. Time limits, set in the 
Substation Details window, are used in the 
classification to determine whether the relay and 
the switchgear operated within these limits

Fault
Classification

Operations

To classify a fault:

1. Click either:

• Classify Fault on the Expert System 32 window

or

• Select Expert Classify Fault.

NOTE An error message can occur. Click OK to clear the message and resolve 
any problems before reclassifying.

2. Click OK.

Export Switchgear
Use this menu option to enable/disable the updating of the Switchgear 
database, if available. Uncheck this menu item to prevent automatic 
updating on fault classification.

The database must already be set up for the current location and circuit(s) 
in order to accept this data. See ”Substation Menu” on page A-19.

NOTE The Switchgear database is only updated if the classifier has detected a 
switchgear operation.

Export Switchgear
Operations

To configure:

• Select Expert > Export Switchgear and the check mark is 
enabled/disabled.

Export Dips
This menu option enables/disables the updating of the Voltage Dip 
database, if available. Uncheck this menu item to prevent automatic 
updating on fault classification.
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NOTE The Voltage Dip database is only updated if the classifier has detected a 
voltage dip event.

Export Dips
Operations

To configure:

• Select Expert > Export Dips and the check mark is 
enabled/disabled.

Save Outputs
Use this menu option to save all out puts to a text (*.txt) file.

Save Outputs
Operations

To perform this:

1. Select Save Outputs and a Save As dialog appears.

2. Navigate to the directory, enter a name and click Save.

Print Outputs
Use this menu option to print all outputs to a printer.

Print Outputs
Operations

To perform this:

1. Select Print Outputs and a Print dialog appears.

2. Configure as required and click Print.

Substation Menu
This menu consists only of Edit/Create Details.

Phase Group 
Channels

Use this window (Figure A.12) to configure the phase group channels for 
the breaker. This window is accessed throughout the configuration of 
circuit details and is produced here for reference.

Phase Group
Channels

Operations

To configure:

1. Click Phase Groups and the dialog appears (Figure A.12).

Figure A.12  Phase group channels
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2. Configure the Phase group channels by:

a. Clicking Phase group and the dialog appears (Figure A.13).

Figure A.13  Phase group channel

b. Enter a Label.
c. Select Definitions for all phases.
d. Click OK.

The Phase group channels dialog reappears.

3. Click Close and the Substation Details window reappears.

Edit/Create Details
Each time the fault classifier runs the Substation Configuration File is 
loaded. If this file is not available, or is corrupted, the Substation Details 
window appears (Figure A.14). Use this window to enter the details of 
the location. This information must be available for a classification to 
occur.

The substation details assume that the recorder is recording at least one 
voltage phase group and one current phase group. These could be the 
bus bar voltages and the summated transformer currents. A number of 
outgoing feeders can be monitored and the Expert System is best used 
when the protection relays and switchgear for each feeder are connected 
to the digital inputs.
A-20 1086-339  Rev. A   11/05



Fault Recorder Operations Manual
Figure A.14  Substation Details

Buttons and Fields

Substation Configuration

Displays the recorder the substation name.

Save Saves all data.

Clear all Clears all the fields. Click Clear all and then Reload 
to recover newly entered information that has not 
been saved.

Delete Erases the Substation Configuration File, which 
may be required if a recorder is moved from one 
substation to another.

Advanced Opens the Classifier Thresholds window to fine 
tune the fault classifier (”Classifier Thresholds” 
on page A-25).

Circuits Opens the Edit Circuits window to add/edit 
circuits. See ”Edit Circuits” on page A-24.

No. of circuits Displays the number of out going feeders 
connected at the location. The names and digital 
channel inputs must be specified separately for 
each feeder.
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Transmission Station Indicates whether the recorder is connected to a 
Transmission station or Distribution station. This 
information is required for DTF calculations.

VT Wiring Select phase - phase (Ø - Ø) if phase-to-phase 
voltage transformers are connected at the inputs. If 
phase to neutral voltage transformers are 
connected at the inputs then select phase - neutral 
(Ø - N).

Neutrals Opens the Neutral Inputs dialog to specify whether 
or not to monitor neutral currents and voltages.

Circuit Details Enter the details for each outgoing feeder.

DTF Opens the DTF - Transmission Line Model Details. 
See ”DTF - Transmission Line Model Details” 
on page A-30.

Circuit Name Select the number of the feeder up to the value 
determined in No of circuits.

Voltage/Current Phase Group

Select the Phase Group that represents the Voltage 
Phase Group or Current Phase Group for the 
selected circuit number. The channel names 
appear in the boxes to the right. The classifier 
needs to know which inputs are voltages and 
which are currents.

Channels Opens the Phase group channels for configuration. 
See ”Phase Group Channels” on page A-19.

Relay Channel Click the check box and select a digital input 
channel. If a protection relay contact is connected 
to the recorder this includes relay information in 
the classification. Either the pick up or trip 
auxiliary output is used but the fixed operate time 
should reflect the output in use. The digital input 
configuration in Display Station can be used to 
select the normal state of the relay.
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Switchgear channel (C/B Channel)

Click the check box and select a digital input 
channel that represents the Circuit Breaker. If an 
auxiliary switchgear contact is connected to the 
recorder this includes Switchgear information in 
the classification. The digital input configuration in 
Display Station can be used to select the normal 
state of the relay.

Time limit Enter a value that represents the time at which the 
Relay output or Switchgear operates after the fault 
detection. It is set in milliseconds (mSecs). e.g. the 
Relay is required to operate 10 mSecs after fault 
occurrence and the Relay/Switchgear is required to 
operate 55 mSecs after fault occurrence. This value 
is only considered if the relay has operated during 
the fault.

Tolerance Enter a tolerance related to the Time Limit.

Switchgear Opens the Circuit Breaker window to set up the 
present circuit in the Switchgear database. See 
”Circuit Breaker” on page A-28.

Neutral Inputs Opens the Neutral Inputs dialog (”Neutral Inputs” 
on page A-27) to specify if neutral inputs are 
present.

Substation Details
Window General

Operations

This is the general procedure for configuring this window:

1. Add a circuit. See ”Edit Circuits” on page A-24.

2. Set classifier thresholds. See ”Classifier Thresholds” on page A-25.

3. Configure neutral inputs. See ”Neutral Inputs” on page A-27.

4. Configure circuit breaker issues. See ”Circuit Breaker” on page A-28.

5. Configure line details, if required. See ”DTF - Transmission Line 
Model Details” on page A-30.

6. Configure phase group channels. See ”Phase Group Channels” 
on page A-19.

7. Configure the details on the Substation Details window.
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Edit Circuits Use this window (Figure A.15) to add/edit circuits.

Figure A.15  Edit Circuits

Buttons and Fields

Circuits available at Location

List the circuits previously added or just added.

Circuits in Substation Config

List circuits linked to this substation.

Add Adds a circuit name entered in the field to Circuits 
available at Location.

Arrows Toggles circuits between the lists.

Edit Circuits
Operations

To configure:

1. Click Circuits on the Substation Details window.

2. Type a name in the Add field and click Add.

It appears in Circuits available at Location.

3. Select the circuit in Circuits available at Location.

4. Click the right arrow.

It appears in Circuits in Substation Config.

5. Click OK.

The Substation Details window reappears.
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Classifier 
Thresholds

Opens the Classifier Thresholds window to fine tune the fault classifier 
(Figure A.16).

Figure A.16  Classifier Thresholds

Buttons and Fields

Fault Current Ratio Enter a ratio. The fault ratio compares the pre-fault 
and in-fault values and uses this ratio to determine 
if there is a fault condition. If the classifier is not 
detecting a fault on a phase where it should, 
decrease the Fault Current Ratio. The default is 
1.195. For example, the Post fault current on a 
phase must be at least 1.195 times the Pre-fault 
current for a fault on that phase to be detected.

Neutral Current Enter a value. If the classifier is not detecting a 
ground or neutral current properly, decrease the 
Neutral Current value to make it more sensitive. 
This value represents the post fault neutral current 
above the pre-fault neutral current in Amps.

The Neutral Current (HiZ)

Sets a threshold (the default is 20 Amps) for a high 
impedance earth fault. If the classifier cannot 
detect fault current or a voltage dip it checks the 
neutral channel, if available, for a high impedance 
earth fault.

Voltage Dip Level Set the voltage dip level as a percentage. The RMS 
nominal voltage is compared with the RMS in-fault 
value. The pre-fault is not considered.
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Export dips for downstream faults

Enables the export of Voltage Dip information to 
the Voltage Dips Database, even when 
overcurrent/downstream faults are detected. 

Always export dips as P-P percentage

Forces the dips that are exported to the voltage dips 
database to always be in the Phase-Phase format, 
irrespective of the type of V-Ts connected. Circuits 
with Phase-Neutral V-Ts have voltage waveforms 
that are Phase-Neutral. These are converted to 
Phase-Phase by the Expert System before export to 
the Phase-Phase voltage.

Defaults Resets the Fault Current Ratio, the Neutral Current, 
and the Neutral Current (HiZ) to their default 
values of 1.195, 40, and 20, respectively.

Classifier
Thresholds
Operations

To configure:

1. Click Advanced on the Substation Details window.

The Classifier Thresholds window appears (Figure A.17).

Figure A.17  Classifier Thresholds

2. Select a value, as required, for:

• Fault Current Ratio
• Neutral Current
• Neutral Current (HiZ)
• Voltage Dip Level
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3. Click Export dips for downstream faults, as required.

4. Click Always export dips as P-P percentage, as required.

5. Click Return and the Substation Details window reappears.

Neutral Inputs Opens this dialog (Figure A.18) to specify if neutral inputs are present. 
Both the voltage and neutral current inputs can be specified. If these are 
available, the fault classifier can also check for ground faults. The neutral 
details are saved along with the details from the Substation Details 
window.

Buttons and Fields

Voltage Neutral Select a voltage channel label that represents the 
neutral voltage input.

Current Neutral Select a current channel label that represents the 
neutral current input.

Figure A.18  Neutral Inputs

Neutral Inputs
Operations

To configure:

1. Click Neutrals and the Neutral Inputs dialog appears (Figure A.18)

2. Select a Voltage Neutral and/or Current Neutral.

3. Click Return and the Substation Details window reappears.
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Circuit Breaker This window (Figure A.19) sets up the present circuit in the Switchgear 
database, if available. This allows the exporting of switchgear operations 
to the database. If the details have already been entered for the circuit, 
they appear and cannot be edited. To edit the details, use the Breaker 
Performance Monitor database viewer, if available. See ”BPM Menus and 
Windows” on page A-61.

Figure A.19  Circuit Breaker

Button and Fields

Substation/Feeder names

Appears at the top of the window for reference. 

Circuit breaker details

Breaker number (or asset number

Enter a reference for each piece of switchgear.

Auxiliary/Main contact delay 

Enter a time. Used as a way for determining an 
accurate time for the parting of the main contacts. 
This time (in milliseconds) is the difference in time 
from the sensed auxiliary contacts changing state 
until the main contacts open. This value can be 
negative as well as positive.
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Last Service Date

Specify which breaker operations to included 
when calculating the maintenance time. All 
operations before this date are ignored. When a 
breaker is serviced, enter its service date.

Circuit Breaker Operation limit

Click a radio button to set the operation limit.

Breaker Performance Monitor (BPM) has three 
ways of determining the maintenance interval for 
switchgear. These are:

• Number of operations
• Accumulated current (current counter) ( I )
• Dissipation function ( Int ) or duty or contact 

wear

The dissipation function has been promoted in 
recent years as a more accurate method of 
determining service life. The function Int is used to 
estimate contact wear by measuring the energy in 
the arc as the contacts open. A value of n = 2 was 
the original guess but operation experience 
suggests that a value of 1.6 may be more accurate. 
The choice of maintenance interval measurement 
for each circuit breaker and the value of the power 
n are determined by operational experience and 
consultation with the manufacturer.

Number of Operations

Enter the threshold value for no. of operations 
mode.

n Enter the value for n, the exponent in Int.

Threshold Enter the threshold for the breaker.

Circuit Breaker
Operations

To configure:

1. Configure the Circuit Breaker Details by:

• Entering a Breaker Number.
• Entering an Auxiliary/Main Contact Delay.
• Entering a Last service date.
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2. Configure the Circuit Breaker Operation Limit by:

3. Clicking either:

• Number of operations and entering a value in the field.
• I
• Int

NOTE BPM tracks all three parameters in the database and you can switch 
between these values within the BPM program.

4. Enter n.

5. Enter a Threshold.

6. Click Save.

The Substation Details window reappears.

DTF - Transmission 
Line Model Details

Use this window (Figure A.20) to set up the basic information for the 
circuit line model. Use the Line and Line-to-line buttons to access 
windows to enter the 3-Phase base value in MVA’s and also Line-Line 
base in KV’s. The parameter types for the line are selected, as well as that 
for the Local and Remote source.

Figure A.20  DTF - Transmission Line Model Details
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Buttons and
Fields

Circuit Name Displays the circuit name for configuration.

Line Details

Label Enter a label.

Description Enter relevant information about the line.

Length Enter a length

Unit Select a unit:

• Kms
• Miles

Parallel Line Select a parallel line circuit, if available.

Description Enter relevant information about the line.

Line Model Opens the DTF Line Model window.

Delete Deletes the selected detail.

DTF -
Transmission Line

Model Details
Operations

To configure:

1. Click DTF on the Substation Detail window and the DTF - 
Transmission Line Model Details appears (Figure A.20).

2. Configure Line Details by:

• Entering a Label.
• Entering a Description.
• Enter a Length and select Units.

3. Click Line Model and the Line Model Impedance Data Sheets 
window appears (Figure A.21).
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Figure A.21  Line Model Impedance Data Sheets

4. Configure Line Details by:

• Entering a 3 Phase Base value.
• Entering a Line-to-Line Base value.

5. Configure Local Source by:

• Clicking a Units radio button:
• Ohms 
• PU

6. Clicking a Format radio button:

• Phase
• Sequence

7. Click Local and a Line Impedance Components dialog appears 
(Figure A.22 or Figure A.23).

Figure A.22  Line Impedance Components: Sequence Format
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Figure A.23  Line Impedance Components: Phase Format

8. Enter values per phase.

If the phase component form is used, the individual and mutual 
impedances are required.

9. Click OK.

10. Repeat steps 6 through 9 for Line and Remote Source.

NOTE For Remote Source there are two additional drop downs:

• Remote Location
• Circuit Name

Configure these as well.

11. Click OK and the DTF - Transmission Line Model Details window 
reappears.

12. Select a Parallel Line, if available.

13. Enter Parallel Line Details by:

• Entering a Label.
• Enter a Description.

14. Click Line-to-Line Parameters and the window appears (Figure A.24).

Figure A.24  Line-to-Line Parameters
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15. Click a Format radio button:

• Phase
• Sequence

NOTE For double-ended line models:

Enter the data in the order:

• Phase group details for the local end recorder in ES
• Phase group details for any parallel circuit 
• Phase group details for the remote end recorder in ES
• Phase group details for any parallel circuit 
• The line model for the local end recorder

16. Click Line-to- Line-Impedance and the window appears 
(Figure A.25). DTF32 does not assume that the two lines have 
identical impedances. The mutual coupling between the lines is also 
entered.

Figure A.25  Line Impedance Components

17. Enter values per phase.

If the phase component form is used, the individual and mutual 
impedances are required. 

18. Click OK and the Line-to-Line Parameters reappears. 

19. Click OK.

A dialog appears.

20. Click Yes and the Substation Details window reappears.
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Edit Menu
This menu consists only of Copy Outputs.

Copy Outputs
Use this to copy the record to the clipboard for use in a text editor.

Copy Outputs
Operations

To use this:

1. Select Edit > Copy Outputs.

2. Paste into a text editor.

Help Menu
The Help menu consists of:

• ”Help”
• ”About”

Help
The information in the application Help is mostly duplicated in this 
manual.

To open help:

• Select Help
• Select Help > Contents the main index page for the help system 

appears.
• Select Help > Searching for help on and the search window for 

the help system appears.
• Select Help > Using Help and the main contents page for the help 

system appears.
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About
This dialog (Figure A.26) contains copyright and licensing information for 
the product together with its version number. When seeking support you 
may be asked to provide some of the information found here.

To display this dialog:

• Select Help > About and the dialog appears (Figure A.26).

Figure A.26  About Expert System
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Distance to Fault Menus and Windows
Substation model Before the distance to fault is calculated, the line length and impedance 

must be defined. This is done inside the Expert system as part of the 
Substation Model. For DTF to be available, the substation must be 
defined as a Transmission station by checking the relevant box, and the 
VT Wiring must be defined as phase to neutral (-N). See ”Edit/Create 
Details” on page A-20.

If the voltage and current phase groups have not been previously defined, 
use Channels to set up the groups. See ”Neutral Inputs” on page A-27.

Figure A.27 shows the Distance to Fault main window.

Access this window by:

• Selecting Tools > Distance to Fault 32 in DSA.

Figure A.27  DTF Window

This window accesses the DTF functionalities:

Select Single Circuit Opens the Select Transmission Circuit ID window 
(”Select Single Circuit” on page A-38).

Calculate DTF Calculates the DTF values (”Calculate DTF” 
on page A-39).

Fault Parameters Opens the Fault parameters window (”Fault 
Parameters” on page A-41).

Circuits Opens the Transmission Circuits window 
(”Circuits” on page A-42).
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About Opens the About dialog.

Close Closes DTF.

Select Single Circuit
Use this window (Figure A.28) to designate a circuit for DTF use.

Figure A.28  Select Transmission Circuit ID

Buttons and Fields

Circuit Selected Displays the circuit selected.

Circuits available Displays available circuits.

Clear Clear selected circuits from the Circuits available.

Select
Transmission

Circuit ID
Operations

To select a circuit:

1. Click Select Single Circuit and the Select Transmission Circuit ID 
window appears (Figure A.28).

2. Select a Circuits available.

3. Click OK.
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Calculate DTF
Use this option to start the DTF algorithm. which:

• Looks at the current channels defined by the phase groups and 
accurately determines the start and end of the fault period.

• Moves the two cursors in the DSA graphics display to these 
points.

• Finds the faulted phase(s).
• Selects the type of fault (phase - neutral, phase - phase, etc.).
• Measures the fundamental pre-fault and fault currents with the 

voltages during the fault.
• Computes the fault impedance and, knowing the line impedance, 

the distance to the fault is determined.

To improve the accuracy of the result, the fault distance is computed a 
number of times during the period that the fault current is flowing and the 
answers averaged. This mean value with the standard deviation appears 
with the fault type. The positions of the start and end of the fault relative 
to the record trigger time also appear.

Fault Impedance The average impedance during the fault is also measured by the system. 
The impedance appears in the Average Resistance and Average 
Reactance boxes, and represents the computed phase-neutral impedance 
of the faulted phase selected by the fault classifier. In the case of a 
multi-phase fault (either phase-phase or phase-neutral), the reference 
phase quantity defined as the leading phase in the phase group definition 
used by the classifier, is used in the impedance algorithm. 

Ordinarily, the computed impedance quantity gives an indication of the 
average fault-impedance during a typical line fault. However, the 
average fault impedance provides additional information for fault 
location in complex network connections such as those encountered in 
distribution networks.

The standard deviation of the results can be treated as a reliability figure. 
The smaller the standard deviation, the more certain the result. If the 
deviation is large, it is probable that the computed distance is unreliable 
and the fault classifier may have picked the wrong fault type. If this is the 
case, override the fault type and recompute the fault distance. See ”Fault 
Parameters” on page A-41.
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Calculate DTF
Operations

To calculate DTF: 

1. Ensure that a model is created or selected. See ”Substation model” 
on page A-37.

2. Click Calculate DTF.

The DFT 32 Results window appears (Figure A.29).

Figure A.29  DTF 32 Results

The DTF 32 Results window displays calculation results. Use the Circuit 
Name drop down to view results for different circuits.
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Fault Parameters
Use this window (Figure A.30) to change the fault type and the position 
of the cursors that determine the start and end of the fault current, and 
recompute the distance once the system has completed the automatic 
calculation. This manual calculation overrides the automatic fault 
classifier. This facility is useful for removing the initial burst of fault 
current that may include arcing and so increase the standard deviation of 
the distance result.

Figure A.30  Fault Parameters

Buttons and Fields

Circuit ID selected Displays the circuit in use.

Data window Displays the From and To time in msecs.

Faulted line and classification

Displays the line tested and classification data. Use 
the drop down to select this line.

Defaults Resets the automatically generated values.

Fault Parameters
Operations

To manually operate the DTF calculation:

1. Click Fault Parameters and the Fault parameters window appears 
(Figure A.30).

2. Select a Faulted line and classification.

3. Use the left and right mouse buttons move the cursor positions to 
select an alternative fault position.

4. Click Close and click Calculate DTF to re-compute the distance.
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Circuits
Use this window (Figure A.31) to create a transmission line model for 
each circuit in a transmission substation. The line model allows for a 
single or double line to be defined. For each line, a label and description 
can be entered, used to discriminate between the two lines for manual 
parameter selection. The line length is entered in miles or kilometers and 
represents the true length, not the distance over the ground. The actual 
impedance model can also be entered.

Figure A.31  Transmission Circuits

NOTE The accuracy of the distance to fault calculation depends on the 
accuracy of the line model. Ensure that the impedance values are as 
accurate as possible.

For each line, the line impedance must be entered. If the local and 
remote source impedances are known, they are also entered for 
improved accuracy. In most cases, the sequence component form of the 
impedances are known but individual phase impedances can also be 
used. If Per Unit values are being used, the base MVA and line-to-line 
voltage must be entered. 

For each of the three impedances - local, line and remote - the zero, 
positive and negative values are all required. These are entered in the 
form R + jX. The off diagonal values are not required, but maintain 
compatibility with the phase component form of the impedance. In most 
cases, the positive (+1) and negative (-1) sequence impedances are the 
same.

Viewing line 
models

When DTF32 is run from DSA32, view the line models by:

Clicking Circuits. The model cannot be changed here. This is done from 
the Expert System Substation model.
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Transmission
Circuits

Operations

To configure this:

1. Click Circuits and the Transmission Circuits window appears 
(Figure A.31 on page -42).

2. Select a Circuit ID.

3. Click Details.

The DTF-Transmission Line Model Details window appears. Refer to 
”DTF - Transmission Line Model Details Operations” on page A-31 
for the remainder of this procedure.

Exit DTF
To exit the DTF program:

• Click Close in the main DTF window.
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Voltage Dips Windows and Menus

The Voltage Dips menu consists of:

• ”System Menu” on page A-46
• ”Database Menu” on page A-55
• ”Edit Menu” on page A-57
• ”Help Menu” on page A-57

Voltage Dips Analysis Main Window
Figure A.32 shows the main window.

Figure A.32  Voltage Dips Analysis 32 Main Window

Buttons and Fields

List Displays the list of filtered events for use in 
graphing. 

3D Bar Chart Displays the voltage dip information as the number 
of dips that occurred between the defined start and 
end dates. This is graphed against the duration of 
the dips and the magnitude of the dip itself, 
expressed as a percentage of the Nominal Voltage. 
See ”Bar Chart Set Up” on page A-52. 
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Scatter graph, Dips against limits

Displays the voltage dips as dots on a scatter graph 
and draws a curve on the graph showing the 
defined limits. Those dips which fall above or 
below the curve, depending on whether 
percentage dip or retention is used (”Options” 
on page A-49), therefore fall outside their 
allowable limits.

Scatter graph, Dips and Surges against limits

Displays the same information as the other scatter 
graph but includes surges of voltage. With this 
option only percentage voltage retention can be 
graphed at this time.

Graph Operations Create a graph

To draw one of the graphs:

1. Click the appropriate radio button.

2. Click .

Details
Use this window (Figure A.33) to edit values for an event before opening 
a graph or to delete an event.

Figure A.33  Voltage Dips Details

Buttons and Fields

Date Displays the event date

Phase Displays the phase.

Time Edit the time.

Duration Edit the duration.
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Retention Enter the percentage.

Comment Edits the comment.

Delete Deletes a record.

OK Enter changes for use in graphing.

Details
Operations

To configure details:

1. Double-click on a record in the main window.

The Details window appears (Figure A.33).

2. Edit active fields, as required.

3. Click OK.

The main window reappears.

System Menu
This menu consists of:

• ”Find Records” on page A-47
• ”Options” on page A-49
• ”Choose/Edit Limits” on page A-50
• ”Bar Chart Set Up” on page A-52
• ”Print Preview/Print Record List/Print Setup” on page A-54
• ”Exit” on page A-54
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Find Records
Use this window (Figure A.34) to define which voltage dip records to 
display.

Figure A.34  Voltage Dips Analysis 32 - Record Selection

Buttons and Fields

Location Select a location.

Date Selection Click a radio button:

• Year - select a year
• Unmarked drop down - select a year for the 1/2 

Year, Quarter and Month fields.
• 1/2 Year - select a time range
• Quarter - select a time range
• Month - select a month
• Start date - select a Start date and End date.

Hold <Shift> down as well a date spinner and the 
date jumps by thirty days at a time.

Display Extracts the required data records and opens them 
on the main window.

Directory Open a dialog (Figure A.35) to enter a path name 
for the database.
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Figure A.35  Data Directory

Find Records
Operations

To access a voltage dip record:

1. Click on the Voltage Dips icon or select it from the Start menu.

The Voltage Dips Analysis 32 Define information to view window 
appears (Figure A.36) to filter records.

Figure A.36  Voltage Dips Analysis 32 - Record Selection

2. Select a Location.

3. Click a radio button:

• Year - select a year
• 1/2 Year - select a year in the unmarked drop down and select a 

time range
• Quarter - select a year in the unmarked drop down and select a 

time range
• Month - select a year in the unmarked drop down and select a 

month
• Start date - select a Start date and End date
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4. Click Display and the Voltage Dips Analysis 32 main window 
appears (Figure A.37).

Figure A.37  Voltage Dips Analysis 32 Main Window

Options
Use this dialog (Figure A.38) to select the voltage dip display option. The 
voltage events are always viewed as percentages. The default is the 
percentage of the nominal voltage retained.

Figure A.38  Voltage Dips Options

Buttons and Fields

Percentage Dip Sets events to appear graphed as percentage 
dipped.

Percentage voltage retained

Sets events to appear graphed retaining percentage 
voltage.
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Options
Operations

To set options:

1. Open Options by:

• Clicking Options on the main window.
• Selecting System > Options. 

The dialog appears (Figure A.38).

2. Click either:

• Percentage Dip
• Percentage voltage retained

3. Click OK.

NOTE This option is not available for the Dips and Surges Scatter Graph, 
which is always graphed in terms of voltage retention.

Choose/Edit Limits
Use this window (Figure A.39) to define a new or different limit curve for 
the creation of scatter graphs.

Figure A.39  Limit Curve

Scatter Graph limit curve definitions are stored as separate files with the 
extension .lmt, for example cbema.lmt. These define the percentage 
voltage retention (the Y coordinate of the curve) and duration in 
milliseconds (the X coordinate of the curve) for the points on the curve.
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Buttons and Fields

Title Enter a title.

Dips

Add Range Enter a value for Retention and Duration.

Delete Range Deletes the selected range.

Copy Copies the selected range.

Paste Paste the copied range.

Surges

Add Range Add a range: an entry field for Surge and Duration.

Delete Range Deletes the selected range.

Copy Copies the selected range.

Paste Paste the copied range.

Choose/Edit
Limits Operations

To configure limits:

1. Open Limit Curve by:

• Clicking Choose/Edit Limits on the main window
• Select System > Choose/Edit Limits.

The Append Database window appears.

2. Navigate to and select a.lmt file.

3. Click Open.

The Limit Curve window appears (Figure A.40).

Figure A.40  Limit Curve
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4. Enter a Title.

5. Configure Dips by:

• Clicking Add Range.
• Entering a Retention and Duration value.
• Editing other fields, as required.

6. Configure Surges by:

• Clicking Add Range.
• Entering a Surge and Duration value.
• Editing other fields, as required.

7. Click OK.

Bar Chart Set Up
Use this window (Figure A.41) to define a new or different set up for the 
creation of 3D bar charts.

Bar Chart set up definitions is stored as separate files with the extension 
.bar, for example default.bar. These define the ranges into which the dip 
data is graphed in terms of percentage voltage retention (the Z axis of the 
chart) and duration in milliseconds (the X axis of the chart). 

Figure A.41  Bar Chart Setup

The minimum number of retention ranges allowed is one, the minimum 
number of duration ranges allowed is two.
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Buttons and Fields

Title Enter a title.

Retention

Add Range Add a range: an entry field for From and To.

Delete Range Deletes the selected range.

Copy Copies the selected range.

Paste Paste the copied range.

Duration

Add Range Add a range: an entry field for From and To.

Delete Range Deletes the selected range.

Copy Copies the selected range.

Paste Paste the copied range.

Choose/Edit
Limits Operations

To configure limits:

1. Open Bar Chart Setup by:

• Clicking Bar Chart Setup on the main window
• Select System > Bar Chart Set Up.

The Append Database window appears.

2. Navigate to and select a.bar file.

3. Click Open.

The Bar Chart Setup window appears (Figure A.42).

Figure A.42  Bar Chart Setup
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4. Enter a Title.

5. Configure Retention by:

• Clicking Add Range.
• Entering a From and To value.
• Editing other fields, as required.

6. Configure Duration by:

• Clicking Add Range.
• Entering a From and To value.
• Editing other fields, as required.

7. Click OK.

Print Preview/Print Record List/Print Setup
Printing options include:

Print record list Prints the contents of the record list in the main 
record list window, with its list of voltage 
dips/surges. If A4 paper is used, configure the print 
set-up options to change the printer page set-up to 
landscape.

Also, if printing on a monochrome printer instead 
of a color printer, redraw graphs in black and white 
using the Black and White option of the Color part 
of the Graph menu prior to sending the graph to 
the printer.

See ”Print/Print Preview/Print Setup” on page 3-37 for procedures.

Exit
To close the application:

• Select System > Exit.
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Database Menu
This menu consists of:

• ”Archive Records”
• ”Append Records” on page A-56
• ”Compact Database” on page A-56

Archive Records
Use this window (Figure A.43) to remove old records from the voltage 
dips database (dips.mdb) database and put them in an archive database.

Figure A.43  Data Archiving

Archive Records
Operations

To archive a database:

1. Select Database > Archive Records.

2. Enter a month and year using the drop downs.

3. Click a date in the calendar.

4. Click a Site Selection radio button:

• All Sites
• Current Site

5. Click OK.

All records in the database that record voltage dip events that 
occurred before this date are removed from the database and placed 
into the archive database.

An Archive Database window appears.
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6. Navigate to a directory, enter a name and click Open.

NOTE If the name already exists then a dialog ask whether to overwrite the 
existing database or append to it. Click:

• YES and the records are appended. 
• NO and the archive is over written. 

Append Records
Use this option to remove old records from the database and append 
them in an existing archive database.

If voltage dip records exist in a separate database, for example in an 
archive database, it is possible to return these records to the voltage dips 
database. 

Append Database
Operations

To archive a database:

1. Select Database > Append Records.

An Append database window appears.

2. Navigate to the archive database and click Open.

Compact Database
Use this option to compact the database.

Append Database
Operations

To compact a database:

1. Select Database > Compact Database.

The Database Compacting dialog appears (Figure A.44).

Figure A.44  Database Compacting

2. Click Compact.

3. Click Close.
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Edit Menu
This menu consists only of Copy record list.

Copy record list
Use this function to copy the record list. Then it can be pasted into a text 
editor.

Help Menu
See ”Help Menu” on page 3-114.

Graph Window
Figure A.45 shows the main graph window.

Figure A.45  Voltage Dips Graph Window
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Voltage Dips Graph Window Menus
These menus are:

• ”Graph Menu”
• ”Edit Menu” on page A-60
• ”View Menu” on page A-60
• Help

Graph Menu This menu consists of:

• ”Save Graph”
• ”Look” on page A-58 - 3D Bar Chart only
• ”Footer Label” on page A-58
• ”Colors” on page A-59
• ”Z-Axis Scaling” on page A-59 - 3D Bar Chart only
• ”Legend/ Logarithmic” on page A-59 - Scatter only
• ”Print/Print Preview/Print Setup” on page A-59

Save Graph To save a graph as a .bmp or .wmf:

1. Click Graph > Save Graph.

A Save As dialog appears.

2. Navigate to the directory, enter a file name and type and click Save.

Look To change the look of the graph:

1. Click Graph > Look.

A popup menu appears with three items:

• Surface Plot
• Zoned
• Contoured

2. Select a type and the graph changes.

Footer Label To add/change the footer:

1. Click Graph > Footer Text.

A popup menu appears with three items:

• Label
• Font

A dialog appears.

2. Enter the text and click OK and the text appears in the appropriate 
area.
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Colors To change the color of the graph:

1. Click Graph > Color.

A popup menu appears with three items:

• Background
• Foreground

A color dialog appears.

2. Click a color and click OK and the color changes.

Z-Axis Scaling To change the scale:

1. Click Graph > Z-Axis Scaling.

The Z-Axis Scaling dialog appears (Figure A.46).

Figure A.46  Z-Axis Scaling

2. Click a Z-Axis Scale Selector radio button:

• Automatic
• Manual - enter a Maximum value

3. Click Return and the axis appears.

Legend/
Logarithmic

To toggle these on/off:

• Click Graph > Legend or Logarithms.

Limit Curves See ”Choose/Edit Limits” on page A-50.

Print/Print 
Preview/Print 
Setup

See ”Print/Print Preview/Print Setup” on page 3-37.
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Edit Menu This menu consist of:

• Copy - see ”Copy” on page 3-39/
• Bar Chart Set Up - ”Bar Chart Set Up” on page A-52.
• Options - see ”Options” on page A-49.
• Statistics - Scatter Graphs only

Statistics Displays the Dip/Surge Statistics dialog for scatter graphs (Figure A.47).

Figure A.47  Dip/Surge Statistics

View Menu This menu consists only of Data Graph.

Data Graph Use this option to toggle on/off the data display on the bottom of graph 
(Figure A.48).

To toggle the data on/off:

• Select View > Data Graph.

Figure A.48  Voltage Dips Graph with Data
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BPM Menus and Windows

The Breaker Performance Monitor menu consists of:

• ”System Menu”
• ”View Menu” on page A-69
• ”Help Menu” on page A-70

BPM Main Window
Figure A.49 shows the BPM main window.

Figure A.49  Breaker Performance Monitor Main Window

There are three record views:

• Accumulated contact wear (default) -Lists the breaker number, the 
location of the breaker, the feeder it is on and the accumulated 
contact wear per phase (A, B and C).

• Total Current Interrupted
• Operations - Fills the list with circuit breaker operations records. 

For each record of each operation, the breaker number, the 
location of the breaker, and the feeder it is appears, along with the 
date and time at which the operation occurred.

Buttons and Fields

Location Sorts the list by the location selected in the drop 
down.
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Month Sorts the list by month selected in the drop down. 
Available only for circuit breaker operations

Feeder Sorts the list by feeder selected in the drop down.

Breaker number Sorts by breaker number selected in the drop 
down.

Breakers with phase value greater than limit

Sorts the list according to phase values greater than 
the preset limit. This filters the Contact Wear list to 
only those breakers that have a total current value 
greater than the set threshold. Use this to check for 
switchgear needing maintenance.

Phase values above ?

Opens the Threshold dialog to input a threshold 
computed wear and operation values below which 
files do not appear. Use a percentage value, with 
the % symbol, and all records with a wear figures 
above this percentage of their set limits appear.

BPM Main
Window Sorting

Operations

Sort Record Lists

To sort the record list:

1. Click the check boxes, as required:

• Location
• Feeder
• Breaker Number
• Month - Operations only
• Breaker with phase values greater than limit - deselects all other 

check boxes

2. Click Phase values above ?, if required, and the Threshold dialog 
appears (Figure A.50).
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Figure A.50  BPM Threshold

3. Enter a value and click OK.

Operation Details
Use this window (Figure A.51) to:

• Display operations details
• Print details
• Edit operation details to see the results

This window initially appears only and the Edit button is enabled.

Figure A.51  Operation Details - View Mode

Buttons and Fields

Location Displays the location.

Feeder Displays the feeder.
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Timing Information

Operation date Displays the operation date.

Operation time Displays the operation time.

Breaker operate time

Displays the breaker operation time. Changeable 
in edit mode.

Relay operate time Displays the relay operation time. Changeable in 
edit mode.

Arcing time Displays the arcing time. Changeable in edit mode.

Faulted Phase(s) Indicates the phases in fault. Changeable in edit 
mode.

Fault Current par phase

Displays the fault current per phase. Changeable in 
edit mode.

Fault Duration per phase

Displays the fault duration per phase. Changeable 
in edit mode.

Edit Activates certain fields for editing so effects can be 
noted. Changeable in edit mode.

Print Prints an image of the window to the default 
printer.

BPM Operation
Details

Operations

To display an operation details:

1. Select a specific record in the Operations window record list.

2. Double-click on the record or select a record and press <Enter>.

The Operations Details window appears (Figure A.52) with the full 
details of the record in it.
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Figure A.52  Operation Details - Edit Mode

3. Click Edit.

4. Configure the active fields, as required.

5. Click OK.

The changes are reflected in the Operations window.
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Set Service Date
Use this window (Figure A.53) to change the formula for calculating the 
contact wear or the service date of the breaker.

NOTE Whenever the service date is changed, the accumulated contact wear is 
recalculated and only operations after that date are included.

Figure A.53  Service Date

Buttons and Fields

Location/Feeder names

Enter the name for each. 

Auxiliary/Main contact delay 

Enter a time. Used as a way for determining an 
accurate time for the parting of the main contacts. 
This time (in milliseconds) is the difference in time 
from the sensed auxiliary contacts changing state 
until the main contacts open. This value can be 
negative as well as positive.

Last Service Date

Specify which breaker operations to included 
when calculating the maintenance time. All 
operations before this date are ignored. When a 
breaker is serviced, enter its service date.
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Circuit Breaker Operation limit

Click a radio button to set the operation limit.

Breaker Performance Monitor (BPM) has three 
ways of determining the maintenance interval for 
switchgear. These are:

• Number of operations
• Accumulated current (current counter) ( I )
• Dissipation function ( Int )

The dissipation function has been promoted in 
recent years as a more accurate method of 
determining service life. The function Int is used to 
estimate contact wear by measuring the energy in 
the arc as the contacts open. A value of n = 2 was 
the original guess but operation experience 
suggests that a value of 1.6 may be more accurate. 
The choice of maintenance interval measurement 
for each circuit breaker and the value of the power 
n are determined by operational experience and 
consultation with the manufacturer.

Number of Operations

Enter the threshold value for no. of operations 
mode.

n Enter the value for n, the exponent in Int.

Threshold Enter the threshold for the breaker.

BPM Service Date
Operations

To configure:

1. Enter a Location name.

2. Enter an Auxiliary/Main Contact Delay.

3. Enter a Last service date.

4. Configure the Circuit Breaker Operation Limit by clicking either:

• Number of operations and entering a value in the field.
• I
• Int

5. Enter n.

6. Enter a Threshold.

7. Click OK.
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System Menu
This menu consists of:

• ”Set Edit Password”
• ”Archive” on page A-69
• ”Print” on page A-69

Set Edit Password
Use this window (Figure A.54) to set or change the password. The 
password protects unauthorized edits to the Operation Details including, 
the amount of wear for each breaker (no. of operations).

Figure A.54  Old Password

BPM Set Edit
Password

Operations

To set the password:

1. Select System > Set edit password and if there is an old password a 
dialog appears, click OK.

2. Enter a new password in Enter Password.

3. Click OK and the new Password dialog appears (Figure A.55).

Figure A.55  New Password

4. Enter a new password and click OK.
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Archive
Use this window (Figure A.56) to archive old records into another file to 
reduce searching and sorting times.

Figure A.56  Archive Old Data

BPM Archive
Operations

To archive old data:

1. Select System > Archive.

2. Enter the date before which all data is archived in the format dd 
mmm yy. For example, 21 Apr 04.

NOTE Ensure that the specified date is before any currently specified service 
dates.

3. Click OK and a Save as dialog appears.

4. Enter a file name and directory for the archived data and click Open. 
The default file is archive.mdb in the c:\bpm directory.

Print
See ”Print/Print Preview/Print Setup” on page 3-37.

View Menu
This menu consists only of Operations and Contact Wear.

Operations/Contact Wear
BPM can display either circuit breaker operations, recorded by the 
Ametek recorder, the total current interrupted or the accumulated contact 
wear on the breakers due to the operations. 

To change between these views:

• Select View > Operations or View > Contact Wear.
1086-339  Rev. A   11/05 A-69



Expert System
Help Menu
See ”Help Topics” on page 3-115.

Fault Classifier Tutorial

This tutorial helps you get the Expert System Fault Classifier up and 
running. The various steps involved assist you in setting up the Substation 
Configuration File for one of the demonstration fault records included 
with this system. You will:

• Classify this fault record
• Analyze the RMS plots associated with the record and,
• View the explanation for the fault.

It is useful to run the Expert System along side this tutorial and follow 
each step as instructed.

NOTE The following steps assume that the Expert System is already installed to 
the same directory as Display Station and that Display Station is 
running.

Step-by-Step Guide
1. Select the ESDemo3 from the Display Station main window and 

double-click it. This record details window appears.

2. Click Analyze. This runs Display Station Analysis for this fault record.

The sinusoidal waveforms recorded for this fault appear.

3. Select Tools > Expert System on the DSA menu and the Fault 
Classifier is initiated

NOTE If Expert System is not on the Tools menu, it has not been installed 
correctly.

If this is the first time that the Fault Classifier is run, then the 
Substation Configuration File is probably not set up for the demo 
recorder ESDemo3. In this case, a message appears indicating this. 
Click OK to continue.

The Fault Classifier main window appears.

The next few steps involve setting up the Substation Configuration 
File and classifying the fault.
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4. Click Edit/Create Substation Configuration File at the bottom of the 
main window to enter details specific to the recorder ESDemo3. The 
text box at the top of the Substation Details window lists the 
substation or recorder name.

5. Enter the following details to set up the demo location:

• Enter a name for the circuit. e.g. Demo Cct.
• Select Phase Group 1 for the voltage phase group.
• Select Phase Group 2 for the current phase group.
• Select the Relay Channel option and choose 5 RT8 AIP
• Select the C/B Channel option and choose 6 RT8 C/B Contact

Time limits and thresholds can also be entered for the relay and 
circuit breaker digital channels.

6. Click Neutrals and enter the neutral channel information. On the 
Neutral Inputs window:

a. Click the Neutral inputs check box and choose NONE for 
Voltage and 8 In for Current.

b. Click Return

This is enough information to allow the Fault Classifier to perform a 
classification on the fault.

7. Click Close and click Yes to save the details for the recorder. The 
main window reappears.

NOTE These details are saved for future use and any other records returned 
from this recorder will use the same details. These are all changeable.

8. Classify the fault by selecting Expert > Classify Fault in main window. 
After a few seconds the fault conclusion appears in the two list boxes.

9. Display the RMS plots of the eight analogue inputs by:

a. Select Expert > Graph Plots.
b. Click the leftmost button on the toolbar of the RMS Graphs 

window.
c. Select channel numbers from the list or a complete phase 

group and click OK.

Displaying the RMS graphs is a way of verifying the conclusion 
drawn by the fault classifier.
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Appendix B.  3Com 56k LAN Modem 
Configuration: Manual and Autopolling

The recording instruments used with Display Station (TR2000, TR100+, 
TR100, PQR, etc.) can be connected via an RS232 serial link, a dial up 
modem or a TCP/IP network connection over a LAN or WAN. All 
instruments have a serial connection and most have either a modem or 
network card or both.

Display Station can also support a dial-up network where a connection is 
made via a modem to a network (Figure B.1). For this, use the Windows 
Dial-Up Connections. For each remote network a dial-up configuration 
must be created. For information on this see Appendix C ”DS32 
3Com/Remote TR 3Com LAN Modem Connection Configuration 
(Autocall)”. To support auto-call an Incoming Connection must also be 
created. For information on configuring auto-call from a network or 
pseudo machine, see Appendix C ”DS32 3Com/Remote TR 3Com LAN 
Modem Connection Configuration (Autocall)”.

Figure B.1  Dial-Up Networking Via Modem on Network
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You can create a pseudo machine (PM) from a number of individual 
recorders connected via a standard network. If adding an individual 
recorder accessed via a modem, then use dial-up networking to connect 
to a PM. To create a small dial up network, a product like the 3Com 
OfficeConnect 56k LAN modem may be used. This allows both dial in 
and dial out functions to support auto-poll and auto-call. The 
configuration of this product for use with Display Station is given in this 
appendix and Appendix C ”DS32 3Com/Remote TR 3Com LAN Modem 
Connection Configuration (Autocall)”.

For more complete information about configuring the 3Com LAN 
modem, use the help at the bottom of each configuration page or the user 
manual which is available as uguide.pdf or uguide.hml file on the DOCS 
directory of the CD that was supplied with the product.

NOTE Remote recorder networks may operate independently of a company 
LAN/WAN or intranet. If, however, the connections are part of a larger 
network the network administrator or IT department should be involved 
in the issuing of IP addresses and configuration of the system.

To create a remote dial up network of recorders each instrument must be 
fitted with a network card (NIC). These are all connected directly to the 
LAN modem. This device accepts up to four recorders directly. To extend 
this an extra hub unit may be added. Up to twenty-three recorders can be 
accommodated on one LAN modem.

The configuration of the system is divided into these parts:

• ”Set Up the DS32 Computer 3Com Modem to Transient Recorder 
3Com Remote Station”

• ”Set up the DS32 Master Station for Use with the Async Modem” 
on page B-15

• ”Set Up the First Remote Sub-station 3Com LAN Modem” 
on page B-17

• ”Set Up the First Remote Transient Recorder” on page B-29
• ”Set Up the Second Remote Transient Recorder” on page B-30
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Set Up the DS32 Computer 3Com Modem to Transient Recorder 
3Com Remote Station

For each recorder the IP address, subnet mask and router IP address are 
all required. If auto-call is required see Appendix C ”DS32 3Com/Remote 
TR 3Com LAN Modem Connection Configuration (Autocall)”. If the 
recorders or Display Station are connected to a corporate network the 
network administrator must issue these addresses. Obey the following 
rules:

• If the system is running stand alone the default address range is 
192.168.1.xxx, where xxx ranges from 3 to 254.

• Do not use 192.168.1.1, since this is the default address of the 
LAN modem itself. 

• Do not use 192.168.1.2, since it is used as the default address for 
the PC linked to the LAN modem for configuration. 

• The subnet mask should be 255.255.255.224. 
• The router IP must be set to the address of the LAN modem. The 

default value of this is 192.168.1.1.

Windows 2000 Configuration
This section explains how to bond the Master Station async modem to 
call a remote 3Com LAN modem for Windows 2000.

The first windows contain the setup information for the DS32 computer. 
This setup allows the PC system to communicate using TCP/IP via a 
modem to the remote 3 Com LAN modem. Figure B.2 is an example 
from a Windows 2000 operating system. See ”Windows XP 
Configuration” on page B-8 for an example of Windows XP 
configuration.

Figure B.2  Network and Dial-up Connections
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To perform this procedure:

1. Click Make a New Connection to start the setup wizard (Figure B.3).

Figure B.3  Network Connection Wizard

2. Click Next and Figure B.4 appears.

Figure B.4  Network Connection Type

3. Click Dial-up to a Private Network and click Next and Figure B.5 
appears. If you have more than one modem, you are prompted to 
choose which modem to use.
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Figure B.5  Phone Number To Dial

4. Enter the phone number of the remote sub-station 3Com LAN modem 
in Phone number to Dial, click Next and Figure B.6 appears.

Figure B.6  Connection Availability
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5. Click For all Users and click Next and Figure B.7 appears.

Figure B.7  Sub-Station Name

6. Enter a name. The name and password you choose must be the same 
as what you set up in the 3Com LAN modem. The Name and 
Password are case sensitive. To make the setup less confusing and 
reduce the chance of a setup mistake, keep everything in the same 
case.

We have named the first sub-station AMS1. This is in capital letters, 
but you can use numbers also. Do not add a shortcut to your desktop, 
as it is not needed.

7. Click Next and Figure B.8 appears.

Figure B.8  Name and Password

8. Enter the password, ensuring it is all upper or lower case, click Save 
Password and enter the entire phone number of the sub-station to 
call. If you need a 9 or some other number to dial out, make sure to 
include it.
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9. Click Properties and Figure B.9 appears.

Figure B.9  Networking Tab

10. Click Internet Protocol (TCP/IP). Ensure that type of dial-up server in 
Figure B.9 matches your setup.

11. Click Properties and Figure B.10 appears.

Figure B.10  TCP/IP Properties

12. Click Obtain an IP Address automatically and Obtain a DNS server 
address automatically and click OK.

This procedure has generated a Dial Up Networking shortcut that can be 
selected under DS32. See ”Recorder Network” on page 2-32 for more 
details.
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Windows XP Configuration
This procedure is an example of how to bond your Windows XP async 
modem to TCP/IP. It creates a DS32 PC Async modem capable of calling 
a remote 3Com LAN modem at a sub-station.

To perform this procedure:

1. Click Start and select Connect To and select Show all connections 
from the pop up (Figure B.11).

Figure B.11  Connect To

The Network Connections window appears (Figure B.12).

Figure B.12  Network Connections
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2. Click Create a new connection in the upper left hand corner.

The Welcome to the New Connection Wizard window appears 
(Figure B.13).

Figure B.13  Welcome to the new Connection Wizard

3. Click Next and Figure B.14 appears.

Figure B.14  New Connection Type
1086-339  Rev. A   11/05 B-9



3Com 56k LAN Modem Configuration: Manual and Autopolling
4. Click Connect to the network at my workplace, click Next and 
Figure B.15 appears.

Figure B.15  New Connection

5. Click Dial up connection, click Next and Figure B.16 appears.

Figure B.16  Connection Name

The Company Name and Password, must match the name and 
password in the 3Com LAN modem device exactly. We have used 
AMS, but we could use AMS1 or AMS2, etc. 

6. Enter the name, the case must match exactly, click Next and 
Figure B.17 appears.
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Figure B.17  Phone Number to Dial

7. Enter the Phone number of the sub-station where the 3Com LAN 
modem and transient recorders are located, click Next and 
Figure B.18 appears.

Figure B.18  Connection Availability
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8. Click Anyone’s use, click Next and Figure B.19 appears.

Figure B.19  Complete the Connection

9. Click Finish and Figure B.20. Do not add a shortcut to your desktop, 
as it is not needed. This new connection is selected for the correct 
Location under DS32, Edit – Recorder Network. If needed, this 
connection can also be used for troubleshooting the connection.

Remember, the user name and password must match the information 
in the 3Com exactly.

10. Click Save password and then click Properties (Figure B.20). If the 
user name or password do not match the remote 3Com LAN modem 
exactly you can connect this modem to 3Com LAN modem, but no 
data is transferred. You could also click Me only or Anyone that uses 
this computer depending on how your PC is used.

Figure B.20  Connect AMS
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11. Click Properties and Figure B.21 appears.

Figure B.21  AMS Properties

12. Select the desired modem and then click the Networking tab 
(Figure B.22).

Figure B.22  AMS Networking Tab
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13. Select PPP: Windows 95/98/NT4/2000, click Internet protocol 
(TCP/IP), click Properties and Figure B.23 appears.

Figure B.23  XP TCP/IP Properties

14. Click Obtain an IP address automatically and Obtain DNS sever 
address automatically, click OK and Figure B.22 reappears.

15. Click OK and setup is complete. The dial up network is now 
complete for this sub-station only. You need to generate one of these 
for each remote sub-station you plan on calling that has a 3Com LAN 
modem. If you wish to change the name or password, then that 3Com 
LAN modem must be set up with the exact same information. If the 
information is incorrect, you will be unable to completely connect to 
the LAN modem and transfer data.
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Set up the DS32 Master Station for Use with the Async Modem
This section explains how to select and add the correct modem 
connection for each recorder.

To setup in DS32 for the remote sub-station:

1. Open DS32 and select Edit > Recorder Network (Figure B.24).

Figure B.24  DS32 Transient Tab

The Recorder Network – Edit window appears (Figure B.25).

Figure B.25  Recorder Network - Edit

Under Recorder Network you can have multiple Regions. For 
example, you could have a North, South, East, and West Region. Or 
you could have a region broken down into Counties. If it’s not a 
concern or you only have a few recorders, you can just use the 
Default New Region and place all of your locations under that.
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2. Add a new Location by right-clicking on the Region and selecting 
Add new Location. The Location is basically the name of the 
sub-station or sub-station area.

3. Add recorders under the Location by right-clicking on the Location 
and selecting Add recorder.

As you add the Locations and recorders, you can right click on each 
one of them and select Rename location or Rename recorder to 
change each name. Once you have added your Location and the 
transient recorders under it, you are ready to add the details of the 
recorder. Make sure that the recorder type is correct, as the default is 
a PQ&R type recorder. 

4. Ensure you select a TR2100, TR100 plus, etc., then (Figure B.26):

a. Click the TCP/IP tab
b. Click the TCP/IP radio button
c. Enter the Recorders IP address
d. Select the correct Dial-Up Networking connection that you 

have already created.
e. Click OK and you are done with setting up Display Station for 

this one recorder. Repeat this for each recorder out in the 
field.

Figure B.26  XP Recorder Details
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Set Up the First Remote Sub-station 3Com LAN Modem
This procedure sets up the 3Com device at the sub-station that is separate 
from the DS32 PC with the async modem setup. 

To perform this procedure:

1. Set up the computer that you plan to use to configure the 3Com 
device:

a. Double-click the Networking dialup connections icon 
(Figure B.27).

Figure B.27  Networking Dialup Connections Icon

b. Double-click the Local Area connection icon (Figure B.28). 

Figure B.28  Local Area Connection Icon
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The Local Area Connection Status window appears (Figure B.29).

Figure B.29  Local Area Connection Status

c. Click Properties and Figure B.29 appears.

Figure B.30  Local Area Connection Properties

d. Click Internet Protocol (TCP/IP) and then click Properties 
and Figure B.31 appears.
B-18 1086-339  Rev. A   11/05



Fault Recorder Operations Manual
Figure B.31  Internet Protocol (TCP/IP) Properties

2. Click Obtain an IP address automatically and Obtain DNS server 
address automatically and click OK.

The PC is now ready to communicate to the 3Com LAN modem that 
is hooked up to the Transient Recorders at the sub-station. Windows 
Internet Explorer is used for all communications to the 3Com LAN 
modem. The next procedure guides you through that.

To set up the remote sub-station 3Com LAN modem:

1. Press the reset button located on the back of the 3Com device and 
hold it. While you hold it, the alert light must goes through three sets 
of flashing. This takes around 30 seconds minimum. This sets the 
3Com LAN modem device to the factory default settings.

2. Reboot the computer if you are using Windows 2000 and open 
Window’s Internet Explorer. Normally you do not need to reboot 
Windows XP in this case. Once you open Window’s Internet Explorer, 
Figure B.32 appears.
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Figure B.32  No Valid Service Providers

3. Click Continue and Figure B.33 appears.

Figure B.33  ISP Wizard

4. Click Abort and Figure B.34 appears.
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Figure B.34  3Com LAN Modem Wizard

5. Click Dial-In and Figure B.35 appears.

Figure B.35  3Com Dial-In User Parameters

6. Configure this window as follows:

• The name and password must match the setup from what you 
entered on the Network Connection Wizard window. 

• Set all of the following pages with the correct IP addresses for 
your application.

• The name and password must match the case you entered in the 
Setup Wizard.

• Router to Router must be selected, and Data Compression must 
be checked. 

• The Idle Timer is set high, that the modem does not hang up if it 
sees a break in data transfer. 
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7. Scroll down and set the following parameters (Figure B.36):

Figure B.36  3Com WAN Parameters

• LAN Modem WAN IP: This is the remote sub-station’s 3Com’s 
LAN modem’s IP address. This is normally the first sub-station that 
you set up. The second sub-station LAN modem’s address is 
normally 192.168.3.1, etc.

• Remote Lan IP: This is the IP address (by default) of the PC 
running DS32 (by way of DHCP).

• Remote Lan IP Subnet Mask: This is the default Subnet mask and 
should be used for all 3Com LAN modems or devices talking to 
them. If you do not use this mask and attempt to go beyond the 
limit of the 3Com device, the 3Com device will not work.

• Primary DNS: This is the same IP address as the Remote LAN IP 
address. 

8. Click Submit. 

NOTE Always click Submit before changing screens.

9. Click Dial-In Global and Figure B.37 appears.
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Figure B.37  3Com Global Parameters

10. Configure Dial-In Global Parameters:

• Change Auto Answer to the 1
• Click the check boxes for PAP, CHAP and MS-CHAP.
• Click Submit

11. Click Service Providers from the main window and Figure B.38 
appears.

Figure B.38  3Com Service Provider Selection
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12. Click New (Private Network) and click Select and Figure B.39 
appears.

Figure B.39  Private Network Parameters

13. Enter the:

a. Name that calls in. In our previous examples we used AMS 
and/or AMS1 as a default name for all locations. In our exam-
ple, we are only using one user name and password at the PC 
and at the 3Com LAN modems, but this does not have to be 
the case. 

b. Telephone number if you have another 3Com LAN modem at 
the PC running DS32. This phone number is used for Auto-
calling only, and is not used if you are only using a 3Com 
LAN modem at the remote sub-station locations.

c. User ID and Password that you entered under the Network 
Connection Wizard.

14. Scroll down and configure the DNS parameters (Figure B.40):

a. Enter the Domain Name Service IP address. This is by default 
192.168.1.1. 

b. The Private Network Parameters are the same with the default 
Subnet Mask.

c. Increase the Callback Delay to at least 5 and the Callback 
Timeout to around 90.
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Figure B.40  Private Network DNS Parameters I

15. Scroll down and configure the Miscellaneous Parameters (Figure B.41 
and Figure B.42):

a. IP address of the Remote sub-station 3Com LAN modem that 
you are currently setting up.

b. The Subnet Mask is always left untouched.
c. The Default Workstation is the PC that is setting up the 

attached 3Com LAN modem.
d. Enable the intelligent NAT by clicking Yes.

Figure B.41  Private Network DNS Misc. Parameters I
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Figure B.42  Private Network DNS Misc. Parameters II

16. Click Submit and the 3Com OfficeConnect Lan Modem Web Wizard 
window reappears (Figure B.34 on page B-21).

17. Click Workstation Config and Figure B.43 appears.

Figure B.43  3Com Workstation Parameters

18. Reserve the static IP Addresses for the recorders and the PC that 
connects to it for future changes:

• 192.168.2.2 is the PC’s IP address that is currently connected to 
it. This is handed out by default by DHCP to the PC.

• 192.168.2.3 is the IP address of the first recorder attached.
• 192.168.2.4 is the second recorder.

Only the recorder’s IP address need to reserved.
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19. Click Submit.

The main 3Com LAN Modem default window reappears 
(Figure B.34 on page B-21).

20. Click Data Call Parameters and Figure B.44 appears. Enter 
parameters as in Figure B.44.

Figure B.44  3Com Data Call Parameters

For Disconnect an outgoing automatic data call after how long of an 
inactivity period, we have set a value of 900 seconds. In some cases 
this may be too long of a value and can be reduced if needed.

21. Click Submit and the main window reappears 
(Figure B.34 on page B-21).

22. Click LAN Parameters and Figure B.45 appears.
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Figure B.45  3Com LAN (Ethernet) Parameters

Configure this screen:

• Change the IP Address to the one that you plan on using for this 
sub-station. As always, enter the default Subnet Mask. To avoid 
setup problems, for the:
• First sub-station you would normally use 192.168.2.1.
• Second sub-station you would use 192.168.3.1, and follow 

this pattern for the rest.

When you change the LAN parameters IP or Sub Mask, it may be 
necessary to reboot your computer to communicate to the 3Com. As 
this will most likely put you on a different LAN, DHCP needs to issue 
a new IP address for your PC.
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Set Up the First Remote Transient Recorder
This procedure sets up sub-station A’s transient recorder #1’s IP address, 
Subnet Mask, and Router’s address, using DS32.

To perform this procedure:

1. Open DS32 and connect to the first transient recorder using the direct 
connect option and the RS232 direct connect cable.

2. Navigate to the Recorder Configuration window (Figure B.46).

Figure B.46  3Com Recorder Configuration

3. Click Peripherals and Figure B.47 appears.

Figure B.47  3Com Recorder Peripherals
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4. Enter the IP Address for that recorder. The default IP Subnet Mask 
always remains the same.

5. Enter the Router IP Addr, the IP address of the router to which the 
transient recorder attaches.

6. Click OK and click Setup. You can now disconnect from this unit and 
proceed to the next unit.

Set Up the Second Remote Transient Recorder
To perform this procedure:

1. Move the RS232 cable to the next transient recorder and connect to it 
using DS32 and the direct connect option with the RS232 direct 
connect cable.

2. Navigate to the Recorder Configuration window (Figure B.48).

Figure B.48  3Com Recorder Configuration

3. Click Peripherals and Figure B.49 appears.
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Figure B.49  3Com Recorder Peripherals

4. Enter the IP Address for that recorder. The default IP Subnet Mask 
always remains the same.

5. Enter the Router IP Addr, the IP address of the router to which the 
transient recorder attaches.

6. Click OK and click Setup. You can now disconnect from this unit and 
proceed to the next unit.
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Appendix C.  DS32 3Com/Remote TR 
3Com LAN Modem Connection 
Configuration (Autocall)

The pseudo machine configuration (Figure C.1) uses either a LAN/WAN 
or dial-up network to make a remote connection. Both configurations 
support manual connections and auto-poll. The LAN/WAN scheme also 
supports auto-call where the recorder initiates the connection. If 
auto-call from a pseudo machine is required for a dial-up network 
connection, a different configuration is required. This prevents Windows 
from assigning a default gateway for a dial-in connection, making it 
impossible for the PC to communicate with a remote instrument through 
a LAN modem.

Figure C.1  Pseudo Machine Configuration

LAN

AUTOCALL
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To implement a scheme that supports an auto-call from a pseudo 
machine, there must be a 3Com-to-3Com card connection. Then 
connect the PC to the LAN modem via a LAN connection. The operating 
system provides a network connection and the local LAN modem 
provides the dial-in services. The dial-out services in the LAN modem are 
very limited, so a standard modem connection is used to provide these.

The LAN modem uses a PC with a network connection and web browser 
(e.g. Windows Explorer) to configure the connection. This requires that 
the PC be set to support dynamic IP addresses (DHCP).

To configure the system to support manual connection, auto-poll and 
auto-call there several area that must be configured:

• ”Set Up the Recorders”
• ”Setup a 3Com Device Connected to the DS32 Computer” 

on page C-3
• ”Setup the DS32 Computer’s Network “NIC” Card.” on page C-14
• ”Set Up the First Remote Sub-station 3Com LAN Modem” 

on page C-17
• ”Set Up the DS32 Transient Recorders for Autocall” on page C-31

The network IP address of each recorder must be unique as the recorders 
do not support DHCP.
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Set Up the Recorders
Obey the following rules:

• For each recorder the IP address, subnet mask, auto-call IP 
address and router IP address are required.

• If the recorders or Display Station are connected to a corporate 
network, the network administrator must issue these addresses.

• If the system is running stand alone the default address range is 
192.168.yyy.xxx, where xxx ranges from 3 to 31. Do not use the 
address 192.168.yyy.1 since this is the default address of the LAN 
modem itself.

• Do not use 192.168.yyy.2 since it is used as the default address 
for the PC linked to the LAN modem for configuration.

• The subnet mask should be 255.255.255.224. 
• Start the value yyy at 1 for the first site and increase up to 253. 

Site 254 is reserved for Display Station. This scheme allows up to 
29 recorders at up to 253 separate sites. For other IP address and 
subnet configurations please consult your network administrator.

• The router IP must be set to the address of the local LAN modem. 
The default value of this is 192.168.yyy.1. For auto-call, the IP 
address must be the same as the one defined for the PC running 
Display Station. The Auto-call On/Off button must be on (colored 
green).

Setup a 3Com Device Connected to the DS32 Computer
This procedure sets up a 3Com device connected to the DS32 computer. 
A standard modem is still needed. This DS32 PC 3Com LAN modem is 
used when Autocall is required.

To perform this procedure:

1. Boot the computer with the 3Com LAN modem device connected via 
the network cable connection.
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2. Click Networking Dialup Connections and Figure C.2 appears.

Figure C.2  Network and Dial-up Connections

3. Click Make a New Connection and Figure C.3 appears.

Figure C.3  Local Area Connection

4. Click Local Area Connection and Figure C.4 appears.

Figure C.4  Local Area Connection Status
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5. Click Properties and Figure C.5 appears.

Figure C.5  Local Area Connection Properties

6. Click Internet Protocol TCP/IP, click Properties and Figure C.6 
appears.

Figure C.6  Internet Protocol (TCP/IP) Properties

7. Click both Obtain an IP address automatically, Obtain DNS server 
address automatically and click OK.
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Set up the 3Com LAN Modem attached to the DS32 PC
To perform this procedure:

1. Press the reset button located on the back of the 3Com device and 
hold it. While you hold it, the alert light must goes through three sets 
of flashing. This takes around 30 seconds minimum. This sets the 
3Com LAN modem device to the factory default settings.

2. Reboot the attached PC open Windows Internet Explorer. Figure C.7 
appears.

Figure C.7  No Valid Service Providers

3. Click Continue and Figure C.8 appears.

Figure C.8  ISP Wizard

4. Click Abort and Figure C.9 appears.
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Figure C.9  3Com LAN Modem Wizard

5. Click Service Providers and Figure C.10 appears.

Figure C.10  Service Providers
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6. Select New (Private Network), click Select and Figure C.11 appears.

Figure C.11  Private Network Parameters

7. Enter the:

a. Name, and Telephone Number of the sub-station that you will 
call.

b. User ID and Password in Security you entered into the remote 
sub-station 3Com LAN modem that calls in.

c. Sub-station IP’s address in DNS IP address for the sub-station 
3Com LAN modem that calls in.

8. Scroll down and configure the Private Network Parameters and 
Callback Parameters as per Figure C.12.

The Private Network Parameters are the same are the same as the 
DNS IP and the subnet is always the same 255.255.255.224. In 
Figure C.12, it is 255.255.255.0, this is incorrect, the last part of the 
Subnet Mask must always be 224.
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Figure C.12  Private Network Parameters

9. Scroll down and configure the Miscellaneous Parameters 
(Figure C.13 and Figure C.40):

a. Enable the intelligent NAT by clicking Yes.
b. Click No for Do yo want to use this Private Network for 

accessing the Internet. 
c. Click Yes for Use PPP Data Compression.
d. Enter the WAN Link IP Address as the IP address of the 3Com 

LAN modem attached to the DS32 PC.
e. Enter the Default Workstation name (lower on Figure C.12) 

which is the name of the attached PC and setting up the cur-
rent 3Com LAN modem.

f. Click Submit and the main window reappears.
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Figure C.13  Private Network DNS Misc. Parameters I

10. Click Workstation Parameters and Figure C.14 appears.

Figure C.14  Workstation Parameters

11. Enter the IP address 192.168.1.2, which is the IP address of the DS32 
PC. On this 3Com LAN modem, none of the IP address’s have to be 
reserved.

12. Click Submit and the main window reappears.
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Add the Required Autocall Information to the DS32 - 3Com LAN modem
This procedure adds the information of the remote sub-station 3Com 
LAN modems that will call the 3Com LAN modem attached to the DS32 
PC.

To perform this procedure:

1. Click Dial-In on the main window and Figure C.15 appears.

Figure C.15  Dial-In User Selection

2. Click Dial-In User and select New dial in user under User Name: and 
Figure C.16 and Figure C.17 appears.

Figure C.16  Dial In User Parameters I
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Figure C.17  Dial In User Parameters II

3. Configure this window by:

a. Entering the same Name and Password that you entered in the 
remote sub-station 3Com LAN modem that will call in.

b. Configuring the IP network information for the local 3Com 
LAN modem, which by default is always 192.168.1.1.

c. Entering the Remote LAN IP address, which is the remote 
3Com LAN modem’s IP address.

d. Entering the Primary DNS, which is always the same as the 
LAN modem WAN IP address.

e. Click Submit and the main window reappears.
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4. Click Dial in Global and Figure C.18 appears.

Figure C.18  Dial In Global Parameters

5. Configure this window by:

a. Setting Auto Answer to 1.
b. Click PAP, CHAP, and MS-CHAP to activate them.
c. Click Submit.
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Setup the DS32 Computer’s Network “NIC” Card.
This procedure sets up the DS32’s PC internal NIC card, which is 
attached directly to the 3Com LAN modem. This gives the DS32’s PC a 
static IP address, that can be used with autocall. 

To perform this procedure:

1. Open the Local Area Connection Status window (Figure C.19).

Figure C.19  Local Area Connection Status

2. Click Properties and set the DS32 computer’s (PC) 3Com modem’s IP 
address and Subnet mask as shown in Figure C.20. In this case, the 
Default gateway is always the 3Com LAN modem attached to the PC. 

Figure C.20  Internet Protocol (TCP/IP) Properties
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Set Up the Master Station DS32 for Use with the 3Com LAN Modem
To perform this procedure:

1. Open DS32 and Figure C.21 appears.

Figure C.21  DS32 Main Window

2. Select Edit > Recorder network from the pull down. 

The Recorder Network – Edit window appears (Figure C.22).

Figure C.22  Recorder Network - Edit

Under Recorder Network you can have multiple Regions. For 
example, you could have a North, South, East, and West Region. Or 
you could have a region broken down into Counties If it’s not a 
concern or you only have a few recorders, you can just use the 
Default New Region and place all of your locations under that.

3. Add a new Location by right-clicking on the Region and selecting 
Add new Location. The Location is basically the name of the 
sub-station or sub-station area.
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4. Add recorders under the Location by right-clicking on the Location 
and selecting Add recorder.

As you add the Locations and recorders, you can right click on each 
one of them and select Rename location or Rename recorder to 
change each name. Once you have added your Location and the 
transient recorders under it, you are ready to add the details of the 
recorder. 

5. Select the new TR and right-click on it to change it’s recorder 
information (Figure C.23).

Figure C.23  Recorder Details - Modem Tab

6. Select the Recorder Type for this TR.

7. Click TCP/IP in Autopoll Uses.

8. Click the TCP/IP tab and Figure C.24 appears.

Figure C.24  Recorder Details - TCP/IP Tab
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9. Enter the TR’s IP address and make sure that you do not change 
Dial-Up Networking if you have already selected an item from the 
other setup menu. This will normally always have something listed 
here, if you are also using a bonded async type modem.

Set Up the First Remote Sub-station 3Com LAN Modem
This procedure sets up the 3Com device at the sub-station that is separate 
from the DS32 PC with the async modem setup. 

To perform this procedure:

1. Set up the computer that you plan to use to configure the 3Com 
device per the following instructions:

a. Double-click the Networking dialup connections icon 
(Figure C.25).

Figure C.25  Networking Dialup Connections Icon

b. Double-click the Local Area connection icon (Figure C.26). 
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Figure C.26  Local Area Connection Icon

The Local Area Connection Status window appears (Figure C.27).

Figure C.27  Local Area Connection Status

c. Click Properties and Figure C.27 appears.

Figure C.28  Local Area Connection Properties
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d. Click Internet Protocol (TCP/IP) and then click Properties 
and Figure C.29 appears.

Figure C.29  Internet Protocol (TCP/IP) Properties

2. Click Obtain an IP address automatically and Obtain DNS server 
address automatically and click OK.

The PC is now ready to communicate to the 3Com LAN modem that 
is hooked up to the Transient Recorders at the sub-station. Windows 
Internet Explorer is used for all communications to the 3Com LAN 
modem. The next procedure guides you through that.

Set Up the Remote Sub-station 3Com LAN Modem
To perform this procedure:

1. Press the reset button located on the back of the 3Com device and 
hold it. While you hold it, the alert light must goes through three sets 
of flashing. This takes around 30 seconds minimum. This sets the 
3Com LAN modem device to the factory default settings.

2. Reboot the computer if you are using Windows 2000 and open 
Window’s Internet Explorer. Normally you do not need to reboot 
Windows XP in this case. Once you open Window’s Internet Explorer, 
Figure C.30 appears.
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Figure C.30  No Valid Service Providers

3. Click Continue and Figure C.8 appears.

Figure C.31  ISP Wizard

4. Click Abort and Figure C.9 appears.
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Figure C.32  3Com LAN Modem Wizard

5. Click Dial-In and Figure C.33 appears.

Figure C.33  3Com Dial-In User Parameters

6. Configure this window as follows:

• The name and password must match the setup from what you 
entered on the Network Connection Wizard window. 

• Set all of the following pages with the correct IP addresses for 
your application.

• The name and password must match the case you entered in the 
Setup Wizard.

• Router to Router must be selected, and Data Compression must 
be checked. 

• The Idle Timer is set high, that the modem does not hang up if it 
sees a break in data transfer. 
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7. Scroll down and set the following parameters (Figure C.34):

Figure C.34  3Com WAN Parameters

• LAN Modem WAN IP: This is the remote sub-station’s 3Com’s 
LAN modem’s IP address. This is normally the first sub-station that 
you set up. The second sub-station LAN modem’s address is 
normally 192.168.3.1, etc.

• Remote Lan IP: This is the IP address (by default) of the PC 
running DS32 (by way of DHCP).

• Remote Lan IP Subnet Mask: This is the default Subnet mask and 
should be used for all 3Com LAN modems or devices talking to 
them. If you do not use this mask and attempt to go beyond the 
limit of the 3Com device, the 3Com device will not work.

• Primary DNS: This is the same IP address as the Remote Lan IP 
address. 

8. Click Submit. 

NOTE Always click Submit before changing screens.

9. Click Dial-In Global and Figure C.35 appears.
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Figure C.35  3Com Global Parameters

10. Configure Dial-In Global Parameters:

• Change Auto Answer to the 1
• Click the check boxes for PAP, CHAP and MS-CHAP.
• Click Submit

11. Click Service Providers from the main window and Figure C.36 
appears.

Figure C.36  3Com Service Provider Selection
1086-339  Rev. A   11/05 C-23



DS32 3Com/Remote TR 3Com LAN Modem Connection Configuration (Autocall)
12. Click New (Private Network) and click Select and Figure C.11 
appears.

Figure C.37  Private Network Parameters

13. Enter the:

a. Name that will call in. In our previous examples we used AMS 
and/or AMS1 as a default name for all locations. In our exam-
ple, we are only using one user name and password, at the PC 
and at the 3Com LAN modems, but this does not have to be 
the case. 

b. Telephone number if you have another 3Com LAN modem at 
the PC running DS32. This phone number is used for Auto-
calling only, and is not used if you are only using a 3Com 
LAN modem at the remote sub-station locations.

c. User ID and Password that you entered under the Network 
Connection Wizard.

14. Scroll down and configure the DNS parameters (Figure C.38):

a. Enter the Domain Name Service IP address. This is by default 
192.168.1.1. 

b. The Private Network Parameters are the same with the default 
Subnet Mask.

c. Increase the Callback Delay to at least 5 and the Callback 
Timeout to around 90.
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Figure C.38  Private Network DNS Parameters I

15. Scroll down and configure the Miscellaneous Parameters 
(Figure C.13 and Figure C.40):

a. IP address of the Remote sub-station 3Com LAN modem that 
you are currently setting up.

b. The Subnet Mask is always the default Subnet mask.
c. The Default Workstation is the PC that is setting up the 

attached 3Com LAN modem.
d. Enable the intelligent NAT by clicking Yes.

Figure C.39  Private Network DNS Misc. Parameters I
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Figure C.40  Private Network DNS Misc. Parameters II

16. Click Submit and the 3Com OfficeConnect Lan Modem Web Wizard 
window reappears (Figure C.9 on page C-7).

17. Click Workstation Config and Figure C.41appears.

Figure C.41  3Com Workstation Parameters

18. Reserve the static IP Addresses for the recorders and the PC that 
connects to it for future changes:

• 192.168.2.2 is the PC’s IP address that is currently connected to 
it. This is handed out by default by DHCP to the PC by default.

• 192.168.2.3 is the IP address of the first recorder attached
• 192.168.2.4 is the second recorder.

Only the recorders IP address need to reserved.
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19. Click Submit.

The main 3Com LAN Modem default window reappears 
(Figure C.9 on page C-7).

20. Click Data Call Parameters and Figure C.42 appears. Enter 
parameters as per the figure.

Figure C.42  3Com Data Call Parameters

For Disconnect an outgoing automatic data call after how long of an 
inactivity period, we have set a value of 900 seconds. In some cases 
this may be too long of a value and can be reduced if needed.

21. Click Submit and the main window reappears 
(Figure C.9 on page C-7).
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22. Click LAN Parameters and Figure C.43 appears.

Figure C.43  3Com LAN (Ethernet) Parameters

Configure this screen:

• Change the IP Address to the one that you plan on using for this 
sub-station. As always, enter the default Subnet Mask. To avoid 
setup problems, for the:
• First sub-station you would normally use 192.168.2.1.
• Second sub-station you would use 192.168.3.1, and follow 

this pattern for the rest.

When you change the LAN parameters IP or SUB MASK, it may be 
necessary to reboot your computer to communicate to the 3Com. As 
this will most likely put you on a different LAN, DHCP needs to issue 
a new IP address for your PC.
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Set Up the First Remote Transient Recorder
This procedure sets up sub-station A’s transient recorder #1’s IP address, 
Subnet Mask, and Router’s address, using DS32.

To perform this procedure:

1. Open DS32 and connect to the first transient recorder using the direct 
connect option and the RS232 direct connect cable.

2. Navigate to the Recorder Configuration window (Figure C.44).

Figure C.44  3Com Recorder Configuration

3. Click Peripherals and Figure C.45 appears.

Figure C.45  3Com Recorder Peripherals
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4. Enter the IP Address for that recorder. The default IP Subnet Mask 
always remains the same.

5. Enter the Router IP Addr, the IP address of the router to which the 
transient recorder attaches.

6. Click OK and click Setup. You can now disconnect from this unit and 
proceed to the next unit.

Set Up the Second Remote Transient Recorder
To perform this procedure:

1. Move the RS232 cable to the next transient recorder and connect to it 
using DS32 and the direct connect option with the RS232 direct 
connect cable.

2. Navigate to the Recorder Configuration window (Figure C.46).

Figure C.46  3Com Recorder Configuration
C-30 1086-339  Rev. A   11/05



Fault Recorder Operations Manual
3. Click Peripherals and Figure C.47 appears.

Figure C.47  3Com Recorder Peripherals

4. Enter the IP Address for that recorder. The default IP Subnet Mask 
always remains the same.

5. Enter the Router IP Addr, the IP address of the router to which the 
transient recorder attaches.

6. Click OK and click Setup. You can now disconnect from this unit and 
proceed to the next unit.

Set Up the DS32 Transient Recorders for Autocall
Figure C.48 shows the default DS32 main window.

Figure C.48  DS32 Main Window
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To perform this procedure:

1. Select System > Auto-poll/call and Figure C.49 appears.

Figure C.49  Recorder Autopoll

The majority of this window is for autopolling, which we are not 
concerned with at this point in time. In the upper right hand corner of 
the window, note the word incoming in Automatic record 
downloading (Auto poll & incoming). This word applies to DS32 
Autocall or Autocalling options.

2. Select the type of records you want retrieved by Autocall and what 
type of data.

3. Set up the Autocall TRs by selecting Edit – Recorder Network on the 
main window Figure C.48 and appears.

Figure C.50  Recorder Network - Configure

4. Select the Location and the Recorder that you want to assign the 
Autocall option (Figure C.51).
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Figure C.51  Recorder Network - Configure Location

You could also do this online while connected to the recorder. In this 
example, we are setting up Autocall off line. When it is set up off line, 
you are required to call up or to connect to the TR and download the 
configuration.

5. Open the Recorder Configuration window (Figure C.52) and click 
Peripherals.

Figure C.52  Recorder Configuration

The Recorder Peripherals window appears (Figure C.53).

Figure C.53  Recorder Peripherals
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6. Enter the IP Address of the DS32 PC’s 3Com LAN modem in Auto 
Call.

7. Click the Auto Call ON/OFF button if you want this TR to Autocall 
each time a new record is captured.
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Telephone/Fax Number List
Use these numbers for ordering equipment, application assistance, 
technical support, and scheduling field service

NOTE Your instruction manual may contain other phone and fax numbers; this 
list takes precedence.

MAIN OFFICE

AMETEK Power Instruments – Rochester

255 North Union St., Rochester, NY 14605

FAR EAST OFFICE

AMETEK Power Instruments
271 Bukit Timah Road, #03-09
Balmoral Plaza, Singapore 259708
Tel: 65-732-8675
Fax: 65-732-8676

UK OFFICE

AMETEK Power Instruments
Unit 20, Ridgeway
Donibristle Industrial Estate
Dunfermline, UK
Tel: 1383-825630

Fax: 1383-825715

Table D.1  Ametek Main Office Contact Numbers

Department/Product Line Telephone Fax

MAIN PHONE 585-263-7700 585-262-4777

FIELD SERVICE 800-374-4835 585-238-4945

REPAIRS/RETURNS 888-222-6282 585-238-4945

SALES SUPPORT 800-950-6676 585-454-7805
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Appendix E.  TR-2000 Application Note 
Synchrophasor Output to IEEE P37.118

This document describes the implementation of the standard P37.118 as 
used in the AMETEK TR-2000 recorder and should be read in 
conjunction with the standard itself and tries to follow formats used 
there. You should also consult the AMETEK Display Station Operation 
Manual and the TR-2000 User Guide for further information. For 
information on installing the new recorder firmware, if this is required, 
consult the AMETEK Recorder Firmware Upgrade guide.

The synchrophasor output provides data via the COM2 port located at 
the rear of the instrument. Enable the output by setting DIL switch 2/6 on 
the master acquisition card within the instrument. 

Data output is provided in three forms viz: header, configuration and 
data frames. Of these the data frames are output spontaneously at a rate 
pre-defined by the transmission period setting. The configuration and 
header frames are output on command from the receiving device. There 
are some restrictions on the full range of output options allowed for in the 
standard. The exact frame formats and limitations used are detailed 
below.

Baud rate data selection and other set up parameters are entered via the 
Display Station package. The settings are found at the Phasor Display tab 
under Input Channel Selection. Note that this is only shown if the 
instrument is set for synchrophasor output via the switch. The parameters 
available include Header, Station Name, Identity, Baud rate and data 
transmission Period. Display Station also allows selection of the phasor, 
analog and digital data to be transmitted. The Baud rate may be selected 
from 9600, 19200, 38400 and 57600. Period may be selected from 
20mS at 50Hz or 16.66mS at 60Hz to 1S per data frame. Display Station 
will also check that the transmission period and quantity of data 
requested are compatible with the available baud rate.

This is a factory fitted option for the TR-2000.
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Table E.1  Data Frame (Spontaneous Output)

No Field Size Value
 (if fixed)

Comment

1 SYNC 2 AA01 Synchronization byte followed
by frame type and version 
number. Note that the version 
number is 01

2 FRAMESIZE 2 Number of bytes in frame 
including SYNC and CRC. (132
max)

3 SOC 4 Second count. (UNIX time, 
starting midnight 01-Jan-1970).

4 FRASEC 4 Bits 0-23 contain fraction of 
second sample time related to 
the MEAS_RATE parameter in 
the configuration frame.

5 STAT 2 Bit mapped flags. Bit 14 is set 
by a PMU error. Bit 13 is set by
a sync error. Other bits are not 
included in this 
implementation.

6 PHASORS 4 x PHNMR Phasors are in signed 16-bit 
rectangular format Polar and 
floating-point options are not 
supported. This reflects the 
internal formats of the MFR. 
The phasors included are 
selected by the Display Station
package. Up to 10 may be 
included. Note that the data 
transmitted is the Positive Phase
Sequence, current or voltage

7 FREQ 2 Frequency deviation (signed 
16-bit only, Hz * 1000)

8 DFREQ 2 Rate of change of frequency 
(signed 16-bit only, Hz/S * 100
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9 ANALOG 2 x ANNMR This field holds 16-bit RMS 
representations of the MFR 
inputs. The values included are
selected by Display Station 
package. Up to 32 may be 
included.

10 DIGITAL (2 x 
DGNMR)
 / 16

This field holds digital input 
data. Note that this field is 
compacted with 16 inputs per 
word.

11 CHK 2 CRC16

Table E.2  Configuration Frame (On Command)

No Field Size (bytes) Value 
(if fixed)

Short Description

1 SYNC 2 0xAA21
0xAA31

Synchronization byte 
followed by frame type and 
version number. Since the 
MFR has only one 
configuration available this 
implementation responds to 
both configuration type 
requests with the same 
frame except the SYNC 
word.

2 FRAMESIZE 2 Number of bytes in frame 
including SYNC and CRC 
(max 2046)

3 SOC 4 Second count. (UNIX time, 
starting midnight 
01-Jan-1970).

4 D_FRAME 2 0x0000 Data frame format. This is 
fixed as including a CRC16 

Table E.1  Data Frame (Spontaneous Output) (Continued)
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5 MEAS_RATE 4 Number of samples per 
second, used for time 
stamping the data frame. In 
this implementation this is 
based on the primary rate of 
phasor calculation within 
the MFR i.e. once per half 
cycle. (100 or 120)

6 NUM_PMU 2 0x0001 The number of PMUs 
included in the data frame. 
This is fixed at 1 in this 
implementation

7 STN 16 Station Name – 16 bytes in 
ASCII format

8 IDCODE 8 8 bytes in ASCII – PMU 
hardware identification.

9 FORMAT 2 0x000C Data format within the data 
frame. Fixed as first sample 
sync, rotating phasors, 
16-bit and rectangular in 
this implementation.

10 PHNMR 2 Number of phasors – 16-bit 
integer. Maximum is 10.

11 ANNMR 2 Number of analogue values 
– 16-bit integer. Maximum 
is 32.

12 DGNMR 2 Number of digital channels 
– 16-bit integer. Maximum 
is 64.

13 CHNAM 16 x 
(PHNMR + 
ANNMR + 
DGNMR)

Phasor and channel names 
– 16 bytes per phasor, 
analog and digital channel 
in ASCII format in the same 
order as they are transmitted

Table E.2  Configuration Frame (On Command) (Continued)
E-4 1086-339  Rev. A   11/05



Fault Recorder Operations Manual
14 PHUNIT 4 x 
PHNMR

Conversion factor for phasor 
channels. Bit 24 =1 for 
current. Bits 0-23 in Amps 
or Volts*105

15 ANUNIT 4 x 
ANNMR

Conversion factor for analog 
channels. Bit 24 =1 for 
current. Bits 0-23 in Amps 
or Volts*105

16 DIGUNIT 2 x 
DGNMR

Conversion factor for digital 
channels. Bit 4 – Word 
normal state. Bit 0 – Input 
normal state.

17 FNOM 2 Nominal line frequency 
code for 50/60 Hz. In this 
implementation FREQ and 
DFREQ are always included 
in the data frame. Bit 0 = 1 
for 50Hz.

18 PERIOD 2 Period of phasor data 
transmissions. Signed 16-bit 
number in cycles * 100. 
Minimum of once per cycle 
to once per second.

19 CHK 2 CRC16

Table E.3  Header Frame (On Command)

No Field Size (bytes) Value 
(if fixed)

Short Description

1 SYNC 2 AA11 Synchronization byte 
followed by frame type and 
version number.

2 FRAMESIZE 2 Number of bytes in frame 
including SYNC and CRC

Table E.2  Configuration Frame (On Command) (Continued)
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3 SOC 4 Second count. (UNIX time, 
starting midnight 
01-Jan-1970).

4 DATA 1 1 ASCII character, 1st byte

N-1 DATA k 1 ASCII character, last byte in 
message
In this implementation the 
maximum is 2038

N CHK 2 CRC16

Table E.3  Header Frame (On Command) (Continued)

Table E.4  Command Frame (Incoming)

No Field Size (bytes) Value 
(if fixed)

Short Description

1 SYNC 2 0xAA41 Synchronization byte followed 
by frame type and version 
number.

2 FRAMESIZE 2 0x0014 Number of bytes in frame 
including SYNC and CRC. 

3 SOC 4 Second count. (UNIX time, 
starting midnight 01-Jan-1970).

4 IDCODE 8 Corresponding to that in the 
configuration frame

5 CMD 2 Command Number – see 
Table E.5

6 CHK 2 CRC16
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Table E.5  Commands Implemented

Command Word Bits Definition

Bits 15-4 Reserved for future use

Bits 3-2-1-0:

0001 Turn off real-time data

0010 Turn on real-time data

0011 Send HDR frame

0100 Send CFG – 1 frame

0101 Send CFG - 2 frame 

1000 Not Implemented
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	a. Using the spinners to select a Line Group Channel.


	Buttons and Fields
	1. Click Cross triggering and the Cross triggering dialog appears (Figure 2.99).
	1. Click Operating limits and the Trigger limits dialog appears.

	Buttons and Fields
	Buttons and Fields
	Buttons and Fields
	Phasor group components
	Buttons and Fields
	Buttons and Fields
	1. Click RealTimeDisplay and the Real Time Display window appears (Figure 2.106).
	1. Select Recorder > PQR Set-up Wizard.

	Button and Fields
	Network Parameters
	Buttons and Fields
	1. Select Manual trigger and the Manual trigger dialog appears (Figure 2.115).

	Buttons and Fields
	Trigger Information
	Cameo record
	1. Select Transient Records and the Record selection dialog appears (Figure 2.118).

	Buttons and Fields
	1. Select Harmonic Records and the Harmonics Data Available On Connected Recorder dialog appears (Figure 2.121).

	Buttons and Fields
	Retrieval Parameters
	1. Select Logger Records and the Logger Data Available On Connected Recorder dialog appears (Figure 2.123).

	Buttons and Fields
	1. Select Disturbance Records and the Record selection dialog appears (Figure 2.126).

	Buttons and Fields
	1. Select Disturbance Logger Records and the Disturbance Logger Data Available On Connected Recorder dialog appears (Figure 2.130).



	View Menu
	Buttons and Fields
	Button and Fields

	Database Menu
	Update File Links
	Repair
	Compact
	Create Archive
	Buttons and Fields
	1. Select Database > Create Archive.

	Buttons and Fields
	1. Select Database > Import Archive.




	3. Display Station Analysis 32 Menus and Operations
	Graph Window Operations
	Status Bar
	Bands
	1. Switch on the cursors.
	1. Select it as the active channel in the band and the Active sub-channel list is filled with entries for Phase A, Phase B and Phase C.
	Buttons and Fields
	1. Select Setup from a right-click menu and the dialog appears (Figure 3.4).


	Display Manipulation
	1. Click between the toolbar buttons and drag it out into the DSA32 window.
	Docking a window
	1. Click on the title bar of the toolbar and drag it to the inside edge of the DSA32 window. Dock it to any side - top, bottom, left or right.

	Pan a record
	Zoom a record
	1. Press <Ctrl> and use the wheel.

	Adjust the gain
	1. Place the mouse pointer over a channel label (the hand cursor appears) the wheel scales that channel or band (see ”Band Settings” on page 3-7).
	1. Double-click on the symbol and the record details appear



	Warning Messages
	Phase Group Classification
	Graph Menu
	Open Record
	1. Open a new record by either:
	1. Click the appropriate button:

	Open File
	1. Select Graph > Open file.

	Close
	CSV Export
	Buttons and Fields
	1. Select CSV Export.


	COMTRADE Export
	Buttons and Fields
	1. Select COMTRADE Export.


	New Graph/Setup
	Buttons and Fields
	1. Click to create a new graph or select Graph > New Graph.
	a. Add the first channel.


	Buttons and Fields
	Phasor Displays
	1. Click Phasor Display and the Phasor Display Setup dialog appears (Figure 3.21).
	a. Selecting the display from the drop down list at the top of the window.

	1. Select the display.


	Setup Colors
	Buttons and Fields
	1. Select Graph > Color and the Colour Setup dialog appears (Figure 3.25).
	1. Click Load and the Load Colour settings dialog appears.
	1. Click Save and the Save Colour settings dialog appears.
	1. Click a name in Items, then click Edit Color.
	1. Click Define Custom Colors.
	1. Double-click on the channel name in the main window or select Setup on the channel’s right-click menu and the Band Settings dialog appears (Figure 3.26).


	Reclassify
	Print/Print Preview/Print Setup
	1. Select Graph > Print Setup and a standard Print Setup dialog appears (Figure 3.27).
	Buttons and Fields

	Exit
	1. Select Graph > Exit and DSA shuts down.


	Edit Menu
	Copy

	View Menu
	Record Header
	Buttons and Fields

	Analogue Profile
	1. Select View > Analog Profile and the Analog Fault levels dialog appears (Figure 3.31).

	Digital Profile
	1. Select View > Digital Profile and the Digital Transitions dialog appears (Figure 3.32).

	Main Toolbar/Status Toolbar/Status Bar
	Preferences
	Fields and Buttons
	1. Select View > Preferences and the Preferences dialog appears (Figure 3.35).



	Power Analysis Toolkit (PAT) Menu
	Fundamental Frequency
	Buttons and Fields
	1. Select PAT > Fundamental Frequency or click .


	Single Channel
	Buttons and Fields
	1. Ensure cursors are active. All PAT calculations are carried out on the samples between the cursors. If the cursors are not active, no values appear.


	Power
	Buttons and Fields
	1. Ensure cursors are active. All PAT calculations are carried out on the samples between the cursors. If the cursors are not active, no values appear.
	a. Clicking Phase group and the dialog appears (Figure 3.43).



	Sequence Components
	Buttons and Fields
	1. Ensure cursors are active. All PAT calculations are carried out on the samples between the cursors. If the cursors are not active, no values appear.
	a. Clicking Phase group and the dialog appears (Figure 3.47).
	a. Clicking Phasor and the dialog appears (Figure 3.48).



	Harmonics
	Buttons and Fields
	1. Ensure cursors are active. All PAT calculations are carried out on the samples between the cursors. If the cursors are not active, no values appear.



	Channels Menu
	Combined Channels
	Buttons and Fields
	1. Select Channels > Combined Channels and the Combined Channel dialog appears (Figure 3.54).
	a. Selecting up to three channels using the drop downs.
	a. Selecting a channel from Channels.



	Single Channel Quantities
	Buttons and Fields
	1. Select Channels > Single Channel Quantities and the dialog appears (Figure 3.57).


	Average
	Buttons and Fields
	1. Select Channels > Average and the dialog appears (Figure 3.59).


	Sequence Components
	Buttons and Fields
	1. Select Channels > Sequence Components and the dialog appears (Figure 3.61).


	Star/Delta Conversion
	Buttons and Fields
	1. Select Channels > Star/Delta Conversion and the dialog appears (Figure 3.65).


	Line Group Quantities
	Buttons and Fields
	1. Select Channels > Group Quantities and the dialog appears (Figure 3.67).


	Phase Group Angles
	Buttons and Fields
	1. Select Channels > Phase Group Angles and the dialog appears (Figure 3.67).


	Differential Phase Angle
	Buttons and Fields
	1. Select Channels > Differential Phase Angle and the dialog appears (Figure 3.71).


	New Phase Group
	Buttons and Fields
	1. Select Channels > New Phase Group and the dialog appears (Figure 3.73).


	Import Channels
	Buttons and Fields
	1. Select Channels > Import channels.


	Synchronize Imports
	Buttons and Fields
	1. Select Channels > Synchronize Imports.
	1. Select Channels > Synchronize Imports.


	Long Term Flicker (Plt)
	Buttons and Fields
	1. Select Channels > Long Term Flicker.



	Tools Menu
	Options Menu
	Show Analog Labels
	Show Digital Labels
	Show Phasors
	Show Annotations
	Time Axis
	1. Move the center of the icon to the start of the region of interest and press and hold the left mouse button.

	Cursors
	Add Annotation
	To add an annotation on the active graph:
	1. Click either:

	Repositioning and annotation


	Windows Menu
	Cascade Windows
	Tile Horizontally
	Tile Vertically
	Arrange Icons
	Save Layout
	Buttons and Fields
	To save the layout of the active record:
	1. Select Windows > Save Layout.


	Delete Layout
	Buttons and Fields
	1. Select Windows > Delete Layout.


	Close All
	Close All but Current

	Help Menu
	Help Topics
	About DSA32

	System Information

	Appendix A. Expert System
	Expert System Introduction
	Expert System Operation - Background
	RMS Graphs Window
	Buttons and Fields
	Buttons and Fields
	1. Select Graph > Setup Graph.
	a. Click a button and the Color dialog appears.
	a. Click Enable Automatic Graph Creation, if required.

	1. Click Graph > Save Graph and a standard Save As dialog appears.



	Distance to Fault Introduction
	Breaker Performance Monitor Introduction
	Volt Dips Analysis Introduction
	Expert System Menus
	Graph Plots
	1. Open the window by:

	Classify Fault
	Buttons and Fields
	1. Click either:


	Export Switchgear
	Export Dips
	Save Outputs
	1. Select Save Outputs and a Save As dialog appears.

	Print Outputs
	1. Select Print Outputs and a Print dialog appears.


	Substation Menu
	1. Click Phase Groups and the dialog appears (Figure A.12).
	a. Clicking Phase group and the dialog appears (Figure A.13).

	Edit/Create Details
	Buttons and Fields
	1. Add a circuit. See ”Edit Circuits” on page A-24.

	Buttons and Fields
	1. Click Circuits on the Substation Details window.

	Buttons and Fields
	1. Click Advanced on the Substation Details window.

	Buttons and Fields
	1. Click Neutrals and the Neutral Inputs dialog appears (Figure A.18)

	Button and Fields
	1. Configure the Circuit Breaker Details by:
	1. Click DTF on the Substation Detail window and the DTF - Transmission Line Model Details appears (Figure A.20).



	Edit Menu
	Copy Outputs
	1. Select Edit > Copy Outputs.


	Help Menu
	Help
	About

	Distance to Fault Menus and Windows
	Select Single Circuit
	Buttons and Fields
	1. Click Select Single Circuit and the Select Transmission Circuit ID window appears (Figure A.28).


	Calculate DTF
	1. Ensure that a model is created or selected. See ”Substation model” on page A-37.

	Fault Parameters
	Buttons and Fields
	1. Click Fault Parameters and the Fault parameters window appears (Figure A.30).


	Circuits
	1. Click Circuits and the Transmission Circuits window appears (Figure A.31 on page -42).

	Exit DTF

	Voltage Dips Analysis Main Window
	Buttons and Fields
	1. Click the appropriate radio button.

	Details
	Buttons and Fields
	1. Double-click on a record in the main window.



	System Menu
	Find Records
	Buttons and Fields
	1. Click on the Voltage Dips icon or select it from the Start menu.


	Options
	Buttons and Fields
	1. Open Options by:


	Choose/Edit Limits
	Buttons and Fields
	Dips
	Surges
	1. Open Limit Curve by:


	Bar Chart Set Up
	Buttons and Fields
	Retention
	Duration
	1. Open Bar Chart Setup by:


	Print Preview/Print Record List/Print Setup
	Exit

	Database Menu
	Archive Records
	1. Select Database > Archive Records.

	Append Records
	1. Select Database > Append Records.

	Compact Database
	1. Select Database > Compact Database.


	Edit Menu
	Copy record list

	Help Menu
	Graph Window
	Voltage Dips Graph Window Menus
	1. Click Graph > Save Graph.
	1. Click Graph > Look.
	1. Click Graph > Footer Text.
	1. Click Graph > Color.
	1. Click Graph > Z-Axis Scaling.


	BPM Main Window
	Buttons and Fields
	1. Click the check boxes, as required:

	Operation Details
	Buttons and Fields
	1. Select a specific record in the Operations window record list.


	Set Service Date
	Buttons and Fields
	1. Enter a Location name.



	System Menu
	Set Edit Password
	1. Select System > Set edit password and if there is an old password a dialog appears, click OK.

	Archive
	1. Select System > Archive.

	Print

	View Menu
	Operations/Contact Wear

	Help Menu
	Step-by-Step Guide
	1. Select the ESDemo3 from the Display Station main window and double-click it. This record details window appears.
	a. Click the Neutral inputs check box and choose NONE for Voltage and 8 In for Current.
	a. Select Expert > Graph Plots.



	Appendix B. 3Com 56k LAN Modem Configuration: Manual and Autopolling
	Set Up the DS32 Computer 3Com Modem to Transient Recorder 3Com Remote Station
	Windows 2000 Configuration
	1. Click Make a New Connection to start the setup wizard (Figure B.3).

	Windows XP Configuration
	1. Click Start and select Connect To and select Show all connections from the pop up (Figure B.11).


	Set up the DS32 Master Station for Use with the Async Modem
	1. Open DS32 and select Edit > Recorder Network (Figure B.24).
	a. Click the TCP/IP tab


	Set Up the First Remote Sub-station 3Com LAN Modem
	1. Set up the computer that you plan to use to configure the 3Com device:
	a. Double-click the Networking dialup connections icon (Figure B.27).

	1. Press the reset button located on the back of the 3Com device and hold it. While you hold it, the alert light must goes throu...
	a. Name that calls in. In our previous examples we used AMS and/or AMS1 as a default name for all locations. In our example, we are only using one user name and password at the PC and at the 3Com LAN modems, but this does not have to be the case.
	a. Enter the Domain Name Service IP address. This is by default 192.168.1.1.
	a. IP address of the Remote sub-station 3Com LAN modem that you are currently setting up.


	Set Up the First Remote Transient Recorder
	1. Open DS32 and connect to the first transient recorder using the direct connect option and the RS232 direct connect cable.

	Set Up the Second Remote Transient Recorder
	1. Move the RS232 cable to the next transient recorder and connect to it using DS32 and the direct connect option with the RS232 direct connect cable.


	Appendix C. DS32 3Com/Remote TR 3Com LAN Modem Connection Configuration (Autocall)
	Set Up the Recorders
	Setup a 3Com Device Connected to the DS32 Computer
	1. Boot the computer with the 3Com LAN modem device connected via the network cable connection.
	Set up the 3Com LAN Modem attached to the DS32 PC
	1. Press the reset button located on the back of the 3Com device and hold it. While you hold it, the alert light must goes throu...
	a. Name, and Telephone Number of the sub-station that you will call.
	a. Enable the intelligent NAT by clicking Yes.


	Add the Required Autocall Information to the DS32 - 3Com LAN modem
	1. Click Dial-In on the main window and Figure C.15 appears.
	a. Entering the same Name and Password that you entered in the remote sub-station 3Com LAN modem that will call in.
	a. Setting Auto Answer to 1.



	Setup the DS32 Computer’s Network “NIC” Card.
	1. Open the Local Area Connection Status window (Figure C.19).
	Set Up the Master Station DS32 for Use with the 3Com LAN Modem
	1. Open DS32 and Figure C.21 appears.


	Set Up the First Remote Sub-station 3Com LAN Modem
	1. Set up the computer that you plan to use to configure the 3Com device per the following instructions:
	a. Double-click the Networking dialup connections icon (Figure C.25).

	Set Up the Remote Sub-station 3Com LAN Modem
	1. Press the reset button located on the back of the 3Com device and hold it. While you hold it, the alert light must goes throu...
	a. Name that will call in. In our previous examples we used AMS and/or AMS1 as a default name for all locations. In our example, we are only using one user name and password, at the PC and at the 3Com LAN modems, but this does not have to be the case.
	a. Enter the Domain Name Service IP address. This is by default 192.168.1.1.
	a. IP address of the Remote sub-station 3Com LAN modem that you are currently setting up.


	Set Up the First Remote Transient Recorder
	1. Open DS32 and connect to the first transient recorder using the direct connect option and the RS232 direct connect cable.

	Set Up the Second Remote Transient Recorder
	1. Move the RS232 cable to the next transient recorder and connect to it using DS32 and the direct connect option with the RS232 direct connect cable.


	Set Up the DS32 Transient Recorders for Autocall
	1. Select System > Auto-poll/call and Figure C.49 appears.


	Appendix D. Contact List
	Telephone/Fax Number List

	Appendix E. TR-2000 Application Note Synchrophasor Output to IEEE P37.118
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